summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/scream/Manifest1
-rw-r--r--media-sound/scream/scream-3.9.ebuild43
-rw-r--r--media-sound/scream/scream-9999.ebuild4
3 files changed, 46 insertions, 2 deletions
diff --git a/media-sound/scream/Manifest b/media-sound/scream/Manifest
index 7f7de9727a58..b3e52d7a1dfc 100644
--- a/media-sound/scream/Manifest
+++ b/media-sound/scream/Manifest
@@ -1 +1,2 @@
DIST scream-3.8.tar.gz 1114613 BLAKE2B 7c178477bbe2e1079394319657ff5bef2cacddb7ebbac0c527ff676ebd1fb66c4f00cff6578202deda96baa78d1d3a95a994e658d2bc893f10a3f3f13cf3d2eb SHA512 0ec3e68177a5852528b8dc0eed35088c7b399a59762063c5f08e06581340884123d37aebcedc0534acfb0ab0702c2d6dfc033cfcbf6d7e80faf8963ab0827983
+DIST scream-3.9.tar.gz 1114518 BLAKE2B f7ae8ca69bc786fdb8055b2d1d5cd8fb9350c147465e1d75936defba8ea630351b4a559e508ef3b1f3bbd24d9b2bf96b6450577c7e5e334aacfd54f71efc5928 SHA512 83cb5b9daca82395b955fc8e01be4a466c6ebcc3839179c47912a78294ca98abed3833b6c636632a37e9d944750f56680a2a55975376756d183c9ed9b1d3dede
diff --git a/media-sound/scream/scream-3.9.ebuild b/media-sound/scream/scream-3.9.ebuild
new file mode 100644
index 000000000000..8c7ed7611cf1
--- /dev/null
+++ b/media-sound/scream/scream-3.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Plays sound received from network or from a QEMU Windows VM"
+HOMEPAGE="https://github.com/duncanthrax/scream"
+S="${WORKDIR}/${P}/Receivers/unix"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/duncanthrax/scream.git"
+else
+ SRC_URI="https://github.com/duncanthrax/scream/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Ms-PL"
+SLOT="0"
+IUSE="alsa jack pcap pulseaudio"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ jack? (
+ media-libs/soxr
+ virtual/jack
+ )
+ pcap? ( net-libs/libpcap )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DALSA_ENABLE=$(usex alsa)
+ -DJACK_ENABLE=$(usex jack)
+ -DPCAP_ENABLE=$(usex pcap)
+ -DPULSEAUDIO_ENABLE=$(usex pulseaudio)
+ )
+ cmake_src_configure
+}
diff --git a/media-sound/scream/scream-9999.ebuild b/media-sound/scream/scream-9999.ebuild
index 82133a82fe29..8c7ed7611cf1 100644
--- a/media-sound/scream/scream-9999.ebuild
+++ b/media-sound/scream/scream-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake