summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/onionrouter/Manifest1
-rw-r--r--net-mail/onionrouter/onionrouter-0.6.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/onionrouter/Manifest b/net-mail/onionrouter/Manifest
index 5ed7784056bd..1ecf64b1152c 100644
--- a/net-mail/onionrouter/Manifest
+++ b/net-mail/onionrouter/Manifest
@@ -1 +1,2 @@
DIST onionrouter-0.6.0.tar.gz 26525 BLAKE2B 59d0709d3d0344422840b89908aedb97a0b869208d9f5e690bede317f0fe20a11ff1f2f2fac11a7827736ddc5e6d27ce6b12cd9395a82f31f7bb51ab4ca511c1 SHA512 251228e677ca1df182e943d692060d5ad83bcaf407c31e30eeb71e9f581d7140eb4edc8f00f7baa47e6561a5457c0f10b25e5c581902aaca7906780a2b8dc69c
+DIST onionrouter-0.6.1.tar.gz 26584 BLAKE2B e1d722ba4e7ec617e39fda54299cd71d9d47bbd34fd44a19ffef8f2349f9b238251b47d01c369223393a9d7f2e0a05c5d8b7dc9f991c7d386ba800086b8cc226 SHA512 5d08e7a7310e69e29eaba2098a62cef4b5044c207f4a78b4cfebfd2a9d18bd812b485793ff7395186d4949ad9604b4e82dc0e9b1200abf03108466bf531a6d15
diff --git a/net-mail/onionrouter/onionrouter-0.6.1.ebuild b/net-mail/onionrouter/onionrouter-0.6.1.ebuild
new file mode 100644
index 000000000000..2efd032bc84b
--- /dev/null
+++ b/net-mail/onionrouter/onionrouter-0.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+DESCRIPTION=".onion discovery via SRV DNS lookups for use with postfix"
+HOMEPAGE="https://pypi.org/project/onionrouter/ https://github.com/ehloonion/onionrouter/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ehloonion/onionrouter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://pypi.io/packages/source/${PN::1}/${PN}/${P}.tar.gz"
+fi
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="$(python_gen_cond_dep '
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+')"
+BDEPEND="$(python_gen_cond_dep '
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ insinto /etc/onionrouter
+ doins "${S}/onionrouter/configs/onionrouter.ini"
+}