summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/ceph-18.2.4-r2.ebuild1
-rw-r--r--sys-cluster/ceph/ceph-19.2.0.ebuild3
-rw-r--r--sys-cluster/ceph/files/ceph-18.2.4-spdk.patch13
3 files changed, 17 insertions, 0 deletions
diff --git a/sys-cluster/ceph/ceph-18.2.4-r2.ebuild b/sys-cluster/ceph/ceph-18.2.4-r2.ebuild
index f23e56039cf6..9684c2b6a87a 100644
--- a/sys-cluster/ceph/ceph-18.2.4-r2.ebuild
+++ b/sys-cluster/ceph/ceph-18.2.4-r2.ebuild
@@ -234,6 +234,7 @@ PATCHES=(
"${FILESDIR}/ceph-18.2.1-gcc14.patch"
"${FILESDIR}/ceph-18.2.1-gcc14-2.patch"
"${FILESDIR}/ceph-18.2.4-liburing.patch"
+ "${FILESDIR}/ceph-18.2.4-spdk.patch"
)
check-reqs_export_vars() {
diff --git a/sys-cluster/ceph/ceph-19.2.0.ebuild b/sys-cluster/ceph/ceph-19.2.0.ebuild
index 05634a309b86..24a94bc4b788 100644
--- a/sys-cluster/ceph/ceph-19.2.0.ebuild
+++ b/sys-cluster/ceph/ceph-19.2.0.ebuild
@@ -230,6 +230,7 @@ PATCHES=(
# https://bugs.gentoo.org/936889
"${FILESDIR}/ceph-18.2.1-gcc14.patch"
"${FILESDIR}/ceph-18.2.4-liburing.patch"
+ "${FILESDIR}/ceph-18.2.4-spdk.patch"
)
check-reqs_export_vars() {
@@ -289,6 +290,8 @@ src_prepare() {
if use spdk; then
# https://bugs.gentoo.org/871942
sed -i 's/[#]ifndef HAVE_ARC4RANDOM/#if 0/' src/spdk/lib/iscsi/iscsi.c || die
+ # unittests fail to build (??!?)
+ sed -i -e 's/CONFIG_UNIT_TESTS=y/CONFIG_UNIT_TESTS=n/' src/spdk/CONFIG || die
fi
# remove tests that need root access
diff --git a/sys-cluster/ceph/files/ceph-18.2.4-spdk.patch b/sys-cluster/ceph/files/ceph-18.2.4-spdk.patch
new file mode 100644
index 000000000000..27fb3c6eaa89
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-18.2.4-spdk.patch
@@ -0,0 +1,13 @@
+diff --git a/cmake/modules/BuildSPDK.cmake b/cmake/modules/BuildSPDK.cmake
+index d6ce97e..0c49e05 100644
+--- a/cmake/modules/BuildSPDK.cmake
++++ b/cmake/modules/BuildSPDK.cmake
+@@ -51,6 +51,8 @@ macro(build_spdk)
+ --with-dpdk=${DPDK_DIR}
+ --without-isal
+ --without-vhost
++ --disable-tests
++ --disable-unit-tests
+ --target-arch=${target_arch}
+ # unset $CFLAGS, otherwise it will interfere with how SPDK sets
+ # its include directory.