From 012c170099daadbb84ff4bdbf48be33398ace0a6 Mon Sep 17 00:00:00 2001
From: Andrew Savchenko <bircoph@gentoo.org>
Date: Wed, 18 May 2016 12:20:36 +0300
Subject: app-text/sdcv: fix bug 583386

1. When USE="nls", but intersection of LINGUAS with PLOCALES is
zero, $BUILD_DIR/locale is not created, thus cmake generated build
fails install phase. Fixed by always creating this directory.

2. Remove dodoc useless in EAPI=6: we have only default doc files.

Package-Manager: portage-2.3.0_rc1
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
---
 app-text/sdcv/sdcv-0.5.0_beta2-r1.ebuild | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/app-text/sdcv/sdcv-0.5.0_beta2-r1.ebuild b/app-text/sdcv/sdcv-0.5.0_beta2-r1.ebuild
index 21fea92c4444..ef684bbb8319 100644
--- a/app-text/sdcv/sdcv-0.5.0_beta2-r1.ebuild
+++ b/app-text/sdcv/sdcv-0.5.0_beta2-r1.ebuild
@@ -58,6 +58,9 @@ src_compile() {
 }
 
 src_install() {
+	# with USE=nls, but empty intersection of LINGUAS and list of
+	# supported translations, this directory is required, see bug 583386
+	# failure is ok here (e.g. if dir exists)
+	mkdir "${BUILD_DIR}/locale"
 	cmake-utils_src_install
-	dodoc AUTHORS NEWS
 }
-- 
cgit v1.2.3-65-gdbad