From 4d7197ad5d12014ff208d9a8af9d4f10142516ee Mon Sep 17 00:00:00 2001
From: Michał Górny <mgorny@gentoo.org>
Date: Sun, 1 Aug 2021 08:42:27 +0200
Subject: dev-python/pycdio: Bump to 2.1.1
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Michał Górny <mgorny@gentoo.org>
---
 dev-python/pycdio/Manifest            |  1 +
 dev-python/pycdio/pycdio-2.1.1.ebuild | 40 +++++++++++++++++++++++++++++++++++
 2 files changed, 41 insertions(+)
 create mode 100644 dev-python/pycdio/pycdio-2.1.1.ebuild

(limited to 'dev-python/pycdio')

diff --git a/dev-python/pycdio/Manifest b/dev-python/pycdio/Manifest
index 2a11f3cf0079..2ea8c840bd43 100644
--- a/dev-python/pycdio/Manifest
+++ b/dev-python/pycdio/Manifest
@@ -1 +1,2 @@
 DIST pycdio-2.1.0.tar.gz 241434 BLAKE2B eb981fdf52b205e14c6dd353ac4aca9a9e82dba6967a53b9059f8a265ef80832fe7236d68b2af7a6e408665fce0f5ed3541289e0b7d282834c4feb8e6b428fc4 SHA512 dc18fbd212f7040b8b06efaf263b17568e9c2d089cff7dfc4dda50a7225059e44c9c86e2d81ade92cf09c823f7189b5723fb601cb12f0884dc04e9f5418c5927
+DIST pycdio-2.1.1.tar.gz 246562 BLAKE2B 7dbbf384f9d70aade922172c6dd070229c1ffc65a76a491c45f91ec176bced9af0dc0e08f50f8ad78828273de14166eae886b402f282a10bdad3f8302276ef01 SHA512 4c756b1c2f39332add86e01af129ccb608178306be42c9719c163b6bad0ba4de3916ac477c6866450890e094b14a2689a24e7d19bcf13846330555c2bb1feaa7
diff --git a/dev-python/pycdio/pycdio-2.1.1.ebuild b/dev-python/pycdio/pycdio-2.1.1.ebuild
new file mode 100644
index 000000000000..635e1a54c837
--- /dev/null
+++ b/dev-python/pycdio/pycdio-2.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python OO interface to libcdio (CD Input and Control library)"
+HOMEPAGE="https://savannah.gnu.org/projects/libcdio/ https://pypi.org/project/pycdio/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="dev-lang/swig"
+DEPEND=">=dev-libs/libcdio-2.0.0"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+	# Remove obsolete sys.path and adjust 'data' paths in examples.
+	sed -i \
+		-e "s:^sys.path.insert.*::" \
+		-e "s:\.\./data:./data:g" \
+		example/*.py || die
+	distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+	distutils-r1_python_install_all
+	if use examples; then
+		docinto examples
+		dodoc -r example/.
+		docompress -x /usr/share/doc/${PF}/examples
+	fi
+}
-- 
cgit v1.2.3-65-gdbad