From f46394d65f26b4fbcbe16aec44997c180b9a9cc5 Mon Sep 17 00:00:00 2001
From: Jakov Smolic <jakov.smolic@sartura.hr>
Date: Sat, 20 Feb 2021 17:13:50 +0100
Subject: net-misc/mstpd: Multiple spanning tree protocol daemon

* mstpd is an user-space daemon that implements RSTP and MSTP protocols

Bug: https://github.com/mstpd/mstpd/issues/105
Closes: https://github.com/gentoo/gentoo/pull/19359
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr>
Signed-off-by: David Seifert <soap@gentoo.org>
---
 net-misc/mstpd/Manifest           |  1 +
 net-misc/mstpd/metadata.xml       | 15 +++++++++++++++
 net-misc/mstpd/mstpd-0.0.9.ebuild | 26 ++++++++++++++++++++++++++
 3 files changed, 42 insertions(+)
 create mode 100644 net-misc/mstpd/Manifest
 create mode 100644 net-misc/mstpd/metadata.xml
 create mode 100644 net-misc/mstpd/mstpd-0.0.9.ebuild

(limited to 'net-misc/mstpd')

diff --git a/net-misc/mstpd/Manifest b/net-misc/mstpd/Manifest
new file mode 100644
index 000000000000..364e28eec594
--- /dev/null
+++ b/net-misc/mstpd/Manifest
@@ -0,0 +1 @@
+DIST mstpd-0.0.9.tar.gz 113711 BLAKE2B 93ff0213a634fcbbb613c79227d737c3961f4de669e0ac2c7351fa1c22842669edc652ba0deb24917a44df5a465a4e905a98e46ab7ccc7e4ebfd13039e6acfe0 SHA512 1d4a926d8437b7c41c69d2a047718181ca6245f3150e4aeb631f437edaaafe0c40b29802a6c9ea38c9f1dfb1b94149934b473f550358be10bb796295fa632e1e
diff --git a/net-misc/mstpd/metadata.xml b/net-misc/mstpd/metadata.xml
new file mode 100644
index 000000000000..359cbebb4676
--- /dev/null
+++ b/net-misc/mstpd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+	<maintainer type="person">
+		<email>jakov.smolic@sartura.hr</email>
+		<name>Jakov Smolic</name>
+	</maintainer>
+	<maintainer type="project">
+		<email>proxy-maint@gentoo.org</email>
+		<name>Proxy Maintainers</name>
+	</maintainer>
+	<upstream>
+		<remote-id type="github">mstpd/mstpd</remote-id>
+	</upstream>
+</pkgmetadata>
diff --git a/net-misc/mstpd/mstpd-0.0.9.ebuild b/net-misc/mstpd/mstpd-0.0.9.ebuild
new file mode 100644
index 000000000000..adbcac48da08
--- /dev/null
+++ b/net-misc/mstpd/mstpd-0.0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 systemd
+
+DESCRIPTION="Multiple spanning tree protocol daemon"
+HOMEPAGE="https://github.com/mstpd/mstpd"
+SRC_URI="https://github.com/mstpd/mstpd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+	default
+	eautoreconf
+}
+
+src_configure() {
+	econf \
+		--with-bashcompletiondir="$(get_bashcompdir)" \
+		--with-systemdunitdir="$(systemd_get_systemunitdir)" \
+		--localstatedir="${EPREFIX}"/var
+}
-- 
cgit v1.2.3-65-gdbad