summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2004-06-06 17:16:06 +0000
committerSteve Arnold <nerdboy@gentoo.org>2004-06-06 17:16:06 +0000
commit66064a8247d887162a4de948462e5a976f0a54ed (patch)
tree4e34691d56836f8188e9251d777dc4d988aa40df
parentstable on amd64 (diff)
downloadhistorical-66064a8247d887162a4de948462e5a976f0a54ed.tar.gz
historical-66064a8247d887162a4de948462e5a976f0a54ed.tar.bz2
historical-66064a8247d887162a4de948462e5a976f0a54ed.zip
bump to x86, corrected depend, added fortran einfo
-rw-r--r--app-sci/udunits/ChangeLog5
-rw-r--r--app-sci/udunits/Manifest12
-rw-r--r--app-sci/udunits/udunits-1.12.1.ebuild17
3 files changed, 23 insertions, 11 deletions
diff --git a/app-sci/udunits/ChangeLog b/app-sci/udunits/ChangeLog
index 61c71cb18262..e6197519a6f9 100644
--- a/app-sci/udunits/ChangeLog
+++ b/app-sci/udunits/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-sci/udunits
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/udunits/ChangeLog,v 1.8 2004/05/12 19:10:48 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/udunits/ChangeLog,v 1.9 2004/06/06 17:16:06 nerdboy Exp $
+
+ 06 Jun 2004; Steve Arnold <nerdboy@gentoo.org> udunits-1.12.1.ebuild:
+ bump to x86, corrected depend, added einfo
12 May 2004; Bryan Østergaard <kloeri@gentoo.org> udunits-1.12.0.ebuild:
Stable on alpha.
diff --git a/app-sci/udunits/Manifest b/app-sci/udunits/Manifest
index 1353087d4e94..a037d4f26730 100644
--- a/app-sci/udunits/Manifest
+++ b/app-sci/udunits/Manifest
@@ -1,10 +1,10 @@
-MD5 37a94d90585b1bc584ecd8a8713ff044 udunits-1.12.1.ebuild 1557
-MD5 176a9013a3fbf4d813fbe2ae5c54b409 metadata.xml 583
-MD5 eb50b491fd3e15a97d10824b27f7ec75 ChangeLog 1218
MD5 755794c3afe485217dd818c97d1bec9c udunits-1.12.0.ebuild 1881
+MD5 683e362aef6116c5fed2a1a44c8e44c9 ChangeLog 1337
+MD5 176a9013a3fbf4d813fbe2ae5c54b409 metadata.xml 583
+MD5 c4f61ce17429b55c71344fdd1df6d681 udunits-1.12.1.ebuild 1944
+MD5 922ab296149176fd2c78ebf4654916ee files/udunits_configure_in.patch 241
+MD5 5b85e692f66a2a74d7c4e1d74a729e23 files/udunits_lib_make.patch 895
+MD5 c4058b93662ad2beab9763c8120c85f4 files/udunits_master_mk.patch 1234
MD5 cea4faba4689abec3805139902ddd0d2 files/digest-udunits-1.12.0 65
MD5 3fdb828dd9ab28f5f06e2456b1c96c65 files/digest-udunits-1.12.1 65
MD5 3dc5d09377cb0326220d293cec108569 files/udunits_customize.patch 375
-MD5 5b85e692f66a2a74d7c4e1d74a729e23 files/udunits_lib_make.patch 895
-MD5 c4058b93662ad2beab9763c8120c85f4 files/udunits_master_mk.patch 1234
-MD5 922ab296149176fd2c78ebf4654916ee files/udunits_configure_in.patch 241
diff --git a/app-sci/udunits/udunits-1.12.1.ebuild b/app-sci/udunits/udunits-1.12.1.ebuild
index baf28cca4c8e..b41cab6b10ec 100644
--- a/app-sci/udunits/udunits-1.12.1.ebuild
+++ b/app-sci/udunits/udunits-1.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/udunits/udunits-1.12.1.ebuild,v 1.1 2004/05/08 22:14:35 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/udunits/udunits-1.12.1.ebuild,v 1.2 2004/06/06 17:16:06 nerdboy Exp $
inherit eutils
@@ -14,11 +14,12 @@ SRC_URI="ftp://unidata.ucar.edu/pub/udunits/udunits-${PV}.tar.Z"
SLOT="0"
LICENSE="UCAR-Unidata"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~mips ~hppa"
-DEPEND="dev-lang/perl"
+DEPEND="dev-lang/perl
+ sys-apps/sed"
-RDEPEND="${DEPEND}"
+RDEPEND="dev-lang/perl"
src_unpack() {
unpack ${A}
@@ -65,3 +66,11 @@ src_install() {
dodoc COPYRIGHT README RELEASE_NOTES VERSION CUSTOMIZE INSTALL
}
+
+pkg_postinst() {
+ ewarn "This package requires a Fortran compiler for maximum utility."
+ ewarn "For now, make sure you have at least g77 for the f77 interface."
+ ewarn "The internal configure should detect many f77 compilers, however,"
+ ewarn "if you have the PG compiler you will need to change the above"
+ ewarn "preprocessor macro to something like -Dpgifortran."
+}