summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-03-18 09:50:12 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-03-18 09:50:12 +0000
commit52805b3ec0488dc8cfea8c0f5a0ac87582ce7828 (patch)
tree817be3a778bbf8e808155028d1d8686c67692104 /app-office
parentRemove old (diff)
downloadhistorical-52805b3ec0488dc8cfea8c0f5a0ac87582ce7828.tar.gz
historical-52805b3ec0488dc8cfea8c0f5a0ac87582ce7828.tar.bz2
historical-52805b3ec0488dc8cfea8c0f5a0ac87582ce7828.zip
Fix detecting python cflags and libs until there is nice eclass call for it. Force due to unsynced tree.
Package-Manager: portage-2.2.0_alpha166/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0x8EEE3BE8
Diffstat (limited to 'app-office')
-rw-r--r--app-office/libreoffice/ChangeLog7
-rw-r--r--app-office/libreoffice/libreoffice-4.0.9999.ebuild6
-rw-r--r--app-office/libreoffice/libreoffice-9999-r2.ebuild6
3 files changed, 12 insertions, 7 deletions
diff --git a/app-office/libreoffice/ChangeLog b/app-office/libreoffice/ChangeLog
index 9609c1a67071..054d150d32f7 100644
--- a/app-office/libreoffice/ChangeLog
+++ b/app-office/libreoffice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/libreoffice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.451 2013/03/17 21:02:54 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/ChangeLog,v 1.452 2013/03/18 09:50:12 scarabeus Exp $
+
+ 18 Mar 2013; Tomáš Chvátal <scarabeus@gentoo.org> libreoffice-4.0.9999.ebuild,
+ libreoffice-9999-r2.ebuild:
+ Fix detecting python cflags and libs until there is nice eclass call for it.
+ Force due to unsynced tree.
17 Mar 2013; Mark Wright <gienah@gentoo.org>
+files/libreoffice-4.0.1.2-boost-1.53.0.patch, libreoffice-4.0.1.2.ebuild:
diff --git a/app-office/libreoffice/libreoffice-4.0.9999.ebuild b/app-office/libreoffice/libreoffice-4.0.9999.ebuild
index 55c742f135f3..802ea1c83656 100644
--- a/app-office/libreoffice/libreoffice-4.0.9999.ebuild
+++ b/app-office/libreoffice/libreoffice-4.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.0.9999.ebuild,v 1.23 2013/03/12 21:22:49 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-4.0.9999.ebuild,v 1.24 2013/03/18 09:50:12 scarabeus Exp $
EAPI=5
@@ -408,8 +408,8 @@ src_configure() {
# System python 2.7 enablement:
export PYTHON="${PYTHON}"
- export PYTHON_CFLAGS=`pkg-config --cflags ${EPYTHON}`
- export PYTHON_LIBS=`pkg-config --libs ${EPYTHON}`
+ export PYTHON_CFLAGS=`pkg-config --cflags python-${EPYTHON#python}`
+ export PYTHON_LIBS=`pkg-config --libs python-${EPYTHON#python}`
# system headers/libs/...: enforce using system packages
# --enable-unix-qstart-libpng: use libpng splashscreen that is faster
diff --git a/app-office/libreoffice/libreoffice-9999-r2.ebuild b/app-office/libreoffice/libreoffice-9999-r2.ebuild
index dbc258e5ce4c..9eb0ca598153 100644
--- a/app-office/libreoffice/libreoffice-9999-r2.ebuild
+++ b/app-office/libreoffice/libreoffice-9999-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.165 2013/03/13 14:03:57 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/libreoffice/libreoffice-9999-r2.ebuild,v 1.166 2013/03/18 09:50:12 scarabeus Exp $
EAPI=5
@@ -408,8 +408,8 @@ src_configure() {
fi
# System python 2.7 enablement:
- export PYTHON_CFLAGS=`pkg-config --cflags ${EPYTHON}`
- export PYTHON_LIBS=`pkg-config --libs ${EPYTHON}`
+ export PYTHON_CFLAGS=`pkg-config --cflags python-${EPYTHON#python}`
+ export PYTHON_LIBS=`pkg-config --libs python-${EPYTHON#python}`
# system headers/libs/...: enforce using system packages
# --enable-unix-qstart-libpng: use libpng splashscreen that is faster