summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 03:26:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-01 03:26:54 +0000
commit03ed1adc4d22910150f07eb89140adc83bc90d81 (patch)
tree7fb3ece433aadf116e83e5d7b6a65ed2497a440d /app-text
parentVersion bump. (diff)
downloadhistorical-03ed1adc4d22910150f07eb89140adc83bc90d81.tar.gz
historical-03ed1adc4d22910150f07eb89140adc83bc90d81.tar.bz2
historical-03ed1adc4d22910150f07eb89140adc83bc90d81.zip
Use PYTHON_DEPEND instead of NEED_PYTHON. Simplify src_test().
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pytextile/ChangeLog6
-rw-r--r--app-text/pytextile/Manifest4
-rw-r--r--app-text/pytextile/pytextile-2.1.4.ebuild20
3 files changed, 14 insertions, 16 deletions
diff --git a/app-text/pytextile/ChangeLog b/app-text/pytextile/ChangeLog
index a7ac6acb4aa3..f93a29bb686d 100644
--- a/app-text/pytextile/ChangeLog
+++ b/app-text/pytextile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/pytextile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.23 2010/01/20 18:01:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/ChangeLog,v 1.24 2010/07/01 03:26:54 arfrever Exp $
+
+ 01 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ pytextile-2.1.4.ebuild:
+ Use PYTHON_DEPEND instead of NEED_PYTHON. Simplify src_test().
20 Jan 2010; <hwoarang@gentoo.org> pytextile-2.1.4.ebuild:
Stable on amd64 wrt bug #300240
diff --git a/app-text/pytextile/Manifest b/app-text/pytextile/Manifest
index 9478eda93047..5ed413f71d87 100644
--- a/app-text/pytextile/Manifest
+++ b/app-text/pytextile/Manifest
@@ -1,4 +1,4 @@
DIST textile-2.1.4.tar.gz 13664 RMD160 1840fe08d01261bbf57fa7eee82e2401308ece42 SHA1 dea3d1f465de3de3d69017a07c57d2b55ce500da SHA256 ca1b14ee4bd34cb72fc95e2960f4e591fc9d019196d7a1dfeaa17ca9ece89632
-EBUILD pytextile-2.1.4.ebuild 944 RMD160 ea4dd4bedf54fda11acb78aa86db1b235808df86 SHA1 f528f4cb6f3f67560ea2c156bf298757ddc10d4b SHA256 a7fbd572f3d03cf5fab180c00ab2403bca0e36b868aaf157948c8e9b3072a9d3
-MISC ChangeLog 2950 RMD160 6e1829c1cec9ce42c6b7839be5465f7bad0d5066 SHA1 085da6cb8680ffc1818a2fb7ad9d9e5d33697cf6 SHA256 38b312abac90cbc9ce66cc042aae07ed4fa89d02df7892a2d7019b82311b749c
+EBUILD pytextile-2.1.4.ebuild 822 RMD160 309c4e2ca029f35aa9b416b63a1875b0f62b3927 SHA1 7a104c294850eddcc850055e09fee14e5fd0ef35 SHA256 a1c48cf32391a5cf3e3e863f89aab90d922210c4adf9c556f51163c87d58103e
+MISC ChangeLog 3115 RMD160 8561120919e6c48fc3ddf1bd56ab60cead1469a6 SHA1 51d2a63377e1a649531f969281375a85abd064fb SHA256 d161ade3d88bec45bb1cd8e30901582833a7ddab0a5b7ed2144dc3ce08964daa
MISC metadata.xml 334 RMD160 63a01644e4421aff527e9f9745dddac39a635c24 SHA1 9ba72a23eb77924ad8762521591875c8784779fa SHA256 205ee562bf70acc0677b45b8904bae78ca777730fc2f51f3d48502e7c9a70db1
diff --git a/app-text/pytextile/pytextile-2.1.4.ebuild b/app-text/pytextile/pytextile-2.1.4.ebuild
index 4b10c4cd8349..f3ee0b3e7e5f 100644
--- a/app-text/pytextile/pytextile-2.1.4.ebuild
+++ b/app-text/pytextile/pytextile-2.1.4.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.1.4.ebuild,v 1.5 2010/01/20 18:01:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pytextile/pytextile-2.1.4.ebuild,v 1.6 2010/07/01 03:26:54 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
-NEED_PYTHON="2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
inherit distutils
@@ -18,19 +20,11 @@ SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.ta
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="test"
+IUSE=""
-DEPEND="test? ( dev-python/nose )"
+DEPEND=""
RDEPEND=""
-RESTRICT_PYTHON_ABIS="2.4 3.*"
S="${WORKDIR}/${MY_P}"
PYTHON_MODNAME="${MY_PN}"
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}