summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-10-23 00:49:31 +0000
committerAron Griffis <agriffis@gentoo.org>2003-10-23 00:49:31 +0000
commitbabee42ab5b5b7852b0f1eaf53035779f433c571 (patch)
treef609e4c280282e6d1fda91825f1ba5b05850b731 /app-text
parentstable on alpha (diff)
downloadhistorical-babee42ab5b5b7852b0f1eaf53035779f433c571.tar.gz
historical-babee42ab5b5b7852b0f1eaf53035779f433c571.tar.bz2
historical-babee42ab5b5b7852b0f1eaf53035779f433c571.zip
stable on alpha
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gpdf/ChangeLog5
-rw-r--r--app-text/gpdf/Manifest4
-rw-r--r--app-text/gpdf/gpdf-0.111.ebuild11
3 files changed, 14 insertions, 6 deletions
diff --git a/app-text/gpdf/ChangeLog b/app-text/gpdf/ChangeLog
index 99bdb77289aa..0f01fb522a9a 100644
--- a/app-text/gpdf/ChangeLog
+++ b/app-text/gpdf/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for app-text/gpdf
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/ChangeLog,v 1.11 2003/10/22 16:59:12 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/ChangeLog,v 1.12 2003/10/23 00:49:28 agriffis Exp $
22 Oct 2003; Bartosch Pixa <darkspecter@gentoo.org> gpdf-0.110.ebuild:
set ppc in keywords
+ 22 Oct 2003; Aron Griffis <agriffis@gentoo.org> gpdf-0.111.ebuild:
+ Fix compilation on alpha by adding -fPIC
+
*gpdf-0.111 (20 Oct 2003)
20 Oct 2003; Mike Gardiner <obz@gentoo.org> gpdf-0.111.ebuild:
diff --git a/app-text/gpdf/Manifest b/app-text/gpdf/Manifest
index 1cc645b76209..9203725384b1 100644
--- a/app-text/gpdf/Manifest
+++ b/app-text/gpdf/Manifest
@@ -1,6 +1,6 @@
-MD5 822665eb548f8e8cc91af5b542d55c49 ChangeLog 1498
+MD5 4bd83afecbd021ec6a9f7f851550406d gpdf-0.111.ebuild 802
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 b1dbdf1753af06626bb8c7561a27bf28 ChangeLog 1608
MD5 07e057826e94d1d0dbda35466a69dcb0 gpdf-0.110.ebuild 718
-MD5 10da9742618540e4fea399d0442dd293 gpdf-0.111.ebuild 713
MD5 fa41081733a009e00c9cbb0960bca296 files/digest-gpdf-0.110 63
MD5 96c5b6dd9f9aae8366ba4047fadacc6d files/digest-gpdf-0.111 63
diff --git a/app-text/gpdf/gpdf-0.111.ebuild b/app-text/gpdf/gpdf-0.111.ebuild
index 1b0f8e998c81..9982f0e8bafb 100644
--- a/app-text/gpdf/gpdf-0.111.ebuild
+++ b/app-text/gpdf/gpdf-0.111.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-0.111.ebuild,v 1.1 2003/10/20 14:46:12 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gpdf/gpdf-0.111.ebuild,v 1.2 2003/10/23 00:49:28 agriffis Exp $
-inherit gnome2
+inherit gnome2 flag-o-matic
DESCRIPTION="your favourite pdf previewer"
HOMEPAGE="http://www.gnome.org/"
@@ -10,7 +10,7 @@ LICENSE="GPL-2"
IUSE=""
SLOT="0"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc ~amd64"
+KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
RDEPEND=">=gnome-base/libgnomeui-2
>=gnome-base/libbonobo-2.2.1
@@ -24,3 +24,8 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0"
DOCS="AUTHORS CHANGES ChangeLog COPYING INSTALL NEWS README*"
+
+src_compile() {
+ use alpha && append-flags -fPIC
+ gnome2_src_compile
+}