summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2003-10-30 01:00:56 +0000
committerRob Cakebread <pythonhead@gentoo.org>2003-10-30 01:00:56 +0000
commitc7b72e916c2f7b1b34419a177b30ebfa345279f3 (patch)
tree54d064d0c15cc4269a0359f5c50cf6d365d947dc /dev-libs/ltxml/ltxml-1.2.5.ebuild
parentInitial commit (diff)
downloadhistorical-c7b72e916c2f7b1b34419a177b30ebfa345279f3.tar.gz
historical-c7b72e916c2f7b1b34419a177b30ebfa345279f3.tar.bz2
historical-c7b72e916c2f7b1b34419a177b30ebfa345279f3.zip
Initial commit
Diffstat (limited to 'dev-libs/ltxml/ltxml-1.2.5.ebuild')
-rw-r--r--dev-libs/ltxml/ltxml-1.2.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/ltxml/ltxml-1.2.5.ebuild b/dev-libs/ltxml/ltxml-1.2.5.ebuild
new file mode 100644
index 000000000000..3a350f148287
--- /dev/null
+++ b/dev-libs/ltxml/ltxml-1.2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ltxml/ltxml-1.2.5.ebuild,v 1.1 2003/10/30 01:00:47 pythonhead Exp $
+
+
+S="${WORKDIR}/${P}/XML"
+DESCRIPTION="Integrated set of XML tools and a developers tool-kit with C API"
+HOMEPAGE="http://www.ltg.ed.ac.uk/software/xml/"
+SRC_URI=ftp://ftp.cogsci.ed.ac.uk/pub/LTXML/${P}.tar.gz
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lang/perl"
+PV_MAJ="${PV:0:1}${PV:2:1}"
+
+src_compile() {
+ econf || die "configure failed"
+ emake all || die "make failed"
+}
+
+src_install() {
+ einstall \
+ datadir=${D}/usr/lib/${PN}${PV_MAJ} \
+ MANDIR=${D}/usr/share/man \
+ || die "make install failed"
+}
+