summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-12-25 12:07:27 +0000
committerFabian Groffen <grobian@gentoo.org>2010-12-25 12:07:27 +0000
commitb3a1849104a99f681fa1bf2c00a4e356733f6c6a (patch)
treeea8e41d05c3bcb3642650c881fb125b6d424f36b /dev-libs/ntl
parentbump dbus dep (diff)
downloadhistorical-b3a1849104a99f681fa1bf2c00a4e356733f6c6a.tar.gz
historical-b3a1849104a99f681fa1bf2c00a4e356733f6c6a.tar.bz2
historical-b3a1849104a99f681fa1bf2c00a4e356733f6c6a.zip
Bump EAPI=3 for Prefix, add support for Darwin, marked ~x86-linux, ~amd64-linux and ~ppc-macos, bug #341989
Package-Manager: portage-2.2.01.17422-prefix/cvs/Darwin powerpc
Diffstat (limited to 'dev-libs/ntl')
-rw-r--r--dev-libs/ntl/ChangeLog7
-rw-r--r--dev-libs/ntl/files/ntl-5.5.2-shared.patch8
-rw-r--r--dev-libs/ntl/ntl-5.5.2.ebuild18
3 files changed, 22 insertions, 11 deletions
diff --git a/dev-libs/ntl/ChangeLog b/dev-libs/ntl/ChangeLog
index 36f5ffbc3811..46b35c7b86de 100644
--- a/dev-libs/ntl/ChangeLog
+++ b/dev-libs/ntl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ntl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.20 2010/02/09 16:02:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.21 2010/12/25 12:07:27 grobian Exp $
+
+ 25 Dec 2010; Fabian Groffen <grobian@gentoo.org> ntl-5.5.2.ebuild,
+ files/ntl-5.5.2-shared.patch:
+ Bump EAPI=3 for Prefix, add support for Darwin, marked ~x86-linux,
+ ~amd64-linux and ~ppc-macos, bug #341989
09 Feb 2010; Pacho Ramos <pacho@gentoo.org> ntl-5.5.2.ebuild:
amd64 stable, bug 300655
diff --git a/dev-libs/ntl/files/ntl-5.5.2-shared.patch b/dev-libs/ntl/files/ntl-5.5.2-shared.patch
index cd832792e0d1..1ddd74507cf5 100644
--- a/dev-libs/ntl/files/ntl-5.5.2-shared.patch
+++ b/dev-libs/ntl/files/ntl-5.5.2-shared.patch
@@ -153,10 +153,14 @@
rm -rf small
@{LSHAR} - $(LIBTOOL) --mode=clean rm -f libntl.la *.lo #LSHAR
-@@ -549,3 +597,6 @@
+@@ -549,3 +597,10 @@
-+shared: DIRNAME $(SHOBJ)
++sharedso: DIRNAME $(SHOBJ)
+ $(LINK_CXX) $(PICFLAG) -shared -Wl,-soname,lib`cat DIRNAME`.so -o lib`cat DIRNAME`.so $(SHOBJ) $(GMP_OPT_LIBDIR) $(GMP_OPT_LIB) $(GF2X_OPT_LIBDIR) $(GF2X_OPT_LIB)
+ ln -s lib`cat DIRNAME`.so libntl.so
++
++shareddylib: DIRNAME $(SHOBJ)
++ $(LINK_CXX) $(PICFLAG) -dynamiclib -install_name $(LIBDIR)/lib`cat DIRNAME`.dylib -o lib`cat DIRNAME`.dylib $(SHOBJ) $(GMP_OPT_LIBDIR) $(GMP_OPT_LIB) $(GF2X_OPT_LIBDIR) $(GF2X_OPT_LIB)
++ ln -s lib`cat DIRNAME`.dylib libntl.dylib
diff --git a/dev-libs/ntl/ntl-5.5.2.ebuild b/dev-libs/ntl/ntl-5.5.2.ebuild
index 02320b839ee4..dd7653641ade 100644
--- a/dev-libs/ntl/ntl-5.5.2.ebuild
+++ b/dev-libs/ntl/ntl-5.5.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ntl-5.5.2.ebuild,v 1.5 2010/02/09 16:02:35 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ntl-5.5.2.ebuild,v 1.6 2010/12/25 12:07:27 grobian Exp $
-EAPI=2
-inherit toolchain-funcs eutils
+EAPI=3
+inherit toolchain-funcs eutils multilib
DESCRIPTION="High-performance and portable Number Theory C++ library"
HOMEPAGE="http://shoup.net/ntl/"
@@ -11,7 +11,7 @@ SRC_URI="http://www.shoup.net/ntl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="doc"
RDEPEND=">=dev-libs/gmp-4.3
@@ -27,7 +27,7 @@ src_prepare() {
cd ..
# enable compatibility with singular
epatch "$FILESDIR/${P}-singular.patch"
- # implement a call back framework ( submitted upstream)
+ # implement a call back framework (submitted upstream)
epatch "$FILESDIR/${P}-sage-tools.patch"
# sanitize the makefile and allow the building of shared library
epatch "$FILESDIR/${P}-shared.patch"
@@ -35,7 +35,7 @@ src_prepare() {
src_configure() {
perl DoConfig \
- PREFIX=/usr \
+ PREFIX="${EPREFIX}"/usr \
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" \
CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
@@ -49,12 +49,14 @@ src_compile() {
emake setup3 || die "emake setup failed"
sh Wizard on || die "Tuning wizard failed"
emake ntl.a || die "emake static failed"
- emake shared || die "emake shared failed"
+ local trg=so
+ [[ ${CHOST} == *-darwin* ]] && trg=dylib
+ emake shared${trg} || die "emake shared failed"
}
src_install() {
newlib.a ntl.a libntl.a || die "installation of static library failed"
- dolib.so lib*.so || die "installation of shared library failed"
+ dolib.so lib*$(get_libname) || die "installation of shared library failed"
cd ..
insinto /usr/include