summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-22 04:45:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-22 04:45:01 +0000
commit7e9ebc7180910220434bcaecf79e1802bdb751bb (patch)
tree608d9cc21f14660d04d42057a2ebec6d74c345a5 /dev-libs
parentfix Manifest (diff)
downloadhistorical-7e9ebc7180910220434bcaecf79e1802bdb751bb.tar.gz
historical-7e9ebc7180910220434bcaecf79e1802bdb751bb.tar.bz2
historical-7e9ebc7180910220434bcaecf79e1802bdb751bb.zip
Add fix for configure script from upstream.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/lsh/ChangeLog7
-rw-r--r--dev-libs/lsh/Manifest17
-rw-r--r--dev-libs/lsh/files/1.4.3-configure.patch12
-rw-r--r--dev-libs/lsh/files/1.4.3-gcc34.patch54
-rw-r--r--dev-libs/lsh/lsh-1.4.3-r1.ebuild16
5 files changed, 95 insertions, 11 deletions
diff --git a/dev-libs/lsh/ChangeLog b/dev-libs/lsh/ChangeLog
index 99eb6f080a49..7ba5b47fb661 100644
--- a/dev-libs/lsh/ChangeLog
+++ b/dev-libs/lsh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/lsh
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/lsh/ChangeLog,v 1.6 2004/07/17 09:42:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lsh/ChangeLog,v 1.7 2004/11/22 04:45:01 vapier Exp $
+
+ 21 Nov 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.4.3-configure.patch, files/1.4.3-gcc34.patch,
+ lsh-1.4.3-r1.ebuild:
+ Add fix for configure script from upstream.
17 Jul 2004; David Holm <dholm@gentoo.org> lsh-1.4.3-r1.ebuild:
Added to ~ppc.
diff --git a/dev-libs/lsh/Manifest b/dev-libs/lsh/Manifest
index 36842c7b6be8..af9dd8d4cbf5 100644
--- a/dev-libs/lsh/Manifest
+++ b/dev-libs/lsh/Manifest
@@ -1,4 +1,15 @@
-MD5 c7b0ca40fb2bf76b8e80daebba24ba06 ChangeLog 913
-MD5 6e5194f0459a3de92a94896f5c16d60a lsh-1.4.3-r1.ebuild 1337
-MD5 ff304a4da3f1a19a3da4d5c1d1382303 files/1.4.3-gcc34.patch 389
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 0defd3db16c62344e3806bfdad8a0bf7 ChangeLog 1091
+MD5 e8d16e734d637941c6ce77c577023bbe lsh-1.4.3-r1.ebuild 1401
MD5 12d8d84a70281a27cccb14cc8e2c83e2 files/digest-lsh-1.4.3-r1 62
+MD5 e2a988c83f0406d964502a58a4f58cd3 files/1.4.3-gcc34.patch 2002
+MD5 5e752fc7adf408a2f4a3fb4601132787 files/1.4.3-configure.patch 355
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFBoW8QHTu7gpaalycRApeEAKCdKyFje11Qmr/Nu88qcjsZU1nAdQCg9lRH
+oIrvVda7zw8dITrHrsv4F0U=
+=H4as
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/lsh/files/1.4.3-configure.patch b/dev-libs/lsh/files/1.4.3-configure.patch
new file mode 100644
index 000000000000..e8190931fde3
--- /dev/null
+++ b/dev-libs/lsh/files/1.4.3-configure.patch
@@ -0,0 +1,12 @@
+--- lsh-1.4.3/configure.ac.orig 2004-11-21 19:47:44.363105536 -0500
++++ lsh-1.4.3/configure.ac 2004-11-21 19:48:20.205656640 -0500
+@@ -406,7 +406,9 @@
+ AC_PATH_X
+
+ if test -z "$no_x" ; then
++ if test x"$x_includes" != x ; then
+ CPPFLAGS="$CPPFLAGS -I$x_includes"
++ fi
+ LDFLAGS="$LDFLAGS -L$x_libraries"
+ LSH_RPATH_ADD($x_libraries)
+ fi
diff --git a/dev-libs/lsh/files/1.4.3-gcc34.patch b/dev-libs/lsh/files/1.4.3-gcc34.patch
index 302bb4db7471..37c35c0978a1 100644
--- a/dev-libs/lsh/files/1.4.3-gcc34.patch
+++ b/dev-libs/lsh/files/1.4.3-gcc34.patch
@@ -12,3 +12,57 @@
sftp_get_mem_main(next, msg, id, in, out, state );
+--- lsh-1.4.3/src/argp/argp.h.orig 2004-11-21 18:26:53.256585824 -0500
++++ lsh-1.4.3/src/argp/argp.h 2004-11-21 18:27:08.438277856 -0500
+@@ -554,13 +554,13 @@
+ # endif
+
+ ARGP_EI void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ ARGP_EI int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -572,7 +572,7 @@
+ }
+
+ ARGP_EI int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
+--- lsh-1.4.3/src/argp/argp-parse.c.orig 2004-11-21 18:27:21.137347304 -0500
++++ lsh-1.4.3/src/argp/argp-parse.c 2004-11-21 18:27:38.008782456 -0500
+@@ -1267,13 +1267,13 @@
+ /* Defined here, in case a user is not inlining the definitions in
+ * argp.h */
+ void
+-__argp_usage (__const struct argp_state *__state) __THROW
++__argp_usage (__const struct argp_state *__state)
+ {
+ __argp_state_help (__state, stderr, ARGP_HELP_STD_USAGE);
+ }
+
+ int
+-__option_is_short (__const struct argp_option *__opt) __THROW
++__option_is_short (__const struct argp_option *__opt)
+ {
+ if (__opt->flags & OPTION_DOC)
+ return 0;
+@@ -1287,7 +1287,7 @@
+ }
+
+ int
+-__option_is_end (__const struct argp_option *__opt) __THROW
++__option_is_end (__const struct argp_option *__opt)
+ {
+ return !__opt->key && !__opt->name && !__opt->doc && !__opt->group;
+ }
diff --git a/dev-libs/lsh/lsh-1.4.3-r1.ebuild b/dev-libs/lsh/lsh-1.4.3-r1.ebuild
index 5091a7b7546c..6ba9d5d16c42 100644
--- a/dev-libs/lsh/lsh-1.4.3-r1.ebuild
+++ b/dev-libs/lsh/lsh-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/lsh/lsh-1.4.3-r1.ebuild,v 1.3 2004/07/17 09:42:45 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/lsh/lsh-1.4.3-r1.ebuild,v 1.4 2004/11/22 04:45:01 vapier Exp $
inherit eutils
@@ -26,20 +26,22 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${PV}-gcc34.patch
+ epatch ${FILESDIR}/${PV}-configure.patch
+ autoconf || die
}
src_compile() {
# configure script checks /dev/ptmx in order to enable
# proper unix pty support ... so lets fake that it works :)
addpredict /dev/ptmx
-# `use_enable kerberos` \
+# $(use_enable kerberos)
econf \
--disable-kerberos \
- `use_enable pam` \
- `use_enable ipv6` \
- `use_with zlib` \
- `use_with tcpd tcpwrappers` \
- `use_with X x` \
+ $(use_enable pam) \
+ $(use_enable ipv6) \
+ $(use_with zlib) \
+ $(use_with tcpd tcpwrappers) \
+ $(use_with X x) \
|| die
emake || die
}