summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-20 09:55:40 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-20 09:55:40 +0000
commit8913b7ebc4714b8623a0732a0e0aca64e232b37d (patch)
treea71ab21c2d111c9e579110a1740e98081a7824af /dev-lisp
parentAdded to ~hppa (diff)
downloadhistorical-8913b7ebc4714b8623a0732a0e0aca64e232b37d.tar.gz
historical-8913b7ebc4714b8623a0732a0e0aca64e232b37d.tar.bz2
historical-8913b7ebc4714b8623a0732a0e0aca64e232b37d.zip
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-hello/ChangeLog10
-rw-r--r--dev-lisp/cl-hello/Manifest4
-rw-r--r--dev-lisp/cl-hello/cl-hello-0.2.ebuild25
-rw-r--r--dev-lisp/cl-hello/files/digest-cl-hello-0.21
-rw-r--r--dev-lisp/cl-hello/metadata.xml10
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-lisp/cl-hello/ChangeLog b/dev-lisp/cl-hello/ChangeLog
new file mode 100644
index 000000000000..c9cff11ce6d5
--- /dev/null
+++ b/dev-lisp/cl-hello/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-hello
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-hello/ChangeLog,v 1.1 2005/03/20 09:55:40 mkennedy Exp $
+
+*cl-hello-0.2 (20 Mar 2005)
+
+ 20 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-hello-0.2.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-hello/Manifest b/dev-lisp/cl-hello/Manifest
new file mode 100644
index 000000000000..a71f4be9f946
--- /dev/null
+++ b/dev-lisp/cl-hello/Manifest
@@ -0,0 +1,4 @@
+MD5 b350f22c4bc2cc295575ef6559df2b8c cl-hello-0.2.ebuild 689
+MD5 671e3ff179bd2babbc6c3c961eb65faa metadata.xml 428
+MD5 0d9388efa71b9618c8c1c3ba8df59e76 ChangeLog 407
+MD5 404c20c44fd7fc3226f65cd68684164a files/digest-cl-hello-0.2 64
diff --git a/dev-lisp/cl-hello/cl-hello-0.2.ebuild b/dev-lisp/cl-hello/cl-hello-0.2.ebuild
new file mode 100644
index 000000000000..c9b3c02c55d6
--- /dev/null
+++ b/dev-lisp/cl-hello/cl-hello-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-hello/cl-hello-0.2.ebuild,v 1.1 2005/03/20 09:55:40 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="An example of how to layout the file structure of a Lisp program or library."
+HOMEPAGE="http://www.cliki.net/hello-lisp"
+SRC_URI="http://constantly.at/lisp/hello-lisp-${PV}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=hello-lisp
+
+S=${WORKDIR}/hello-lisp
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc README
+}
diff --git a/dev-lisp/cl-hello/files/digest-cl-hello-0.2 b/dev-lisp/cl-hello/files/digest-cl-hello-0.2
new file mode 100644
index 000000000000..2637e2707f31
--- /dev/null
+++ b/dev-lisp/cl-hello/files/digest-cl-hello-0.2
@@ -0,0 +1 @@
+MD5 5a4abb02262d0ab1b14697bb1aa26d2c hello-lisp-0.2.tar.gz 1820
diff --git a/dev-lisp/cl-hello/metadata.xml b/dev-lisp/cl-hello/metadata.xml
new file mode 100644
index 000000000000..d59e0f384f19
--- /dev/null
+++ b/dev-lisp/cl-hello/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+HELLO-LISP is an example of how to lay out the file structure of a Lisp program
+/ library. It serves as a reference document for intermediate Lisp programmers
+who want to use asdf and make their programs asdf-install-friendly.
+</longdescription>
+</pkgmetadata>