summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Smee <strerror@gentoo.org>2005-06-22 15:01:00 +0000
committerBenjamin Smee <strerror@gentoo.org>2005-06-22 15:01:00 +0000
commit9147e18705e7c697958e9e92fa1b779ee50fcc32 (patch)
treefad41f4b55810150d818de47f4d2d871bdb6fba3 /dev-perl/CUFlow
parentInitial import. (diff)
downloadhistorical-9147e18705e7c697958e9e92fa1b779ee50fcc32.tar.gz
historical-9147e18705e7c697958e9e92fa1b779ee50fcc32.tar.bz2
historical-9147e18705e7c697958e9e92fa1b779ee50fcc32.zip
Initial import.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-perl/CUFlow')
-rw-r--r--dev-perl/CUFlow/CUFlow-1.5.ebuild53
-rw-r--r--dev-perl/CUFlow/ChangeLog10
-rw-r--r--dev-perl/CUFlow/Manifest3
-rw-r--r--dev-perl/CUFlow/files/CUFlow.cf76
-rw-r--r--dev-perl/CUFlow/files/digest-CUFlow-1.51
-rw-r--r--dev-perl/CUFlow/metadata.xml8
6 files changed, 151 insertions, 0 deletions
diff --git a/dev-perl/CUFlow/CUFlow-1.5.ebuild b/dev-perl/CUFlow/CUFlow-1.5.ebuild
new file mode 100644
index 000000000000..9571626f4a22
--- /dev/null
+++ b/dev-perl/CUFlow/CUFlow-1.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+inherit eutils
+
+
+DESCRIPTION="Provides an API for reading and analysing raw flow files"
+HOMEPAGE="http://www.columbia.edu/acis/networks/advanced/CUFlow/CUFlow.html"
+SRC_URI="http://www.columbia.edu/acis/networks/advanced/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ net-analyzer/FlowScan
+ net-www/apache"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s%my \$rrddir = \"/cflow/reports/rrds\";%my \$rrddir = \"/var/lib/flows/rrds\";%" CUGrapher.pl \
+ || die "sed failed"
+}
+
+src_install() {
+ insinto /var/lib/flows/bin
+ doins ${FILESDIR}/CUFlow.cf
+ exeinto /var/lib/flows/bin
+ doexe CUFlow.pm
+ exeinto /var/www/localhost/cgi-bin
+ doexe CUGrapher.pl
+ ewarn "CUGrapher.pl has been placed in /var/www/localhost/cgi-bin"
+ ewarn "If this is not where your cgi-bin directory is then you must"
+ ewarn "move it manually"
+ dodoc COPYING README.txt
+
+}
+
+pkg_postinst() {
+ chown flows:flows /var/lib/flows/bin/CUFlow.pm
+ chown flows:flows /var/lib/flows/bin/CUFlow.cf
+ einfo
+ einfo "Edit /var/lib/flows/bin/CUFlow.cf for your site"
+ einfo "You will need to add the following line to flowscan.cf:"
+ einfo " ReportClasses CUFlow"
+ einfo "You must also comment out any other lines that contain"
+ einfo "ReportClasses."
+ einfo
+}
diff --git a/dev-perl/CUFlow/ChangeLog b/dev-perl/CUFlow/ChangeLog
new file mode 100644
index 000000000000..44755488cf29
--- /dev/null
+++ b/dev-perl/CUFlow/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-perl/CUFlow
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CUFlow/ChangeLog,v 1.1 2005/06/22 14:58:57 strerror Exp $
+
+*CUFlow-1.5 (22 Jun 2005)
+
+ 22 Jun 2005; Benjamin Smee <strerror@gentoo.org> +files/CUFlow.cf,
+ +metadata.xml, +CUFlow-1.5.ebuild:
+ Initial import.
+
diff --git a/dev-perl/CUFlow/Manifest b/dev-perl/CUFlow/Manifest
new file mode 100644
index 000000000000..865d1ea7ad07
--- /dev/null
+++ b/dev-perl/CUFlow/Manifest
@@ -0,0 +1,3 @@
+MD5 0be914001c1a692e95b8c4d0aafad5a0 CUFlow-1.5.ebuild 1391
+MD5 29cdd8662081c464bceea70d5e65cf0c files/digest-CUFlow-1.5 58
+MD5 14fe134067dc677df00b57d0ecb558fe files/CUFlow.cf 2027
diff --git a/dev-perl/CUFlow/files/CUFlow.cf b/dev-perl/CUFlow/files/CUFlow.cf
new file mode 100644
index 000000000000..8ea0a52ee4f2
--- /dev/null
+++ b/dev-perl/CUFlow/files/CUFlow.cf
@@ -0,0 +1,76 @@
+# Sample CUFlow.cf file
+
+# These are the subnets in our network
+# These are used only to determine whether a packet is inbound our
+# outbound
+Subnet 10.0.0.0/16
+
+# These are networks we are particularly interested in, and want to
+# get separate rrd's for their aggregate traffic
+Network 10.0.1.0/24 special
+
+# Where to put the rrd's
+# Make sure this is the same as $rrddir in CUGrapher.pl
+OutputDir /var/lib/flows/rrds
+
+# Track multicast traffic
+Multicast
+
+# Keep top N lists
+# Show the top ten talkers, storing reports in /cflow/flows/reports
+# and keeping the current report in /etc/httpd/data/reports/topten.html
+#Scoreboard 10 /cflow/reports/scoreboard /var/www/html/topten.html
+Scoreboard 25 /var/lib/flows/scoreboard /var/lib/flows/scoreboard/toptalkers.html
+
+# Same, but build an over-time average top N list
+#AggregateScore 10 /cflow/reports/scoreboard/agg.dat /var/www/html/overall.html
+AggregateScore 25 /var/lib/flows/rrds/agg.dat /var/lib/flows/scoreboard/overall.html
+
+# Our two netflow exporters. Produce service and protocol reports for the
+# total, and each of these.
+Router 10.0.1.2 router2
+
+# Services we are interested in
+Service 20-21/tcp ftp
+Service 22/tcp ssh
+Service 23/tcp telnet
+Service 25/tcp smtp
+Service 53/udp,53/tcp dns
+Service 80/tcp http
+Service 110/tcp pop3
+Service 123/udp ntp
+Service 143/tcp imap
+Service 161/udp snmp
+#Service 412/tcp,412/udp dc
+Service 389/tcp ldap
+Service 443/tcp https
+Service 636/tcp ldaps
+#Service 1214/tcp kazaa
+#Service 4661-4662/tcp,4665/udp edonkey
+#Service 6346-6347/tcp gnutella
+Service 993/tcp imaps
+Service 994/tcp irc
+Service 995/tcp pop3s
+Service 5223/tcp jabbers
+#Service 54320/tcp bo2k
+Service 7070/tcp,554/tcp,6970-7170/udp real
+
+# protocols we are interested in
+Protocol 1 icmp
+Protocol 4 ipinip
+Protocol 6 tcp
+Protocol 17 udp
+Protocol 47 gre
+Protocol 50 esp
+Protocol 51 ah
+Protocol 57 skip
+Protocol 88 eigrp
+Protocol 169
+Protocol 255
+
+# ToS bit percentages to graph
+TOS 0 normal
+TOS 1-255 other
+
+# Interested in traffic to/from AS 1
+#ASNumber 1 Genuity
diff --git a/dev-perl/CUFlow/files/digest-CUFlow-1.5 b/dev-perl/CUFlow/files/digest-CUFlow-1.5
new file mode 100644
index 000000000000..f5e3db20f821
--- /dev/null
+++ b/dev-perl/CUFlow/files/digest-CUFlow-1.5
@@ -0,0 +1 @@
+MD5 23a65d1bdaefa4d187151d96e0bfef30 CUFlow-1.5.tgz 28223
diff --git a/dev-perl/CUFlow/metadata.xml b/dev-perl/CUFlow/metadata.xml
new file mode 100644
index 000000000000..49f20b1c1d96
--- /dev/null
+++ b/dev-perl/CUFlow/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<maintainer>
+ <email>strerror@gentoo.org</email>
+</maintainer>
+</pkgmetadata>