summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-08 02:43:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-08 02:43:05 +0000
commitc87ad59dcaa7a2176881f7dce9ac073f4448b322 (patch)
tree156cc2b5fa520ad4e463659cb2f73f029cc74a69 /dev-perl/PDL
parentRemoving wltjr as a maintainer since he was retired. (diff)
downloadhistorical-c87ad59dcaa7a2176881f7dce9ac073f4448b322.tar.gz
historical-c87ad59dcaa7a2176881f7dce9ac073f4448b322.tar.bz2
historical-c87ad59dcaa7a2176881f7dce9ac073f4448b322.zip
Version bump.
Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/ChangeLog7
-rw-r--r--dev-perl/PDL/PDL-2.4.4.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index 4f2245af3ff6..f13900135baf 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/PDL
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.77 2008/08/06 16:55:46 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.78 2008/12/08 02:38:53 robbat2 Exp $
+
+*PDL-2.4.4 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> +PDL-2.4.4.ebuild:
+ Version bump.
06 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/dev-perl/PDL/PDL-2.4.4.ebuild b/dev-perl/PDL/PDL-2.4.4.ebuild
new file mode 100644
index 000000000000..ce1649bbdf58
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.4.ebuild,v 1.1 2008/12/08 02:38:53 robbat2 Exp $
+
+MODULE_AUTHOR=CHM
+inherit perl-module eutils multilib
+
+DESCRIPTION="PDL Perl Module"
+
+LICENSE="Artistic as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sh ~sparc ~x86"
+IUSE="opengl badval gsl"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ perl-core/Filter
+ virtual/perl-File-Spec
+ dev-perl/Inline
+ dev-perl/Astro-FITS-Header
+ >=dev-perl/ExtUtils-F77-1.13
+ virtual/perl-Text-Balanced
+ opengl? ( virtual/opengl virtual/glu )
+ dev-perl/Term-ReadLine-Perl
+ gsl? ( sci-libs/gsl )
+ >=sys-apps/sed-4"
+
+mydoc="DEPENDENCIES DEVELOPMENT MANIFEST* Release_Notes TODO"
+
+#SRC_TEST="do"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/PDL-2.4.2-makemakerfix.patch"
+
+ # Unconditional -fPIC for the lib (#55238, #180807)
+ epatch "${FILESDIR}/${PN}-2.4.3-PIC.patch"
+
+ # TODO: everything in this function below this
+ # TODO: line really belongs in src_compile() :
+
+ # This 'fix' breaks compiles for non-opengl users
+ #if ! use opengl ; then
+ # sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ # ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ #fi
+
+ if use badval ; then
+ sed -i -e "s:WITH_BADVAL => 0:WITH_BADVAL => 1:" "${S}/perldl.conf"
+ fi
+
+ # Turn off GSL automagic:
+ if use gsl ; then
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 1:" "${S}/perldl.conf"
+ else
+ sed -i -e "s:WITH_GSL => undef:WITH_GSL => 0:" "${S}/perldl.conf"
+ fi
+}
+
+src_install() {
+ perl-module_src_install
+ dodir /usr/share/doc/${PF}/html
+ eval `perl '-V:version'`
+ PERLVERSION=${version}
+ eval `perl '-V:archname'`
+ ARCHVERSION=${archname}
+ mv ${D}/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/HtmlDocs/PDL \
+ ${D}/usr/share/doc/${PF}/html
+
+ mydir=${D}/usr/share/doc/${PF}/html/PDL
+
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+ cp ${S}/Doc/scantree.pl ${D}/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
+ cp ${S}/Doc/mkhtmldoc.pl ${D}/usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/
+}
+
+pkg_postinst() {
+ perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running"
+ elog "perl /usr/$(get_libdir)/perl5/vendor_perl/${PERLVERSION}/${ARCHVERSION}/PDL/Doc/scantree.pl"
+ epause 3
+ elog "PDL requires that glx and dri support be enabled in"
+ elog "your X configuration for certain parts of the graphics"
+ elog "engine to work. See your X's documentation for futher"
+ elog "information."
+}