summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-04-28 00:12:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-04-28 00:12:47 +0000
commit69b1b7e4ae3a5f2d05fc0126d4da76e55a026326 (patch)
tree5f5d5dd21ac226d20b902570b97b3302c6ca5999 /dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild
parentVersion bump, bug #176124. (diff)
downloadhistorical-69b1b7e4ae3a5f2d05fc0126d4da76e55a026326.tar.gz
historical-69b1b7e4ae3a5f2d05fc0126d4da76e55a026326.tar.bz2
historical-69b1b7e4ae3a5f2d05fc0126d4da76e55a026326.zip
Version bumped, bug #149351.
Package-Manager: portage-2.1.2.4
Diffstat (limited to 'dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild')
-rw-r--r--dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild b/dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild
new file mode 100644
index 000000000000..95d3e6e1bd90
--- /dev/null
+++ b/dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tkzinc/tkzinc-3.3.4.ebuild,v 1.1 2007/04/28 00:12:47 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="A Tk widget library."
+HOMEPAGE="http://www.tkzinc.org"
+SRC_URI="http://www.tkzinc.org/Packages/zinc-tk_${PV}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="threads opengl doc"
+DEPEND=">=dev-lang/tk-8.4
+ opengl? ( virtual/opengl )
+ doc? ( virtual/tetex )"
+
+S="${WORKDIR}/Tkzinc"
+
+src_compile() {
+ local myconf
+ if use opengl ; then
+ myconf="--enable-gl=damage"
+ fi
+
+ econf \
+ $(use_enable threads) \
+ ${myconf} || die
+
+ emake || die "make failed"
+ if use doc ; then
+ make pdf || die "make pdf files failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc BUGS README
+ dohtml -r doc/*
+ use doc && dodoc doc/refman.pdf
+}