summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-05 03:53:43 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-05 03:53:43 +0000
commitcf9e10fbe09c6c90583d93e8f974e3e86d2d6d40 (patch)
tree9d230aed331afa5e15b3839c405eb8920123b4ac /dev-util/byacc
parentremoved incorrect S (bug #46788); use sed -i; IUSE; error messages; tidy (diff)
downloadhistorical-cf9e10fbe09c6c90583d93e8f974e3e86d2d6d40.tar.gz
historical-cf9e10fbe09c6c90583d93e8f974e3e86d2d6d40.tar.bz2
historical-cf9e10fbe09c6c90583d93e8f974e3e86d2d6d40.zip
Add patch from Jaime Alvaro Moreno in bug 46233 to make byacc work correctly on ia64 and other 64-bit arches. Also modify the mkstemp patch to coexist with the new patch.
Diffstat (limited to 'dev-util/byacc')
-rw-r--r--dev-util/byacc/ChangeLog10
-rw-r--r--dev-util/byacc/Manifest7
-rw-r--r--dev-util/byacc/byacc-1.9.ebuild7
-rw-r--r--dev-util/byacc/files/byacc-1.9-ia64.patch24
-rw-r--r--dev-util/byacc/files/mkstemp.patch9
5 files changed, 42 insertions, 15 deletions
diff --git a/dev-util/byacc/ChangeLog b/dev-util/byacc/ChangeLog
index 5cd5be11da28..66b35219ef8c 100644
--- a/dev-util/byacc/ChangeLog
+++ b/dev-util/byacc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/byacc
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.2 2003/02/12 06:39:02 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/ChangeLog,v 1.3 2004/04/05 03:53:43 agriffis Exp $
+
+ 04 Apr 2004; Aron Griffis <agriffis@gentoo.org> byacc-1.9.ebuild,
+ files/byacc-1.9-ia64.patch, files/mkstemp.patch:
+ Add patch from Jaime Alvaro Moreno in bug 46233 to make byacc work correctly
+ on ia64 and other 64-bit arches. Also modify the mkstemp patch to coexist with
+ the new patch.
*byacc-1.9 (17 Dec 2002)
diff --git a/dev-util/byacc/Manifest b/dev-util/byacc/Manifest
index f48301bfc17c..5a2547cc2c9e 100644
--- a/dev-util/byacc/Manifest
+++ b/dev-util/byacc/Manifest
@@ -1,4 +1,5 @@
-MD5 bae46ba4d50327303e4b4ad457300e1c ChangeLog 339
-MD5 0252d5128b0de0e4e96a5a6c38cfa629 byacc-1.9.ebuild 717
+MD5 83676eb84f97fab9050bc49bbdd970a6 ChangeLog 638
+MD5 8ba45fa5abb2b72b389a59cd9c375a1e byacc-1.9.ebuild 863
MD5 463704e3c68fc5577c576216a24e9932 files/digest-byacc-1.9 61
-MD5 36346e8f511936c86922fe7f411a3577 files/mkstemp.patch 545
+MD5 df645d0e6382050201af35e3002dfc5b files/mkstemp.patch 413
+MD5 c5a221a78a10f6156ea9ddb2ade30598 files/byacc-1.9-ia64.patch 504
diff --git a/dev-util/byacc/byacc-1.9.ebuild b/dev-util/byacc/byacc-1.9.ebuild
index c7137a7eba70..f1d97de128b4 100644
--- a/dev-util/byacc/byacc-1.9.ebuild
+++ b/dev-util/byacc/byacc-1.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/byacc-1.9.ebuild,v 1.6 2004/03/13 01:49:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/byacc/byacc-1.9.ebuild,v 1.7 2004/04/05 03:53:43 agriffis Exp $
inherit eutils
@@ -14,6 +14,11 @@ KEYWORDS="x86 ppc ia64 ~sparc ~alpha ~mips ~hppa"
src_compile() {
epatch ${FILESDIR}/mkstemp.patch
+
+ # The following patch fixes yacc to run correctly on ia64 (and
+ # other 64-bit arches). See bug 46233
+ epatch ${FILESDIR}/byacc-1.9-ia64.patch
+
make PROGRAM=byacc CFLAGS="${CFLAGS}" || die
}
diff --git a/dev-util/byacc/files/byacc-1.9-ia64.patch b/dev-util/byacc/files/byacc-1.9-ia64.patch
new file mode 100644
index 000000000000..c10e88541287
--- /dev/null
+++ b/dev-util/byacc/files/byacc-1.9-ia64.patch
@@ -0,0 +1,24 @@
+--- byacc-1.9/defs.h.busted Sat May 6 21:10:56 2000
++++ byacc-1.9/defs.h Sat May 6 21:11:22 2000
+@@ -1,7 +1,8 @@
+ #include <assert.h>
+ #include <ctype.h>
+ #include <stdio.h>
+-
++#include <string.h>
++#include <stdlib.h>
+
+ /* machine-dependent definitions */
+ /* the following definitions are for the Tahoe */
+@@ -280,10 +281,3 @@
+ extern int errno;
+
+
+-/* system functions */
+-
+-extern void free();
+-extern char *calloc();
+-extern char *malloc();
+-extern char *realloc();
+-extern char *strcpy();
+
diff --git a/dev-util/byacc/files/mkstemp.patch b/dev-util/byacc/files/mkstemp.patch
index a4a30a342078..f037e331fb5b 100644
--- a/dev-util/byacc/files/mkstemp.patch
+++ b/dev-util/byacc/files/mkstemp.patch
@@ -1,14 +1,5 @@
--- main.c.orig 2002-12-17 14:28:54.000000000 -0500
+++ main.c 2002-12-17 14:29:31.000000000 -0500
-@@ -57,7 +57,7 @@
- short **derives;
- char *nullable;
-
--extern char *mktemp();
-+extern char *mkstemp();
- extern char *getenv();
-
-
@@ -264,9 +264,9 @@
text_file_name[len + 5] = 't';
union_file_name[len + 5] = 'u';