summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-21 20:34:23 +0000
committerMike Frysinger <vapier@gentoo.org>2010-11-21 20:34:23 +0000
commit6e7b0cf4bbbb7a7c6fffa0d5e3a36bf9364d428b (patch)
tree43c657ba6fa2d9d9c38a6760f55024110cdcf8ed /dev-util/ccache
parentconvert to /bin/sh and use standard gentoo output funcs (diff)
downloadhistorical-6e7b0cf4bbbb7a7c6fffa0d5e3a36bf9364d428b.tar.gz
historical-6e7b0cf4bbbb7a7c6fffa0d5e3a36bf9364d428b.tar.bz2
historical-6e7b0cf4bbbb7a7c6fffa0d5e3a36bf9364d428b.zip
Version bump.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog7
-rw-r--r--dev-util/ccache/ccache-3.1.2.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index 258c8cdefe2b..cc8aa89607ed 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.68 2010/11/19 09:46:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.69 2010/11/21 20:34:23 vapier Exp $
+
+*ccache-3.1.2 (21 Nov 2010)
+
+ 21 Nov 2010; Mike Frysinger <vapier@gentoo.org> +ccache-3.1.2.ebuild:
+ Version bump.
*ccache-3.1.1 (19 Nov 2010)
diff --git a/dev-util/ccache/ccache-3.1.2.ebuild b/dev-util/ccache/ccache-3.1.2.ebuild
new file mode 100644
index 000000000000..2e598472738e
--- /dev/null
+++ b/dev-util/ccache/ccache-3.1.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-3.1.2.ebuild,v 1.1 2010/11/21 20:34:23 vapier Exp $
+
+inherit multilib
+
+DESCRIPTION="fast compiler cache"
+HOMEPAGE="http://ccache.samba.org/"
+SRC_URI="http://samba.org/ftp/ccache/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # make sure we always use system zlib
+ rm -rf zlib
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
+
+ dobin "${FILESDIR}"/ccache-config || die
+ dosed "/^LIBDIR=/s:lib:$(get_libdir):" /usr/bin/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_postinst() {
+ "${ROOT}"/usr/bin/ccache-config --install-links
+ "${ROOT}"/usr/bin/ccache-config --install-links ${CHOST}
+
+ # nuke broken symlinks from previous versions that shouldn't exist
+ rm -f "${ROOT}/usr/$(get_libdir)/ccache/bin/${CHOST}-cc"
+ [[ -d "${ROOT}/usr/$(get_libdir)/ccache.backup" ]] && \
+ rm -rf "${ROOT}/usr/$(get_libdir)/ccache.backup"
+
+ elog "To use ccache with **non-Portage** C compiling, add"
+ elog "/usr/$(get_libdir)/ccache/bin to the beginning of your path, before /usr/bin."
+ elog "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ elog "no additional steps. If this is your first install of ccache, type"
+ elog "something like this to set a maximum cache size of 2GB:"
+ elog "# ccache -M 2G"
+ elog
+ elog "If you are upgrading from an older version than 3.x you should clear"
+ elog "all of your caches like so:"
+ elog "# CCACHE_DIR='${CCACHE_DIR:-${PORTAGE_TMPDIR}/ccache}' ccache -C"
+}