summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-07-11 15:53:37 +0000
committerMike Frysinger <vapier@gentoo.org>2004-07-11 15:53:37 +0000
commit169b6f9a74304f278c8f696019893f8083e9ab9f (patch)
tree687295e865484b38dd55ab2f765fca86adcf504f /dev-util/cvsup
parentvirtual/m3 (diff)
downloadhistorical-169b6f9a74304f278c8f696019893f8083e9ab9f.tar.gz
historical-169b6f9a74304f278c8f696019893f8083e9ab9f.tar.bz2
historical-169b6f9a74304f278c8f696019893f8083e9ab9f.zip
dont bundle ezm3 in anymore
Diffstat (limited to 'dev-util/cvsup')
-rw-r--r--dev-util/cvsup/Manifest18
-rw-r--r--dev-util/cvsup/cvsup-16.1h.ebuild117
-rw-r--r--dev-util/cvsup/files/digest-cvsup-16.1h2
3 files changed, 41 insertions, 96 deletions
diff --git a/dev-util/cvsup/Manifest b/dev-util/cvsup/Manifest
index 17f053ba3609..50018038e3ef 100644
--- a/dev-util/cvsup/Manifest
+++ b/dev-util/cvsup/Manifest
@@ -1,10 +1,20 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 1d3feba73cf8eb8a775b90e72a134cee ChangeLog 1610
-MD5 190284bff417813decfed5b0690b7da7 cvsup-16.1h.ebuild 4051
MD5 1c57c6b4152fb7462281a34a6d364d8e metadata.xml 643
+MD5 d3a66af0c2d09b6a576ef9edcaabe7f8 cvsup-16.1h.ebuild 1972
MD5 ef851a57002484a5917f1b446e231e69 files/16.1h-ppc.patch 1179
MD5 8dfbd6317bf54cfaa516faffc69616d8 files/99cvsup 36
-MD5 204b6983886e1cc3e7bbe3b09070be61 files/cvsupd.confd 366
-MD5 e22a754596dde56843f8afd6a46bd6d6 files/cvsupd.rc 558
-MD5 393154754f0d144a7cb93927a7c88acf files/digest-cvsup-16.1h 213
+MD5 10946919aa6c072bc537002932836b0e files/cvsupd.confd 367
+MD5 d08be5b26717ed8542b89b87fe9860aa files/cvsupd.rc 559
+MD5 258f2dae4891b889f3c4b05ef8598fed files/digest-cvsup-16.1h 68
MD5 9a5b6ecba759a5260d4fb3d4e07a4c9c files/gentoo.sup 153
MD5 3f47f29ce5967adb60f63c5e251f1452 files/gentoo_mirror.sup 208
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.8 (GNU/Linux)
+
+iD8DBQFA8WKPHTu7gpaalycRAjoLAJ9MNCAu+1TY7k9Wnp53PPHTVQDVOACeIjvO
+SPFq4940oIQLYMOlgt7i9Zc=
+=iNCa
+-----END PGP SIGNATURE-----
diff --git a/dev-util/cvsup/cvsup-16.1h.ebuild b/dev-util/cvsup/cvsup-16.1h.ebuild
index 5c43338e9350..b684fb6f0cf0 100644
--- a/dev-util/cvsup/cvsup-16.1h.ebuild
+++ b/dev-util/cvsup/cvsup-16.1h.ebuild
@@ -1,36 +1,26 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsup/cvsup-16.1h.ebuild,v 1.12 2004/07/02 05:06:21 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsup/cvsup-16.1h.ebuild,v 1.13 2004/07/11 15:53:37 vapier Exp $
inherit eutils
MY_P="${P/-/-snap-}"
-EZM3="ezm3-1.1"
-EZM3_TARGET="LINUXLIBC6"
-EZM3_INSTALL="${S}/${EZM3}-install" #// anywhere or having a trailing / makes the compile dies
-
DESCRIPTION="a faster alternative to cvs"
HOMEPAGE="http://www.cvsup.org/"
-SRC_URI="ftp://ftp3.freebsd.org/pub/FreeBSD/development/CVSup/sources/${MY_P}.tar.gz
- ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/ezm3/${EZM3}-src.tar.bz2
- ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/ezm3/${EZM3}-${EZM3_TARGET}-boot.tar.bz2"
+SRC_URI="ftp://ftp3.freebsd.org/pub/FreeBSD/development/CVSup/sources/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="-* x86 ~ppc"
-IUSE="X opengl static"
+KEYWORDS="-* x86 ppc"
+IUSE="X opengl static doc"
DEPEND="virtual/libc
dev-util/yacc
>=sys-apps/sed-4
- ppc? ( dev-lang/cm3 )"
+ virtual/m3"
RDEPEND="virtual/libc"
-S=${WORKDIR}
-
-seduse() {
- useq !${1} && echo "${2}" || echo ":"
-}
+S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${A}
@@ -38,101 +28,48 @@ src_unpack() {
}
src_compile() {
- if [ ${ARCH} != "ppc" ] ; then
- ########################
- ### BEGIN EZM3 SETUP ###
- ########################
-
- # when you do make, ezm3 builds & installs at the same time so we control
- # where it is going to install the compiler and stuff
- # (to not violate sandbox)
- cd ${S}/${EZM3}/m3config/src
- sed -i \
- -e "s:/usr/local:${EZM3_INSTALL}:" ${EZM3_TARGET} || \
- die "sed ${EZM3_TARGET} failed"
- echo "M3CC_MAKE = [\"make\", \"BISON=yacc\"]" >> ${EZM3_TARGET}
-
- # now we disable X and OpenGL if the user doesnt have them in their USE var
- sed -i \
- -e "s:/usr/local:${EZM3_INSTALL}:" \
- -e "s:touch:ranlib:" \
- -e "s:`seduse X 'import_X11():import_X11() is\nend\nproc dont_import_X11()'`:" \
- -e "s:`seduse opengl 'import_OpenGL():import_OpenGL() is\nend\nproc dont_import_OpenGL()'`:" \
- COMMON || \
- die "sed COMMON failed"
-
- # finally we compile the m3 compiler
- # we clear the CFLAGS because:
- # (1) higher optimizations cause issues
- # (2) it doesnt matter ... we arent installing the compiler ...
- # we clea the P because:
- # newer build system uses this variable and having it breaks it
- cd ${S}/${EZM3}
- env -u CFLAGS -u P make || die "ezm3 compile failed"
- fi
-
- #########################
- ### BEGIN CVSUP SETUP ###
- #########################
-
- # first we disable the gui (if no X) and enable static (if static is in USE)
- cd ${S}/${MY_P}
local mym3flags=""
- use static && mym3flags="${mym3flags} -DSTATIC"
- use X || mym3flags="${mym3flags} -DNOGUI"
+ use static && mym3flags="${mym3flags} -DSTATIC"
+ use X || mym3flags="${mym3flags} -DNOGUI"
[ "${mym3flags:0:1}" == " " ] && mym3flags="${mym3flags:1}"
sed -i \
-e "s:/usr/local:${D}/usr:" \
- -e "s:^M3FLAGS=:M3FLAGS=${mym3flags}:" Makefile || \
- die "sed Makefile failed"
+ -e "s:^M3FLAGS=:M3FLAGS=${mym3flags}:" \
+ Makefile || die "sed Makefile failed"
# then we fix the /usr/local/etc/cvsup paths in all the files
- for f in `grep /usr/local/etc * -Rl` ; do
- sed -i \
- -e "s:/usr/local/etc:/etc:" ${f} || \
- die "sed ${f} failed"
- done
+ sed -i \
+ -e "s:/usr/local/etc:/etc:" \
+ `grep /usr/local/etc * -Rl` \
+ || die "sed ${f} failed"
# then we compile cvsup
- env PATH="${EZM3_INSTALL}/bin:${PATH}" make || die "cvsup compile failed"
+ make || die "cvsup compile failed"
# now we do up the html pages ...
- cd ${S}/${MY_P}/doc
- make || die "html pages failed to compile !?"
- for f in `ls *.html` ; do
- sed -i \
- -e "s:images/::" ${f} || \
- die "sed ${f} failed"
- done
- mv ${S}/${MY_P}/doc/images/* ${S}/${MY_P}/doc/
+ if use doc ; then
+ cd ${S}/doc
+ make || die "html pages failed to compile !?"
+ sed -i -e "s:images/::" *.html || die "sed ${f} failed"
+ mv ${S}/doc/images/* ${S}/doc/
+ fi
}
src_install() {
- S="${S}/${MY_P}"
+ dodir /var/cvsup
- for f in `find ${S} -perm +1 -type f | grep -v doc` ; do
+ for f in `find . -perm +1 -type f | grep -v doc` ; do
dobin ${f} || die "dobin failed (${f})"
done
- doman ${S}/client/${EZM3_TARGET}/cvsup.1 \
- ${S}/cvpasswd/${EZM3_TARGET}/cvpasswd.1 \
- ${S}/server/${EZM3_TARGET}/cvsupd.8 || \
- die "doman failed"
-
- dohtml ${S}/doc/*.{html,gif} || die "dohtml failed"
-
- dodoc ${S}/{Acknowledgments,Announce,Blurb,ChangeLog,License,Install} || \
- die "dodoc failed"
+ doman */src/*.[1-9] || die "doman failed"
+ use doc && dohtml doc/*.{html,gif}
+ dodoc Acknowledgments Announce Blurb ChangeLog Install
insinto /etc/cvsup
- doins ${FILESDIR}/gentoo.sup ${FILESDIR}/gentoo_mirror.sup || \
- die "doins failed"
-
+ doins ${FILESDIR}/gentoo.sup ${FILESDIR}/gentoo_mirror.sup
exeinto /etc/init.d
newexe ${FILESDIR}/cvsupd.rc cvsupd || die "newexe failed"
-
insinto /etc/conf.d
newins ${FILESDIR}/cvsupd.confd cvsupd || die "newins failed"
-
- dodir /var/cvsup || die "dodir failed"
}
diff --git a/dev-util/cvsup/files/digest-cvsup-16.1h b/dev-util/cvsup/files/digest-cvsup-16.1h
index 6af1308ea89e..9f7e8f94b8d7 100644
--- a/dev-util/cvsup/files/digest-cvsup-16.1h
+++ b/dev-util/cvsup/files/digest-cvsup-16.1h
@@ -1,3 +1 @@
MD5 b100ace98a41aa9f3d3e75b0d3c245b0 cvsup-snap-16.1h.tar.gz 430951
-MD5 0cb8d2af3784142144c01ffac4c0ffff ezm3-1.1-src.tar.bz2 10705295
-MD5 f2efe85be7676944c537aa729f9cb17e ezm3-1.1-LINUXLIBC6-boot.tar.bz2 1444815