summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-12 09:57:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-12 09:57:16 +0000
commit12189e736773598c3e4d583982d2e70c5dd1a3a2 (patch)
treeee8dcceccbd2ae2112228729b8ebac4c8f8aa29b /games-action/atanks
parentVersion bump (diff)
downloadhistorical-12189e736773598c3e4d583982d2e70c5dd1a3a2.tar.gz
historical-12189e736773598c3e4d583982d2e70c5dd1a3a2.tar.bz2
historical-12189e736773598c3e4d583982d2e70c5dd1a3a2.zip
need eutils for epatch
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/ChangeLog5
-rw-r--r--games-action/atanks/Manifest4
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild19
3 files changed, 15 insertions, 13 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index 990337472fa5..58e5c236113b 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/atanks
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.8 2004/09/04 20:40:00 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.9 2004/09/12 09:57:16 mr_bones_ Exp $
+
+ 12 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> atanks-1.1.0.ebuild:
+ need eutils for epatch
04 Sep 2004; Daniel Goller <morfic@gentoo.org> +files/atanks-gcc34.patch,
atanks-1.1.0.ebuild:
diff --git a/games-action/atanks/Manifest b/games-action/atanks/Manifest
index 4cff870d4179..167b25d744db 100644
--- a/games-action/atanks/Manifest
+++ b/games-action/atanks/Manifest
@@ -1,5 +1,5 @@
-MD5 6ace6072c1bc7423116962d9aefbadcf atanks-1.1.0.ebuild 1365
-MD5 22b342ea30e8e3c91a930f9925ab3f4c ChangeLog 2255
+MD5 149e880c3d8585edba1c8be8408f1d83 ChangeLog 2360
+MD5 7ab38ac7034368528686c1c4be3fe706 atanks-1.1.0.ebuild 1345
MD5 08031c6325250ddda0a99870f53c032d metadata.xml 220
MD5 ea52207aee01685ed0e4b52b4cd66958 files/digest-atanks-1.1.0 65
MD5 f1a4b436c0ef59132f761306104d2904 files/atanks-gcc34.patch 1229
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
index 67aadf2c423e..97b4366b11ca 100644
--- a/games-action/atanks/atanks-1.1.0.ebuild
+++ b/games-action/atanks/atanks-1.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.5 2004/09/04 20:40:00 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.6 2004/09/12 09:57:16 mr_bones_ Exp $
-inherit games gcc
+inherit eutils gcc games
DATA_DIR="${GAMES_DATADIR}/${PN}"
DESCRIPTION="Worms and Scorched Earth-like game"
@@ -14,26 +14,25 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-RDEPEND="virtual/x11
+DEPEND="virtual/x11
>=media-libs/allegro-4.0.3
>=media-libs/allegttf-2.0"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
#apply both patches to compile with gcc-3.4.0 closing bug #49457
- if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ if [ "$(gcc-major-version)" -ge "3" -a "$(gcc-minor-version)" -ge "4" ]
then
- epatch ${FILESDIR}/atanks-gcc34.patch
+ epatch "${FILESDIR}/atanks-gcc34.patch"
fi
sed -i \
- -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" src/Makefile || \
- die "sed src/Makefile failed"
+ -e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" \
+ src/Makefile \
+ || die "sed src/Makefile failed"
}
src_install() {