summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-09-04 20:40:00 +0000
committerDaniel Goller <morfic@gentoo.org>2004-09-04 20:40:00 +0000
commit585a28565f445b91e6604b2b3f1121f3377e261d (patch)
tree548c6950b6844cd12c016fb874901fc808d821ca /games-action/atanks
parentVersion bump to 0.13. closes #45884 (diff)
downloadhistorical-585a28565f445b91e6604b2b3f1121f3377e261d.tar.gz
historical-585a28565f445b91e6604b2b3f1121f3377e261d.tar.bz2
historical-585a28565f445b91e6604b2b3f1121f3377e261d.zip
applied gcc34 patch
Diffstat (limited to 'games-action/atanks')
-rw-r--r--games-action/atanks/ChangeLog7
-rw-r--r--games-action/atanks/Manifest5
-rw-r--r--games-action/atanks/atanks-1.1.0.ebuild9
-rw-r--r--games-action/atanks/files/atanks-gcc34.patch27
4 files changed, 43 insertions, 5 deletions
diff --git a/games-action/atanks/ChangeLog b/games-action/atanks/ChangeLog
index b41e34411107..990337472fa5 100644
--- a/games-action/atanks/ChangeLog
+++ b/games-action/atanks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/atanks
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.7 2004/06/24 21:51:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/ChangeLog,v 1.8 2004/09/04 20:40:00 morfic Exp $
+
+ 04 Sep 2004; Daniel Goller <morfic@gentoo.org> +files/atanks-gcc34.patch,
+ atanks-1.1.0.ebuild:
+ applied gcc34 patch, fixing bug #60692
+ thanks Halcy0n
23 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> atanks-1.1.0.ebuild:
don't rdepend on sed
diff --git a/games-action/atanks/Manifest b/games-action/atanks/Manifest
index 0263c14ee4f2..4cff870d4179 100644
--- a/games-action/atanks/Manifest
+++ b/games-action/atanks/Manifest
@@ -1,4 +1,5 @@
-MD5 e9452da3c448dbf7f647fa191bf569f3 ChangeLog 2099
-MD5 101d0e6ce3aa38ae470c8c7c6e392538 atanks-1.1.0.ebuild 1177
+MD5 6ace6072c1bc7423116962d9aefbadcf atanks-1.1.0.ebuild 1365
+MD5 22b342ea30e8e3c91a930f9925ab3f4c ChangeLog 2255
MD5 08031c6325250ddda0a99870f53c032d metadata.xml 220
MD5 ea52207aee01685ed0e4b52b4cd66958 files/digest-atanks-1.1.0 65
+MD5 f1a4b436c0ef59132f761306104d2904 files/atanks-gcc34.patch 1229
diff --git a/games-action/atanks/atanks-1.1.0.ebuild b/games-action/atanks/atanks-1.1.0.ebuild
index 36e32ce41692..67aadf2c423e 100644
--- a/games-action/atanks/atanks-1.1.0.ebuild
+++ b/games-action/atanks/atanks-1.1.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.4 2004/09/04 09:11:53 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/atanks/atanks-1.1.0.ebuild,v 1.5 2004/09/04 20:40:00 morfic Exp $
-inherit games
+inherit games gcc
DATA_DIR="${GAMES_DATADIR}/${PN}"
DESCRIPTION="Worms and Scorched Earth-like game"
@@ -25,6 +25,11 @@ S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
cd ${S}
+ #apply both patches to compile with gcc-3.4.0 closing bug #49457
+ if [ "`gcc-major-version`" -ge "3" -a "`gcc-minor-version`" -ge "4" ]
+ then
+ epatch ${FILESDIR}/atanks-gcc34.patch
+ fi
sed -i \
-e "s:DATA_DIR=.*:DATA_DIR=\\\\\"${DATA_DIR}\\\\\":" src/Makefile || \
diff --git a/games-action/atanks/files/atanks-gcc34.patch b/games-action/atanks/files/atanks-gcc34.patch
new file mode 100644
index 000000000000..d229923bff86
--- /dev/null
+++ b/games-action/atanks/files/atanks-gcc34.patch
@@ -0,0 +1,27 @@
+diff -ur atanks-orig/src/player.cc atanks/src/player.cc
+--- atanks-orig/src/player.cc 2004-09-04 02:12:37.847112834 -0400
++++ atanks/src/player.cc 2004-09-04 02:17:54.685582198 -0400
+@@ -1009,12 +1009,12 @@
+ if (weapNum >= RIOT_CHARGE && weapNum <= RIOT_BLAST) {
+ // add points only within range and above ctank
+ if ( (cy > ctank->y - (radius / 2)) ||
+- (abs (ctank->x - cx) > radius))
++ (abs ((int)ctank->x - cx) > radius))
+ continue;
+ } else if (weapNum >= SML_ROLLER && weapNum <= DTH_ROLLER) {
+ // Only aim rollers above other tanks
+ if (cy > tankY + TANKHEIGHT &&
+- abs (ctank->x - cx) > radius)
++ abs ((int)ctank->x - cx) > radius)
+ continue;
+ } else if (weapNum >= SML_LAZER && weapNum <= LRG_LAZER) {
+ // Lazer can only be aimed above horizontal
+@@ -1085,7 +1085,7 @@
+ if (itemNum >= ITEM_VENGEANCE && itemNum <= ITEM_FATAL_FURY) {
+ // add sqrt distances for each tank * potential damage
+ long int totalEffectiveDamage = calcTotalEffectiveDamage (itemNum);
+- _targetMatrix[(int)ctank->x] += sqrt (abs (ctank->x - ltank->x)) * totalEffectiveDamage;
++ _targetMatrix[(int)ctank->x] += sqrt (abs ((int)ctank->x - (int)ltank->x)) * totalEffectiveDamage;
+
+ }
+ }