summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-28 09:21:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-28 09:21:09 +0000
commit776a1e31a326432ec127fd31353049bb3c305283 (patch)
tree7673460cfc2f17e228fa6c790f4a8195f03dc102 /games-arcade
parentoggvorbis -> ogg/vorbis #94254 (diff)
downloadhistorical-776a1e31a326432ec127fd31353049bb3c305283.tar.gz
historical-776a1e31a326432ec127fd31353049bb3c305283.tar.bz2
historical-776a1e31a326432ec127fd31353049bb3c305283.zip
oggvorbis -> ogg/vorbis #94254
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/pacmanarena/Manifest2
-rw-r--r--games-arcade/pacmanarena/pacmanarena-0.15.ebuild35
2 files changed, 19 insertions, 18 deletions
diff --git a/games-arcade/pacmanarena/Manifest b/games-arcade/pacmanarena/Manifest
index a848ebdab99c..acbac4af9447 100644
--- a/games-arcade/pacmanarena/Manifest
+++ b/games-arcade/pacmanarena/Manifest
@@ -1,4 +1,4 @@
-MD5 b837a84f23251631baf342e5b300e3ad pacmanarena-0.15.ebuild 1356
MD5 0c25fc453a5ef4a2a094a61fe6be4c0e ChangeLog 1018
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 475303ea8071ada8aed3c936e2ea2ccf pacmanarena-0.15.ebuild 1334
MD5 0415f7c09ef4621972cc3670a50c3d57 files/digest-pacmanarena-0.15 136
diff --git a/games-arcade/pacmanarena/pacmanarena-0.15.ebuild b/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
index f6ea3a910b99..08f551e95c7e 100644
--- a/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
+++ b/games-arcade/pacmanarena/pacmanarena-0.15.ebuild
@@ -1,36 +1,35 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/pacmanarena-0.15.ebuild,v 1.6 2004/06/24 22:09:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pacmanarena/pacmanarena-0.15.ebuild,v 1.7 2005/05/28 09:21:09 vapier Exp $
inherit games
-S="${WORKDIR}/pacman"
DESCRIPTION="a Pacman clone in full 3D with a few surprises. Rockets, bombs and explosions abound."
HOMEPAGE="http://sourceforge.net/projects/pacmanarena/"
SRC_URI="mirror://sourceforge/pacmanarena/pacman-arena-${PV}.tar.bz2
- mirror://sourceforge/pacmanarena/pacman-data-0.0.zip"
+ mirror://sourceforge/pacmanarena/pacman-data-0.0.zip"
-KEYWORDS="x86 ~alpha ~amd64"
LICENSE="GPL-2"
SLOT="0"
-IUSE="oggvorbis"
+KEYWORDS="x86 ~alpha ~amd64"
+IUSE="vorbis"
-RDEPEND="virtual/x11
+DEPEND="virtual/x11
virtual/opengl
>=media-libs/sdl-mixer-1.2.4
>=media-libs/sdl-net-1.2.4
- oggvorbis? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
+ vorbis? ( media-libs/libvorbis )"
+
+S=${WORKDIR}/pacman
src_unpack() {
unpack pacman-arena-${PV}.tar.bz2
- cd ${S}
+ cd "${S}"
unpack pacman-data-0.0.zip
sed -i \
- -e "/^CFLAGS/ s:pacman:${PN}:" Makefile.in \
- || die "sed file.h failed"
+ -e "/^CFLAGS/ s:pacman:${PN}:" \
+ Makefile.in || die "sed file.h failed"
}
src_install() {
@@ -43,8 +42,10 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- echo
- ewarn "You need oggvorbis in your USE var and sdl components build"
- ewarn "with oggvorbis to have sound."
- echo
+ if ! use vorbis ; then
+ echo
+ ewarn "You need vorbis in your USE var and sdl components build"
+ ewarn "with vorbis to have sound."
+ echo
+ fi
}