summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 19:00:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-21 19:00:30 +0000
commit1b572159e36c34be1d1b0cb2c5dc6f9cf8be7cb9 (patch)
tree0d9acd6f437da27c8eeb070e369a7e6ced3160bc /games-board
parentFixes #52876. (diff)
downloadhistorical-1b572159e36c34be1d1b0cb2c5dc6f9cf8be7cb9.tar.gz
historical-1b572159e36c34be1d1b0cb2c5dc6f9cf8be7cb9.tar.bz2
historical-1b572159e36c34be1d1b0cb2c5dc6f9cf8be7cb9.zip
version bump
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mahjongg3d/ChangeLog7
-rw-r--r--games-board/mahjongg3d/Manifest6
-rw-r--r--games-board/mahjongg3d/files/digest-mahjongg3d-0.961
-rw-r--r--games-board/mahjongg3d/mahjongg3d-0.96.ebuild43
4 files changed, 54 insertions, 3 deletions
diff --git a/games-board/mahjongg3d/ChangeLog b/games-board/mahjongg3d/ChangeLog
index dd7025469818..c6c98139b1f8 100644
--- a/games-board/mahjongg3d/ChangeLog
+++ b/games-board/mahjongg3d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/mahjongg3d
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/ChangeLog,v 1.1 2004/06/07 19:09:56 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/ChangeLog,v 1.2 2004/06/21 19:00:30 mr_bones_ Exp $
+
+*mahjongg3d-0.96 (21 Jun 2004)
+
+ 21 Jun 2004; Michael Sterrett <mr_bones_@gentoo.org> mahjongg3d-0.96.ebuild:
+ version bump
*mahjongg3d-0.95 (07 Jun 2004)
diff --git a/games-board/mahjongg3d/Manifest b/games-board/mahjongg3d/Manifest
index 3fe86fb12ad1..c2e45907571a 100644
--- a/games-board/mahjongg3d/Manifest
+++ b/games-board/mahjongg3d/Manifest
@@ -1,4 +1,6 @@
-MD5 cc2d40981741610d224cdf9e0e461dd1 mahjongg3d-0.95.ebuild 1193
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 ac94aa02b1f3e2b30d5533bf7d127462 ChangeLog 420
+MD5 4391423f96f75ecd759f6ffa5270468e ChangeLog 547
+MD5 486b23f4950129eaf155edce86a28c05 mahjongg3d-0.96.ebuild 1132
+MD5 cc2d40981741610d224cdf9e0e461dd1 mahjongg3d-0.95.ebuild 1193
MD5 25238a925f8e2204bb9c3e05e3ad3c3f files/digest-mahjongg3d-0.95 69
+MD5 fc36b2970fcd84e6ab6ae1cbfbb0baeb files/digest-mahjongg3d-0.96 64
diff --git a/games-board/mahjongg3d/files/digest-mahjongg3d-0.96 b/games-board/mahjongg3d/files/digest-mahjongg3d-0.96
new file mode 100644
index 000000000000..f4f4d1e30925
--- /dev/null
+++ b/games-board/mahjongg3d/files/digest-mahjongg3d-0.96
@@ -0,0 +1 @@
+MD5 2c8b0793b6a2f74a0ce5915b8e71e9b4 mahjongg3d.tar.bz2 3674725
diff --git a/games-board/mahjongg3d/mahjongg3d-0.96.ebuild b/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
new file mode 100644
index 000000000000..3ec820285980
--- /dev/null
+++ b/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/mahjongg3d-0.96.ebuild,v 1.1 2004/06/21 19:00:30 mr_bones_ Exp $
+
+inherit kde games
+
+DESCRIPTION="An implementation of the classical chinese game Mah Jongg with 3D OpenGL graphics"
+HOMEPAGE="http://www.reto-schoelly.de/mahjongg3d/"
+SRC_URI="http://www.reto-schoelly.de/${PN}/${PN}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+RDEPEND=">=qt-3.2.0
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}.release"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "/GAMEDATA_BASE_PATH/ s:\.:${GAMES_DATADIR}/${PN}:" \
+ src/gamedata_path.h || die "sed src/gamedata_path.h failed"
+}
+
+src_compile() {
+ qmake -o Makefile mahjongg3d.pro
+ kde_src_compile none
+ emake || die "emake failed"
+}
+
+src_install () {
+ dogamesbin bin/{mahjongg3d,mahjongg3d-install-*} || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r bin/{[a-l]*,t*} "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc README Changelog
+ prepgamesdirs
+}