summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:09:57 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:09:57 +0000
commit841ed7d7986644ab5cb0a1c3c52b0d5856d19f70 (patch)
treeaf1e1a0d0aa427e7d5888d392dc0843e0b0b2bad /kde-base/kopete
parentAdded the KDE 4.0.5 version of konsole. (diff)
downloadhistorical-841ed7d7986644ab5cb0a1c3c52b0d5856d19f70.tar.gz
historical-841ed7d7986644ab5cb0a1c3c52b0d5856d19f70.tar.bz2
historical-841ed7d7986644ab5cb0a1c3c52b0d5856d19f70.zip
Added the KDE 4.0.5 version of kopete.
Package-Manager: portage-2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/kopete-4.0.5.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 948ba9425af9..8c9689e808f1 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.150 2008/05/18 16:38:29 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.151 2008/06/05 22:09:57 keytoaster Exp $
+
+*kopete-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org> +kopete-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of kopete.
18 May 2008; Markus Meier <maekke@gentoo.org> kopete-3.5.9.ebuild:
amd64/x86 stable, bug #221063
diff --git a/kde-base/kopete/kopete-4.0.5.ebuild b/kde-base/kopete/kopete-4.0.5.ebuild
new file mode 100644
index 000000000000..85c0987a35ab
--- /dev/null
+++ b/kde-base/kopete/kopete-4.0.5.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.0.5.ebuild,v 1.1 2008/06/05 22:09:57 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdenetwork
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~amd64 ~x86"
+IUSE="+addbookmarks +alias +autoreplace +contactnotes debug gadu groupwise
++highlight +history htmlhandbook +jabber latex +msn +nowlistening +oscar
++privacy qq sms +statistics testbed +texteffect +translator +urlpicpreview
++webpresence winpopup yahoo"
+# IUSE="irc jingle meanwhile messenger telepathy"
+
+# plugins: addbookmarks, alias, autoreplace, contactnotes, highlight, history,
+# latext, nowlistening, privacy, (sqlite?) statistics, texteffect, translator,
+# urlpicpreview, (&& xml2 xslt) webpresence
+
+# protocols: (ssl?) gadu, (qca2?) groupwise, irc (disabled), (&& qca2 idn) jabber,
+# jingle (disabled), meanwhile (not ported), messenger (not ready), msn, oscar,
+# qq, sms, (decibel?) telepathy (not ready), testbed, winpopup, yahoo
+
+# irc and jingle are disabled in the package (4.0.2)
+# meanwhile hasn't been ported to KDE4 yet (4.0.2)
+# messenger is the new msn support protocol (it's not ready yet; 4.0.1)
+# telepathy isn't ready yet (4.0.1)
+
+# Tests are KDE-ish.
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libpcre
+ kde-base/qimageblitz
+ x11-libs/libXScrnSaver
+ gadu? ( dev-libs/openssl )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? ( net-dns/libidn app-crypt/qca:2 )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )"
+# telepathy? ( net-libs/decibel )
+
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto"
+
+src_compile() {
+ # Xmms isn't in portage, thus forcefully disabled.
+ # telepathy and messenger aren't ready yet.
+ mycmakeargs="${mycmakeargs}
+ -DWITH_Xmms=OFF
+ -DWITH_telepathy=OFF
+ -DWITH_messenger=OFF
+ $(cmake-utils_use_with addbookmarks)
+ $(cmake-utils_use_with alias)
+ $(cmake-utils_use_with autoreplace)
+ $(cmake-utils_use_with contactnotes)
+ $(cmake-utils_use_with gadu OPENSSL)
+ $(cmake-utils_use_with groupwise)
+ $(cmake-utils_use_with groupwise QCA2)
+ $(cmake-utils_use_with highlight)
+ $(cmake-utils_use_with history)
+ $(cmake-utils_use_with jabber IDN)
+ $(cmake-utils_use_with jabber QCA2)
+ $(cmake-utils_use_with latex)
+ $(cmake-utils_use_with msn)
+ $(cmake-utils_use_with nowlistening)
+ $(cmake-utils_use_with oscar)
+ $(cmake-utils_use_with privacy)
+ $(cmake-utils_use_with qq)
+ $(cmake-utils_use_with sms)
+ $(cmake-utils_use_with statistics Sqlite)
+ $(cmake-utils_use_with statistics)
+ $(cmake-utils_use_with testbed)
+ $(cmake-utils_use_with texteffect)
+ $(cmake-utils_use_with translator)
+ $(cmake-utils_use_with urlpicpreview)
+ $(cmake-utils_use_with webpresence LibXml2)
+ $(cmake-utils_use_with webpresence LibXslt)
+ $(cmake-utils_use_with webpresence)
+ $(cmake-utils_use_with winpopup)
+ $(cmake-utils_use_with yahoo)"
+
+# $(cmake-utils_use_with messenger)
+# $(cmake-utils_use_with telepathy)
+# $(cmake-utils_use_with telepathy Decibel)
+
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+# if use telepathy; then
+# elog "To use kopete telepathy plugins, you need to start gabble first:"
+# elog "GABBLE_PERSIST=1 telepathy-gabble &"
+# elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+# fi
+ if use jabber; then
+ echo
+ elog "In order to use ssl in jabber, messenger and irc you'll need to have qca-ossl"
+ echo
+ fi
+}