summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-05-19 05:11:19 +0000
committerMamoru Komachi <usata@gentoo.org>2004-05-19 05:11:19 +0000
commit99a9b21f16d34903f3a44644d0befbb1b49b3912 (patch)
treeff6ad7c0f743e224511ab41d8800b74ff6dc2238 /media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild
parentClean up train coming through.... chooo chooo... (diff)
downloadhistorical-99a9b21f16d34903f3a44644d0befbb1b49b3912.tar.gz
historical-99a9b21f16d34903f3a44644d0befbb1b49b3912.tar.bz2
historical-99a9b21f16d34903f3a44644d0befbb1b49b3912.zip
Fixed invalid symbolic link with fresh install. Thanks to ikezoe <ikezoe@users.sourceforge.jp>, closing bug #51438
Diffstat (limited to 'media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild')
-rw-r--r--media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild b/media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild
new file mode 100644
index 000000000000..2cc1501d3c0b
--- /dev/null
+++ b/media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/kochi-substitute/kochi-substitute-20030809-r2.ebuild,v 1.1 2004/05/19 05:11:19 usata Exp $
+
+IUSE="X"
+
+DESCRIPTION="Kochi Japanese TrueType fonts with Wadalab Fonts"
+HOMEPAGE="http://efont.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/efont/5411/${P}.tar.bz2"
+
+# naga10 has free-noncomm license
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~ia64 ~x86 ~alpha ~sparc ~ppc ~hppa ~amd64 ~mips"
+
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+
+S=${WORKDIR}/${PN}-${PV:0:8}
+FONTPATH="/usr/share/fonts/${PN}"
+
+src_install () {
+
+ insinto ${FONTPATH}
+ doins kochi-gothic-subst.ttf
+ doins kochi-mincho-subst.ttf
+ dosym kochi-gothic-subst.ttf ${FONTPATH}/kochi-gothic.ttf
+ dosym kochi-mincho-subst.ttf ${FONTPATH}/kochi-mincho.ttf
+ dodir /usr/X11R6/lib/X11/fonts/truetype
+ for f in ${D}${FONTPATH}/*.ttf ; do
+ dosym ${f/${D}/} /usr/X11R6/lib/X11/fonts/truetype
+ done
+ mkfontscale ${D}${FONTPATH}
+ newins ${D}${FONTPATH}/fonts.scale fonts.dir
+ if [ -x /usr/bin/fc-cache ] ; then
+ /usr/bin/fc-cache -f ${D}${FONTPATH}
+ fi
+
+ dodoc README.ja COPYING docs/README
+ cd docs
+ for d in kappa20 k14goth ayu20gothic wadalab shinonome* naga10; do
+ docinto $d
+ dodoc $d/*
+ done
+}