summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-16 02:01:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-16 02:01:44 +0000
commit53522a799ce200aa8d3eb7557d09a8eb17fec05a (patch)
treed9388d3551a26ccf9045f17ab48ae5adb4c4d604 /media-libs
parentadded ~ppc keyword as requested in bug #41679 (diff)
downloadhistorical-53522a799ce200aa8d3eb7557d09a8eb17fec05a.tar.gz
historical-53522a799ce200aa8d3eb7557d09a8eb17fec05a.tar.bz2
historical-53522a799ce200aa8d3eb7557d09a8eb17fec05a.zip
hppa uNF
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/taglib/taglib-1.0_beta2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/media-libs/taglib/taglib-1.0_beta2.ebuild b/media-libs/taglib/taglib-1.0_beta2.ebuild
index 44238aa8eb8d..031f594d18c4 100644
--- a/media-libs/taglib/taglib-1.0_beta2.ebuild
+++ b/media-libs/taglib/taglib-1.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.0_beta2.ebuild,v 1.11 2004/02/15 16:50:27 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/taglib/taglib-1.0_beta2.ebuild,v 1.12 2004/02/16 02:01:44 vapier Exp $
inherit flag-o-matic
@@ -11,19 +11,24 @@ SRC_URI="http://ktown.kde.org/~wheeler/taglib/${PN}-${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc ~amd64 ppc"
+KEYWORDS="x86 ppc sparc hppa ~amd64"
DEPEND=">=sys-devel/autoconf-2.58"
RDEPEND=""
S=${WORKDIR}/${PN}-${MY_PV}
-src_compile() {
- replace-flags "-O3 -O2"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
rm -rf autom4te.cache
export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.7
- aclocal && autoconf && automake
+ aclocal && autoconf && automake || die "autotools failed"
+}
+
+src_compile() {
+ replace-flags -O3 -O2
econf || die
emake || die
}