summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-29 13:37:33 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-11-29 13:37:33 +0000
commit6cb4615a10df529d37518ebb3430e200fcd15bc9 (patch)
tree11258abc2e54184b06f1d01c3177f2a5d59a8add /media-libs
parentInitial import of ebuild, based on one from Hydonsingore Cia <hydonsingore@ed... (diff)
downloadhistorical-6cb4615a10df529d37518ebb3430e200fcd15bc9.tar.gz
historical-6cb4615a10df529d37518ebb3430e200fcd15bc9.tar.bz2
historical-6cb4615a10df529d37518ebb3430e200fcd15bc9.zip
Version bump and add ~amd64 keyword.
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/tunepimp/ChangeLog8
-rw-r--r--media-libs/tunepimp/files/digest-tunepimp-0.5.23
-rw-r--r--media-libs/tunepimp/tunepimp-0.5.2.ebuild68
3 files changed, 78 insertions, 1 deletions
diff --git a/media-libs/tunepimp/ChangeLog b/media-libs/tunepimp/ChangeLog
index fb84df3d42f8..5a9aa15472ea 100644
--- a/media-libs/tunepimp/ChangeLog
+++ b/media-libs/tunepimp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/tunepimp
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.39 2006/10/19 20:15:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/ChangeLog,v 1.40 2006/11/29 13:37:33 flameeyes Exp $
+
+*tunepimp-0.5.2 (29 Nov 2006)
+
+ 29 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> -tunepimp-0.5.0.ebuild,
+ -tunepimp-0.5.1.ebuild, +tunepimp-0.5.2.ebuild:
+ Version bump and add ~amd64 keyword.
19 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> tunepimp-0.5.0.ebuild,
tunepimp-0.5.1.ebuild:
diff --git a/media-libs/tunepimp/files/digest-tunepimp-0.5.2 b/media-libs/tunepimp/files/digest-tunepimp-0.5.2
new file mode 100644
index 000000000000..e38a24b73b0b
--- /dev/null
+++ b/media-libs/tunepimp/files/digest-tunepimp-0.5.2
@@ -0,0 +1,3 @@
+MD5 655b254539013f5e7fe50ac035c26dcb libtunepimp-0.5.2.tar.gz 1076084
+RMD160 ec2fe7b28b0d6550d698429df7f70f858c3fb5d8 libtunepimp-0.5.2.tar.gz 1076084
+SHA256 3c78270a844fde2933528c57ebbf1a2910463fe334147ef9911098e39909954c libtunepimp-0.5.2.tar.gz 1076084
diff --git a/media-libs/tunepimp/tunepimp-0.5.2.ebuild b/media-libs/tunepimp/tunepimp-0.5.2.ebuild
new file mode 100644
index 000000000000..348a2abafd4e
--- /dev/null
+++ b/media-libs/tunepimp/tunepimp-0.5.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tunepimp/tunepimp-0.5.2.ebuild,v 1.1 2006/11/29 13:37:33 flameeyes Exp $
+
+inherit eutils distutils perl-app
+
+MY_P="lib${P}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="TunePimp is a library to create MusicBrainz enabled tagging applications."
+HOMEPAGE="http://www.musicbrainz.org/products/tunepimp"
+SRC_URI="http://ftp.musicbrainz.org/pub/musicbrainz/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Most use flags were void as not deterministic - needs a patch sooner or later.
+#IUSE="flac mp3 readline perl python vorbis"
+IUSE="python"
+
+RDEPEND="sys-libs/zlib
+ dev-libs/expat
+ net-misc/curl
+ ~media-libs/flac-1.1.2
+ media-libs/libmad
+ >=media-libs/musicbrainz-2.1.0
+ media-libs/libofa
+ media-libs/libvorbis
+ !media-sound/trm
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ # broken script, install fails
+ sed -i -e "s: tta::" configure.in
+ libtoolize --copy --force
+ autoheader
+ automake --foreign --add-missing --copy --include-deps
+ aclocal
+ autoconf
+
+ econf || die "configure failed"
+ emake || die "emake failed"
+ # disabled as broken with Perl 5.8.8
+ #if use perl; then
+ # cd ${S}/perl/tunepimp-perl
+ # perl-app_src_compile || die "perl module failed to compile"
+ #fi
+}
+
+src_install() {
+ cd ${S}
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+ if use python; then
+ cd ${S}/python
+ distutils_src_install
+ insinto /usr/share/doc/${PF}/examples/
+ doins examples/*
+ fi
+# if use perl; then
+# cd ${S}/perl/tunepimp-perl
+# perl-module_src_install || die "perl module failed to install"
+# insinto /usr/share/doc/${PF}/examples/
+# doins examples/*
+# fi
+}