summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-09 18:19:42 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-09 18:19:42 +0000
commit4389293cb7dd0f26ce81b7adafb764e87242527e (patch)
treeb5cf99a7d8e1772c7fcc97c7c71a68d0225d2035 /net-analyzer/nb/files
parentAdd patch for the arm issue with build. Wrt bug#451520. (diff)
downloadhistorical-4389293cb7dd0f26ce81b7adafb764e87242527e.tar.gz
historical-4389293cb7dd0f26ce81b7adafb764e87242527e.tar.bz2
historical-4389293cb7dd0f26ce81b7adafb764e87242527e.zip
Version bump.
Package-Manager: portage-2.2.0_alpha166/cvs/Linux x86_64 Manifest-Sign-Key: 0xA792A613
Diffstat (limited to 'net-analyzer/nb/files')
-rw-r--r--net-analyzer/nb/files/nb-0.8.14-configure.patch15
-rw-r--r--net-analyzer/nb/files/nb-0.8.14-include.patch30
-rw-r--r--net-analyzer/nb/files/nb-0.8.3-configure.patch49
3 files changed, 45 insertions, 49 deletions
diff --git a/net-analyzer/nb/files/nb-0.8.14-configure.patch b/net-analyzer/nb/files/nb-0.8.14-configure.patch
new file mode 100644
index 000000000000..3b0793a90190
--- /dev/null
+++ b/net-analyzer/nb/files/nb-0.8.14-configure.patch
@@ -0,0 +1,15 @@
+--- a/lib/configure.ac
++++ b/lib/configure.ac
+@@ -130,10 +130,10 @@
+ AC_CHECK_LIB(readline,readline,,[AC_MSG_ERROR(Required library -lreadline not found. Specify path in LDFLAGS.)])
+ AC_CHECK_LIB(history,add_history,,[AC_MSG_ERROR(Required library -lhistory not found. Specify path in LDFLAGS.)])
+ #AC_CHECK_LIB(ssl,SSL_library_init,,[AC_MSG_ERROR(Required library -lssl not found. Specify path in LDFLAGS.)])
+-AC_SEARCH_LIBS(SSL_library_init,ssl)
++#AC_SEARCH_LIBS(SSL_library_init,ssl)
+ AC_SEARCH_LIBS(X509_get_subject_name,crypto)
+ #PKG_CHECK_MODULES(libssl,openssl)
+-#PKG_CHECK_MODULES([libssl],[openssl],[LIBS="$LIBS `$PKG_CONFIG --cflags --libs openssl`"],[AC_MSG_ERROR(Required library -lssl not found. You may want to download it from http://www.openssl.org/ or locate it and include in LDFLAGS or LD_LIBRARY_PATH to support this build.)])
++PKG_CHECK_MODULES(libssl,openssl,[LIBS="$LIBS $libssl_LIBS"],[AC_MSG_ERROR(Required library -lssl not found. You may want to download it from http://www.openssl.org/ or locate it and include in LDFLAGS or LD_LIBRARY_PATH to support this build.)])
+
+ AC_SEARCH_LIBS(socket,socket)
+ AC_SEARCH_LIBS(inet_ntoa,nsl)
diff --git a/net-analyzer/nb/files/nb-0.8.14-include.patch b/net-analyzer/nb/files/nb-0.8.14-include.patch
new file mode 100644
index 000000000000..c34965bfe5e5
--- /dev/null
+++ b/net-analyzer/nb/files/nb-0.8.14-include.patch
@@ -0,0 +1,30 @@
+--- a/lib/nbbfi.c
++++ b/lib/nbbfi.c
+@@ -197,6 +197,7 @@
+ *=============================================================================
+ */
+ #include <nb/nbi.h>
++#include <ctype.h> /* isdigit() */
+
+ /**************************************************************************
+ * Index Routines
+--- a/lib/nbkit.c
++++ b/lib/nbkit.c
+@@ -51,6 +51,7 @@
+ #include <pwd.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <stdlib.h> /* system() */
+
+ static int nbKitUsage(void){
+ printf("Usage:\n");
+--- a/module/webster/nb_webster.c
++++ b/module/webster/nb_webster.c
+@@ -78,6 +78,7 @@
+ */
+ #include "config.h"
+ #include <nb/nb.h>
++#include <ctype.h> /* isalnum() */
+
+ #if defined(WIN32)
+
diff --git a/net-analyzer/nb/files/nb-0.8.3-configure.patch b/net-analyzer/nb/files/nb-0.8.3-configure.patch
deleted file mode 100644
index 645c80d0279b..000000000000
--- a/net-analyzer/nb/files/nb-0.8.3-configure.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-1) Use pkg-config to figure out openssl libraries (also fixes underlinking with
- ld.gold, bug #371893).
-2) Respect CFLAGS/LDFLAGS.
-
--jer
-
-
---- a/lib/configure.ac
-+++ b/lib/configure.ac
-@@ -113,7 +113,7 @@
- AC_CHECK_LIB([pcre],[pcre_compile],,[AC_MSG_ERROR(Required library -lpcre not found. You may want to download it from http://www.pcre.org or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
- AC_CHECK_LIB([readline],[readline],,[AC_MSG_ERROR(Required library -lreadline not found. You may want to download it from http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
- AC_CHECK_LIB(history,add_history,,[AC_MSG_ERROR(Required library -lhistory not found. You may want to download it from http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
--AC_CHECK_LIB(ssl,SSL_library_init,,[AC_MSG_ERROR(Required library -lssl not found. You may want to download it from http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
-+PKG_CHECK_MODULES(libssl,openssl,LIBS="$LIBS `$PKG_CONFIG --cflags --libs openssl`",[AC_MSG_ERROR(Required library -lssl not found. You may want to download it from http://www.openssl.org/ or locate it and include directory in LD_LIBRARY_PATH to support this build.)])
-
- AC_SEARCH_LIBS(socket,socket)
- AC_SEARCH_LIBS(inet_ntoa,nsl)
-@@ -152,8 +152,6 @@
- # define a release date variable
- AC_DEFINE_UNQUOTED(NB_COMPILE_PLATFORM,"$host",[Define compile platform])
-
--CFLAGS="-Wall -I/usr/local/include -I/usr/local/ssl/include"
--LDFLAGS="-L/usr/local/ssl/lib"
- case "$host" in
- *-netbsd*)
- AC_DEFINE(NETBSD,,[Define if NetBSD])
---- a/module/configure.ac
-+++ b/module/configure.ac
-@@ -100,8 +100,6 @@
-
- AC_SUBST([NB_MOD_PATH],[../.libs])
-
--CFLAGS="-Wall -I/usr/local/include -I/usr/local/ssl/include"
--LDFLAGS="-L/usr/local/ssl/lib"
-
- #=====================================
- # Checks for header files.
---- a/module/webster/configure.ac
-+++ b/module/webster/configure.ac
-@@ -87,8 +87,6 @@
- # AC_PATH_PROGS([NB],[nb-0.7.5 nb-0.7.4 nb-0.7.3 nb-0.7.2 nb-0.7.1 nb])
- #fi
-
--CFLAGS="-I/usr/local/include -I/usr/local/ssl/include"
--LDFLAGS="-L/usr/local/ssl/lib"
-
- #=====================================
- # Checks for libraries.