summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-17 21:22:47 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-17 21:22:47 +0000
commitafbf82dee448cf44a0be05b48f8a0b7bfe35c77d (patch)
tree928933afc6f9eece73d7d828885d942ade45cd4c /net-analyzer
parentVersion bumped. (diff)
downloadhistorical-afbf82dee448cf44a0be05b48f8a0b7bfe35c77d.tar.gz
historical-afbf82dee448cf44a0be05b48f8a0b7bfe35c77d.tar.bz2
historical-afbf82dee448cf44a0be05b48f8a0b7bfe35c77d.zip
Version bumped.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti/Manifest6
-rw-r--r--net-analyzer/cacti/cacti-0.8.3a.ebuild6
-rw-r--r--net-analyzer/cacti/cacti-0.8.4.ebuild126
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.41
4 files changed, 134 insertions, 5 deletions
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 00222892ddc3..8cde3f563fec 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,7 +1,7 @@
-MD5 bf2115e57ac4e6b87c52b72a244006c5 ChangeLog 1995
+MD5 3ced8fee60962a2a9abe116988cb610a ChangeLog 2135
MD5 2a9c9a8598f1bdac6e2a7c5817621012 cacti-0.6.8a.ebuild 1491
-MD5 559fcab1f357716b87917761265d8a20 cacti-0.8.4.ebuild 4195
-MD5 559fcab1f357716b87917761265d8a20 cacti-0.8.3a.ebuild 4195
+MD5 ba498a08fe21faebd344b597b4dc9aa6 cacti-0.8.4.ebuild 4263
+MD5 94a1530cb2eff9cc4cd699f5701d122d cacti-0.8.3a.ebuild 4264
MD5 36cff775a40a01ca080d9b290109a795 files/digest-cacti-0.6.8a 64
MD5 e91aa7fea352dd63395f14af9492985f files/digest-cacti-0.8.4 63
MD5 68b23916512df61b699d43aa9f7d25a5 files/digest-cacti-0.8.3a 64
diff --git a/net-analyzer/cacti/cacti-0.8.3a.ebuild b/net-analyzer/cacti/cacti-0.8.3a.ebuild
index 060234822c85..75b60e09f31e 100644
--- a/net-analyzer/cacti/cacti-0.8.3a.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.3a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.3a.ebuild,v 1.4 2003/11/17 21:04:31 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.3a.ebuild,v 1.5 2003/11/17 21:22:42 mholzer Exp $
inherit eutils
inherit webapp-apache
@@ -50,8 +50,10 @@ src_install() {
rm -rf cactid
edos2unix `find -type f -name '*.php'`
- chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
+ #chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${PN}
}
pkg_postinst() {
diff --git a/net-analyzer/cacti/cacti-0.8.4.ebuild b/net-analyzer/cacti/cacti-0.8.4.ebuild
new file mode 100644
index 000000000000..a3bef8bdf9da
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.4.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.4.ebuild,v 1.1 2003/11/17 21:22:42 mholzer Exp $
+
+inherit eutils
+inherit webapp-apache
+
+DESCRIPTION="Cacti is a complete frondend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="snmp mysql"
+
+DEPEND=""
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ mysql? ( dev-db/mysql )
+ dev-php/php
+ dev-php/mod_php"
+
+webapp-detect || NO_WEBSERVER=1
+
+HTTPD_USER=apache
+HTTPD_GROUP=apache
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+ dodir ${destdir}
+
+ dohtml docs/{INSTALL,UPGRADE}.htm
+ dodoc docs/{CHANGELOG,CONTRIB}
+ dodoc LICENSE
+
+ rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
+ rm docs/{README,CHANGELOG,CONTRIB}
+ rm LICENSE README
+
+ mv docs/manual .
+ rm -fr docs
+ rm -rf cactid
+
+ edos2unix `find -type f -name '*.php'`
+ #chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
+ cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}.${HTTPD_GROUP} ${PN}
+}
+
+pkg_postinst() {
+ # check to see if we have a previous version installed
+ minor_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f2)"
+ rel_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f3)"
+ if [ ${minor_inst}${rel_inst} -lt 81 ]
+ then
+ einfo
+ einfo "The cacti has been installed to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "5. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ einfo "Test your upgraded installation. When all is fine you can"
+ eingo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ else
+ einfo
+ einfo "The cacti has been copied to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must:"
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "5. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ fi
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.4 b/net-analyzer/cacti/files/digest-cacti-0.8.4
new file mode 100644
index 000000000000..e4f77cf509dd
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.4
@@ -0,0 +1 @@
+MD5 afa100acd57db792dd65f4443268a64d cacti-0.8.4.tar.gz 595419