summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2002-12-04 02:44:02 +0000
committerJon Nall <nall@gentoo.org>2002-12-04 02:44:02 +0000
commit38bc0b37f0e301e2c5a7b1bd05078449efbf9d78 (patch)
treec07356ff98eaabae017ac2c337e90a917ce7e5e9 /net-fs
parentVersion bump. Added a tiny perl fix. (diff)
downloadhistorical-38bc0b37f0e301e2c5a7b1bd05078449efbf9d78.tar.gz
historical-38bc0b37f0e301e2c5a7b1bd05078449efbf9d78.tar.bz2
historical-38bc0b37f0e301e2c5a7b1bd05078449efbf9d78.zip
compiles on ppc now
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/ftpfs/ChangeLog8
-rw-r--r--net-fs/ftpfs/files/digest-ftpfs-0.6.2-r31
-rw-r--r--net-fs/ftpfs/ftpfs-0.6.2-r3.ebuild56
3 files changed, 64 insertions, 1 deletions
diff --git a/net-fs/ftpfs/ChangeLog b/net-fs/ftpfs/ChangeLog
index ad1777f7f58e..994cc5a77869 100644
--- a/net-fs/ftpfs/ChangeLog
+++ b/net-fs/ftpfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/ftpfs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/ftpfs/ChangeLog,v 1.3 2002/05/08 06:03:11 jnelson Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ftpfs/ChangeLog,v 1.4 2002/12/04 02:44:02 nall Exp $
+
+*ftpfs-0.6.2-r3 (03 Dec 2002)
+
+ 03 Dec 2002; Jon Nall <nall@gentoo.org> ftpfs-0.6.2-r3.ebuild :
+ made patch for non-x86 ARCHs (though currently only patch if ppc)
+
*ftpfs-0.6.2-r2 (10 Apr 2002)
8 May 2002; Jon Nelson <jnelson@gentoo.org>: ftpfs-0.6.2-r2.ebuild
diff --git a/net-fs/ftpfs/files/digest-ftpfs-0.6.2-r3 b/net-fs/ftpfs/files/digest-ftpfs-0.6.2-r3
new file mode 100644
index 000000000000..f384845a3421
--- /dev/null
+++ b/net-fs/ftpfs/files/digest-ftpfs-0.6.2-r3
@@ -0,0 +1 @@
+MD5 5e160de7f7237cdb27e5bc6f234e8c14 ftpfs-0.6.2-k2.4.tar.gz 48743
diff --git a/net-fs/ftpfs/ftpfs-0.6.2-r3.ebuild b/net-fs/ftpfs/ftpfs-0.6.2-r3.ebuild
new file mode 100644
index 000000000000..7048f0b40963
--- /dev/null
+++ b/net-fs/ftpfs/ftpfs-0.6.2-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/ftpfs/ftpfs-0.6.2-r3.ebuild,v 1.1 2002/12/04 02:44:02 nall Exp $
+
+MY_P=${P}-k2.4
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A filesystem for mounting FTP volumes"
+SRC_URI="http://ftp1.sourceforge.net/ftpfs/${MY_P}.tar.gz"
+HOMEPAGE="http://ftpfs.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+
+DEPEND="virtual/linux-sources
+ >=sys-apps/portage-1.9.10"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if [ "${ARCH}" = "ppc" ]
+ then
+ einfo "Patching Makefile for non-x86 ARCH"
+ patch -p0 < ${FILESDIR}/ftpfs-0.6.2-makefile-fix.patch || die
+ fi
+
+}
+
+
+src_compile() {
+ check_KV
+ cd ftpfs
+ make || die
+ cd ../ftpmount
+ make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ mv ftpfs/Makefile ftpfs/Makefile.old
+ sed s:"depmod -aq"::g \
+ ftpfs/Makefile.old > ftpfs/Makefile
+
+ make \
+ MODULESDIR=${D}/lib/modules/${KV} \
+ FTPMOUNT=${D}/usr/bin/ftpmount \
+ install || die
+
+ dodoc CHANGELOG
+ dohtml -r docs
+}
+
+pkg_postinst() {
+ echo "running depmod...."
+ depmod -aq || die
+}