summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-01-10 07:42:11 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-01-10 07:42:11 +0000
commit44d798566400406f7fe355d79c21602d3e7783fe (patch)
tree96edbc58ee292d9766200c48a85784af83037263 /net-wireless/hostapd
parentActually, in -* until the patches tarball hits mirrors... sorry for getting y... (diff)
downloadhistorical-44d798566400406f7fe355d79c21602d3e7783fe.tar.gz
historical-44d798566400406f7fe355d79c21602d3e7783fe.tar.bz2
historical-44d798566400406f7fe355d79c21602d3e7783fe.zip
New development version, bumped included madwifi-driver.
Diffstat (limited to 'net-wireless/hostapd')
-rw-r--r--net-wireless/hostapd/ChangeLog7
-rw-r--r--net-wireless/hostapd/Manifest2
-rw-r--r--net-wireless/hostapd/files/digest-hostapd-0.3.42
-rw-r--r--net-wireless/hostapd/hostapd-0.3.4.ebuild81
4 files changed, 91 insertions, 1 deletions
diff --git a/net-wireless/hostapd/ChangeLog b/net-wireless/hostapd/ChangeLog
index 259a8fb57fb7..707c06ae22a7 100644
--- a/net-wireless/hostapd/ChangeLog
+++ b/net-wireless/hostapd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-wireless/hostapd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.16 2005/01/03 11:06:53 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/ChangeLog,v 1.17 2005/01/10 07:41:24 brix Exp $
+
+*hostapd-0.3.4 (10 Jan 2005)
+
+ 10 Jan 2005; Henrik Brix Andersen <brix@gentoo.org> +hostapd-0.3.4.ebuild:
+ New development version, bumped included madwifi-driver.
*hostapd-0.3.3 (03 Jan 2005)
diff --git a/net-wireless/hostapd/Manifest b/net-wireless/hostapd/Manifest
index bca7fa9b73f1..5e20093d9ae6 100644
--- a/net-wireless/hostapd/Manifest
+++ b/net-wireless/hostapd/Manifest
@@ -4,6 +4,7 @@ MD5 b1c88d1ba7b37d7583fe25b17c403083 hostapd-0.3.0.ebuild 1735
MD5 fd633ac9308f504fa6bab995401e65d7 hostapd-0.2.4.ebuild 1075
MD5 8836c297bffc5ae941dc55c190b653e5 hostapd-0.3.2.ebuild 1932
MD5 133443d07434d26d0bb2cf59a76a0072 hostapd-0.2.6.ebuild 1067
+MD5 56060bf403819c426f8ce5f8c7b9ec84 hostapd-0.3.4.ebuild 2071
MD5 deacc7f59da5342bae4878d319ba9b1c ChangeLog 2279
MD5 52a4b928b36a98e530ae455b73f868f5 metadata.xml 462
MD5 711605de7af0e29bef5ea35a1ad30c94 hostapd-0.3.1.ebuild 1777
@@ -14,4 +15,5 @@ MD5 1ba76b2b1bb9b838b8b72d9d99348f46 files/digest-hostapd-0.3.0 149
MD5 3545835b787224800fe3423a60f29808 files/digest-hostapd-0.3.1 149
MD5 30d8ea24bfd552e0638487411450495e files/digest-hostapd-0.3.2 149
MD5 f713d9fe7806353e0d9a06dd39d389c4 files/digest-hostapd-0.3.3 149
+MD5 7b6b425aae76d68299b011725e1de3b7 files/digest-hostapd-0.3.4 150
MD5 cf287b50f0ccd832a08fb3031281cd4f files/hostapd.init.d 858
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.3.4 b/net-wireless/hostapd/files/digest-hostapd-0.3.4
new file mode 100644
index 000000000000..778e339036af
--- /dev/null
+++ b/net-wireless/hostapd/files/digest-hostapd-0.3.4
@@ -0,0 +1,2 @@
+MD5 e6eadcb979df1aa570bd26b3d2e0faab hostapd-0.3.4.tar.gz 244134
+MD5 8237d57be31464ddd7a710704e6755f0 madwifi-cvs-snapshot-2005-01-07.tar.bz2 1586914
diff --git a/net-wireless/hostapd/hostapd-0.3.4.ebuild b/net-wireless/hostapd/hostapd-0.3.4.ebuild
new file mode 100644
index 000000000000..6c67badb9909
--- /dev/null
+++ b/net-wireless/hostapd/hostapd-0.3.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/hostapd-0.3.4.ebuild,v 1.1 2005/01/10 07:41:24 brix Exp $
+
+inherit toolchain-funcs
+
+MADWIFI_VERSION="2005-01-07"
+
+DESCRIPTION="HostAP wireless daemon"
+HOMEPAGE="http://hostap.epitest.fi"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz
+ mirror://gentoo/madwifi-cvs-snapshot-${MADWIFI_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="ssl"
+
+DEPEND=">=net-wireless/hostap-driver-0.3.0
+ ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ local CONFIG=${S}/.config
+
+ unpack ${A}
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > ${CONFIG}
+
+ # authentication methods
+ echo "CONFIG_EAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+ echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
+ echo "CONFIG_IAPP=y" >> ${CONFIG}
+ echo "CONFIG_PKCS12=y" >> ${CONFIG}
+ echo "CONFIG_RADIUS_SERVER=y" >> ${CONFIG}
+ echo "CONFIG_RSN_PREAUTH=y" >> ${CONFIG}
+ echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
+
+ if use ssl; then
+ # SSL authentication methods
+ echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PEAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TLS=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TTLS=y" >> ${CONFIG}
+ fi
+
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_HOSTAP=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_WIRED=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_PRISM54=y" >> ${CONFIG}
+
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I${WORKDIR}/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /etc/hostapd
+ doins hostapd.conf hostapd.accept hostapd.deny
+
+ dosed 's:\(accept_mac_file=\)/etc/hostapd.accept:\1/etc/hostapd/hostapd.accept:g' \
+ /etc/hostapd/hostapd.conf
+ dosed 's:\(deny_mac_file=\)/etc/hostapd.deny:\1/etc/hostapd/hostapd.deny:g' \
+ /etc/hostapd/hostapd.conf
+
+ dosbin hostapd
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/hostapd.init.d hostapd
+
+ dodoc ChangeLog developer.txt README
+
+ docinto examples
+ dodoc madwifi.conf wired.conf
+}