summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-12-07 15:10:02 +0000
committerNed Ludd <solar@gentoo.org>2004-12-07 15:10:02 +0000
commit4b3e5b212b8f819d21fcbdbe728649d9323d25f2 (patch)
treeccfcf92d6a4ef3aa977a8e703c8b273d84037768 /sys-apps/memtest86
parentFix for bug #72461 (diff)
downloadhistorical-4b3e5b212b8f819d21fcbdbe728649d9323d25f2.tar.gz
historical-4b3e5b212b8f819d21fcbdbe728649d9323d25f2.tar.bz2
historical-4b3e5b212b8f819d21fcbdbe728649d9323d25f2.zip
- patched memtest86-3.1a to disable pic on test.c which was causing BREG errors when building. x86 asm guru needed to make the test pic aware someday
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog7
-rw-r--r--sys-apps/memtest86/Manifest19
-rw-r--r--sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch20
-rw-r--r--sys-apps/memtest86/memtest86-3.1a.ebuild7
4 files changed, 41 insertions, 12 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index 65450ca73786..31ed2e750cb8 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/memtest86
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.21 2004/09/25 03:14:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.22 2004/12/07 15:10:02 solar Exp $
+
+ 07 Dec 2004; <solar@gentoo.org> +files/memtest86-3.1a-test-pic.patch,
+ memtest86-3.1a.ebuild:
+ - patched memtest86-3.1a to disable pic on test.c which was causing BREG
+ errors when building. x86 asm guru needed to make the test pic aware someday
*memtest86-3.1a (24 Sep 2004)
diff --git a/sys-apps/memtest86/Manifest b/sys-apps/memtest86/Manifest
index 228e549128c2..0df01616f56a 100644
--- a/sys-apps/memtest86/Manifest
+++ b/sys-apps/memtest86/Manifest
@@ -1,17 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 1ad4568a2623d55e1ebee53748579aa2 ChangeLog 3075
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 ca8ea7342946bdc0115570a3edaf17d0 memtest86-3.0-r2.ebuild 1959
-MD5 9270a86c267aca796f311133b12e7a84 memtest86-3.1a.ebuild 1961
-MD5 60d6fd47214101182d2f20bf6075f90a files/digest-memtest86-3.0-r2 65
+MD5 c7bf223a3a04518bcbb94349f0689f24 memtest86-3.1a.ebuild 1943
+MD5 ce3122dfdb224b76aa30cc382699a8ba ChangeLog 3326
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 321f79e41c5c62eb61f0fdd2a971b556 files/memtest86-3.0.patch 749
+MD5 979465b1a112b7a052c36a57b8878867 files/memtest86-3.1a-test-pic.patch 606
MD5 1a7396d4f6539280d03b33e8047f9cd9 files/digest-memtest86-3.1a 66
+MD5 60d6fd47214101182d2f20bf6075f90a files/digest-memtest86-3.0-r2 65
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
+Version: GnuPG v1.2.4 (GNU/Linux)
-iD8DBQFBVOKYHTu7gpaalycRAknfAJ96imGLykrW798Qo+QAH0LaNFyRRACg76kR
-eaYh6SDQtmN6xfgZUwT+4Pc=
-=lt2X
+iQCVAwUBQbXHuJ4WFLgrx1GWAQI/AwP/T/ck57k7n/k5A3n314kDZIHvVzRtAyBI
+oG8b/s+5d2ZOczs/yazlQlC6j/8ldviwI1B6DjF0zFySSUr8Zwiyj8KAPDxEo4xi
+3r47uJBD6SKT47PSEkPL9MQl7WSer41gbB4MO1c/T4sSD74b5A/WElKdsWdL/sPV
+23F/fbpTZ0Q=
+=csC4
-----END PGP SIGNATURE-----
diff --git a/sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch b/sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch
new file mode 100644
index 000000000000..9c76ef536886
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-3.1a-test-pic.patch
@@ -0,0 +1,20 @@
+--- Makefile.orig 2004-11-12 07:52:39.000000000 -0500
++++ Makefile 2004-11-12 07:52:02.000000000 -0500
+@@ -12,7 +12,7 @@
+ #
+ # gcc compiler options, these settings should suffice
+ #
+-CCFLAGS=-Wall -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding
++CCFLAGS=-Wall -march=i486 -Os -fomit-frame-pointer -fno-builtin -ffreestanding -fno-stack-protector
+
+ AS=as -k
+
+@@ -26,7 +26,7 @@
+ $(CC) -S $(CCFLAGS) -fPIC reloc.c
+
+ test.o: test.c test.h defs.h config.h
+- $(CC) -c $(CCFLAGS) test.c
++ $(CC) -c $(CCFLAGS) -fno-PIC test.c
+
+ main.o: main.c test.h defs.h
+ $(CC) -c $(CCFLAGS) -fPIC main.c
diff --git a/sys-apps/memtest86/memtest86-3.1a.ebuild b/sys-apps/memtest86/memtest86-3.1a.ebuild
index 3cbfbb5b1cc4..0f5a49e13c6c 100644
--- a/sys-apps/memtest86/memtest86-3.1a.ebuild
+++ b/sys-apps/memtest86/memtest86-3.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.1a.ebuild,v 1.1 2004/09/25 03:12:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-3.1a.ebuild,v 1.2 2004/12/07 15:10:02 solar Exp $
inherit mount-boot eutils
@@ -19,8 +19,9 @@ src_unpack() {
unpack ${A}
cd ${S}
- # a little fix to make gcc-3.3.x happy
-# epatch ${FILESDIR}/memtest86-3.0.patch
+ # bug 66630
+ epatch ${FILESDIR}/memtest86-3.1a-test-pic.patch
+
sed -i -e '/DISCARD/d' memtest_shared.lds
if use serial ; then