summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-24 01:36:26 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-02-24 01:36:26 +0000
commite9c36f7976460a50b7512fed59d0f50bcd9d0022 (patch)
tree321dcd30e929b7bd1900233ac027a9f5d619fc9b /sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild
parentCleanup, use a single patch rather than a patches tarball (patches are split ... (diff)
downloadhistorical-e9c36f7976460a50b7512fed59d0f50bcd9d0022.tar.gz
historical-e9c36f7976460a50b7512fed59d0f50bcd9d0022.tar.bz2
historical-e9c36f7976460a50b7512fed59d0f50bcd9d0022.zip
Build the module straight into the ebuild, and make sure to hide symbols that are not part of the interface.
Package-Manager: portage-2.2.0_alpha163/cvs/Linux x86_64 Manifest-Sign-Key: 0x1CD13C8AD4301342
Diffstat (limited to 'sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild')
-rw-r--r--sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild b/sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild
new file mode 100644
index 000000000000..71fcf4690b2c
--- /dev/null
+++ b/sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_radius/pam_radius-1.3.17-r1.ebuild,v 1.1 2013/02/24 01:36:09 flameeyes Exp $
+
+EAPI=5
+
+inherit eutils pam toolchain-funcs
+
+DESCRIPTION="PAM RADIUS authentication module"
+HOMEPAGE="http://www.freeradius.org/pam_radius_auth/"
+SRC_URI="ftp://ftp.freeradius.org/pub/radius/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+doecho() {
+ echo "$@"
+ "$@" || die
+}
+
+src_compile() {
+ # using the Makefile would require patching it to work properly, so
+ # rather simply re-create it here.
+
+ pammod_hide_symbols
+ doecho $(tc-getCC) ${CFLAGS} -shared -fPIC ${LDFLAGS} *.c -lpam -o pam_radius_auth.so
+}
+
+src_install() {
+ dopammod pam_radius_auth.so
+
+ insopts -m600
+ insinto /etc/raddb
+ doins "${FILESDIR}"/server
+
+ dodoc README Changelog USAGE
+}
+
+pkg_postinst() {
+ elog "Before you can use this you'll have to add RADIUS servers to /etc/raddb/server."
+ elog "The usage of pam_radius_auth module is explained in /usr/share/doc/${PF}/USAGE."
+}