summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-06-26 01:02:58 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-06-26 01:02:58 +0000
commit30eb299b57b5079210539ae49cd3f684694811c0 (patch)
treea44770ed3f1e9b0dc9f3526adcb62ad2df1eb2ef /sys-boot
parentamd64 (diff)
downloadhistorical-30eb299b57b5079210539ae49cd3f684694811c0.tar.gz
historical-30eb299b57b5079210539ae49cd3f684694811c0.tar.bz2
historical-30eb299b57b5079210539ae49cd3f684694811c0.zip
Long-overdue revision bump. There may be issues in building w/ gcc-3.4.x, but these will get ironed out later.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/colo/ChangeLog6
-rw-r--r--sys-boot/colo/Manifest8
-rw-r--r--sys-boot/colo/colo-1.10.ebuild96
-rw-r--r--sys-boot/colo/files/digest-colo-1.101
4 files changed, 107 insertions, 4 deletions
diff --git a/sys-boot/colo/ChangeLog b/sys-boot/colo/ChangeLog
index ad1dcd3f81a6..9d3685ebb51a 100644
--- a/sys-boot/colo/ChangeLog
+++ b/sys-boot/colo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/colo
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.5 2004/06/24 22:33:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/ChangeLog,v 1.6 2004/06/26 01:02:58 kumba Exp $
+
+ 25 Jun 2004; Joshua Kinard <kumba@gentoo.org> :
+ Long-overdue revision bump. There may be issues in building w/ gcc-3.4.x, but
+ these will get ironed out later.
*colo-1.9 (15 May 2004)
diff --git a/sys-boot/colo/Manifest b/sys-boot/colo/Manifest
index 5328be668011..2c5016f2bcd0 100644
--- a/sys-boot/colo/Manifest
+++ b/sys-boot/colo/Manifest
@@ -1,12 +1,14 @@
-MD5 8827f810afdc59f57a941bb8b88d6194 colo-1.9.ebuild 3100
+MD5 3a937eaa6af5214360ace0beb544b435 ChangeLog 1095
MD5 f3ffad95e28eeeae6fbd2324572c8aad colo-1.4.ebuild 3320
MD5 9792974398d5c79c43e81cd23c155eb8 colo-1.6.ebuild 3046
MD5 9e21b3f483ba6ad345eb5bac567351ce colo-1.8.ebuild 3100
-MD5 3cb9affc3e5d6b7b369faa42477a723f ChangeLog 932
+MD5 8827f810afdc59f57a941bb8b88d6194 colo-1.9.ebuild 3100
MD5 821bbe104fd36eab5f08495277bc5adb metadata.xml 364
+MD5 2f0bb3bcf579bfb6caa80d948f0bc055 colo-1.10.ebuild 3098
+MD5 9f076059dca1f289e170da5afd3e7f30 files/digest-colo-1.10 61
+MD5 c1b257fb8b0e15a8f27cbef798f5aede files/colo-1.4-gentoo.patch 2631
MD5 da6cc3a10feca032228e456bd9e77502 files/colo-1.6-gentoo.patch 1285
MD5 6a9e242bf3b159c4ead248ff40151b32 files/default.boot.example 9
-MD5 c1b257fb8b0e15a8f27cbef798f5aede files/colo-1.4-gentoo.patch 2631
MD5 7c11a1ef9a1547e23ae00c09ef797d11 files/digest-colo-1.4 63
MD5 68f29ebc1f7fc45aaf0b1a75db19a3e5 files/digest-colo-1.6 60
MD5 8d935262da6b9a313b6dd36c04cc441a files/digest-colo-1.8 60
diff --git a/sys-boot/colo/colo-1.10.ebuild b/sys-boot/colo/colo-1.10.ebuild
new file mode 100644
index 000000000000..3dc99f62540a
--- /dev/null
+++ b/sys-boot/colo/colo-1.10.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/colo/colo-1.10.ebuild,v 1.1 2004/06/26 01:02:58 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="CObalt Linux lOader - Modern bootloader for Cobalt MIPS machines"
+HOMEPAGE="http://www.colonel-panic.org/cobalt-mips/"
+SRC_URI="http://www.colonel-panic.org/cobalt-mips/colo/colo-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~mips"
+IUSE=""
+DEPEND=""
+RESTRICT="nostrip"
+
+
+pkg_setup() {
+ # See if we're on a cobalt system (must use the cobalt-mips profile)
+ if [ "${PROFILE_ARCH}" != "cobalt" ]; then
+ echo -e ""
+ eerror "This package is only intended for the Cobalt Microserver MIPS-based"
+ eerror "systems. It will not function on any other MIPS-based system or any"
+ eerror "other architecture"
+ echo -e ""
+ die
+ fi
+}
+
+# Not needed for this release, maybe others...
+#src_unpack() {
+# unpack ${A}
+#
+# # patch Docs
+# cd ${S}
+# epatch ${FILESDIR}/${P}-gentoo.patch
+#}
+
+src_compile() {
+ # boot-loader
+ cd ${S}
+ make clean || die # emake breaks the build
+ make || die
+
+ # flash-tool
+ cd ${S}/tools/flash-tool
+ make clean || die
+ make || die
+}
+
+src_install() {
+ # bins
+ cd ${S}
+ dodir /usr/lib/colo
+ cp binaries/colo-chain.elf ${D}/usr/lib/colo
+ cp binaries/colo-rom-image.bin ${D}/usr/lib/colo
+ cp ${FILESDIR}/default.boot.example ${D}/usr/lib/colo/default.colo.example
+
+ # docs
+ dodoc CHANGES COPYING INSTALL README README.{restore,shell} TODO
+
+ # flash-tool
+ dosbin tools/flash-tool/flash-tool
+}
+
+pkg_postinst() {
+ echo -e ""
+ einfo "Binaries for this bootloader have been stored in"
+ einfo "/usr/lib/cobalt-bootloader. Documentation has been"
+ einfo "installed in /usr/share/doc/${PF}. The flash utility"
+ einfo "has been installed as /usr/sbin/flash-tool. An example"
+ einfo "default.colo has been placed in /usr/lib/colo. It is"
+ einfo "a script file the bootloader uses to execute a series"
+ einfo "of commands to load the machine. If you desire the"
+ einfo "machine to boot to the bootloader command prompt, copy"
+ einfo "/usr/lib/colo/default.colo.example to /boot/default.colo,"
+ einfo "otherwise the bootloader will attempt to automatically"
+ einfo "boot /boot/vmlinux.gz. It is recommended that you edit"
+ einfo "the default.colo.example script to fit your needs and"
+ einfo "place it in /boot as default.colo."
+ echo -e ""
+ ewarn "Note: It is HIGHLY recommended that you use the chain"
+ ewarn "bootloader (colo-chain.elf) first before attempting to"
+ ewarn "write the bootloader to the flash chip to verify that"
+ ewarn "it will work for you. It is also recommended that"
+ ewarn "you read the documentation in /usr/share/doc/${PF}"
+ ewarn "as it explains how to properly use this package."
+ echo -e ""
+ eerror "Warning: Make sure that IF you plan on flashing the"
+ eerror "bootloader into the flash chip that you are using a"
+ eerror "modern 2.4 Linux kernel (i.e., >2.4.18), otherwise"
+ eerror "you run a risk of destroying the contents of the"
+ eerror "flash chip and rendering the machine unusable."
+ echo -e ""
+ echo -e ""
+}
diff --git a/sys-boot/colo/files/digest-colo-1.10 b/sys-boot/colo/files/digest-colo-1.10
new file mode 100644
index 000000000000..d7b975652691
--- /dev/null
+++ b/sys-boot/colo/files/digest-colo-1.10
@@ -0,0 +1 @@
+MD5 6e2ba1d2826fb51ce18cab3bc29aee91 colo-1.10.tar.gz 211446