summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2009-03-29 19:44:05 +0000
committerCaleb Tennis <caleb@gentoo.org>2009-03-29 19:44:05 +0000
commit2afc9c5a999136f050130edf9dbcbd42cd39913d (patch)
tree5fb3d3ba02cef959125ddbe2ac008ee4ef9f7697 /sys-cluster/drbd/drbd-8.0.16.ebuild
parentVersion bump (diff)
downloadhistorical-2afc9c5a999136f050130edf9dbcbd42cd39913d.tar.gz
historical-2afc9c5a999136f050130edf9dbcbd42cd39913d.tar.bz2
historical-2afc9c5a999136f050130edf9dbcbd42cd39913d.zip
Version bump
Package-Manager: portage-2.1.6.9/cvs/Linux i686
Diffstat (limited to 'sys-cluster/drbd/drbd-8.0.16.ebuild')
-rw-r--r--sys-cluster/drbd/drbd-8.0.16.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/drbd/drbd-8.0.16.ebuild b/sys-cluster/drbd/drbd-8.0.16.ebuild
new file mode 100644
index 000000000000..69f1cdb35691
--- /dev/null
+++ b/sys-cluster/drbd/drbd-8.0.16.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/drbd/drbd-8.0.16.ebuild,v 1.1 2009/03/29 19:44:05 caleb Exp $
+
+inherit eutils versionator
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+MY_PV="${PV/_/}"
+MY_MAJ_PV="$(get_version_component_range 1-2 ${PV})"
+DESCRIPTION="mirror/replicate block-devices across a network-connection"
+SRC_URI="http://oss.linbit.com/drbd/${MY_MAJ_PV}/${PN}-${MY_PV}.tar.gz"
+HOMEPAGE="http://www.drbd.org"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+PDEPEND="~sys-cluster/drbd-kernel-${PV}"
+
+SLOT="0"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ emake -j1 tools || die "compile problem"
+}
+
+src_install() {
+ emake PREFIX="${D}" install-tools || die "install problem"
+
+ # gentoo-ish init-script
+ newinitd "${FILESDIR}"/${PN}-8.0.rc ${PN} || die
+
+ # docs
+ dodoc README ChangeLog ROADMAP
+
+ # we put drbd.conf into docs
+ # it doesnt make sense to install a default conf in /etc
+ # put it to the docs
+ rm -f "${D}"/etc/drbd.conf
+ dodoc scripts/drbd.conf || die
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Please copy and gunzip the configuration file"
+ einfo "drbd.conf from /usr/share/doc/${PF} to /etc"
+ einfo "and edit it to your needs. Helpful commands:"
+ einfo "man 5 drbd.conf"
+ einfo "man 8 drbdsetup"
+ einfo "man 8 drbdadm"
+ einfo "man 8 drbddisk"
+ einfo "man 8 drbdmeta"
+ einfo ""
+}