summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-10-12 10:56:41 +0000
committerChristian Heim <phreak@gentoo.org>2006-10-12 10:56:41 +0000
commitff1b5316e0088cc9053bb5bac4df67b67c613616 (patch)
treec0116d7ab1bb3b1e9d4ec77eacbd9871f080c4f7 /sys-cluster/vzctl
parentAdding USE=logrotate for sys-cluster/vzctl. (diff)
downloadhistorical-ff1b5316e0088cc9053bb5bac4df67b67c613616.tar.gz
historical-ff1b5316e0088cc9053bb5bac4df67b67c613616.tar.bz2
historical-ff1b5316e0088cc9053bb5bac4df67b67c613616.zip
Version bump (partly fixing #150897); cleaning older version(s).
Package-Manager: portage-2.1.2_pre2-r9
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.126
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.12.ebuild77
3 files changed, 90 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 26fe55aa3cb4..0bd37c504963 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.35 2006/09/06 16:46:47 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.36 2006/10/12 10:56:41 phreak Exp $
+
+*vzctl-3.0.12 (12 Oct 2006)
+
+ 12 Oct 2006; Christian Heim <phreak@gentoo.org> -vzctl-3.0.11.ebuild,
+ +vzctl-3.0.12.ebuild:
+ Version bump (partly fixing #150897); cleaning older version(s).
06 Sep 2006; Benedikt Böhm <hollow@gentoo.org> vzctl-3.0.11-r1.ebuild:
add info for new SRC_URI for future releases
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.12 b/sys-cluster/vzctl/files/digest-vzctl-3.0.12
new file mode 100644
index 000000000000..fc32606b6db6
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.12
@@ -0,0 +1,6 @@
+MD5 ba83f2b8949d9c1ed469bd325fb47840 vzctl-3.0.12.tar.bz2 127309
+RMD160 9e94be2d61a8e1c9c9be1947d45677c24f763649 vzctl-3.0.12.tar.bz2 127309
+SHA256 d165f551c2004211d4001d5f8764dbe0249d61fe61632f4ce5b26c01b99897f9 vzctl-3.0.12.tar.bz2 127309
+MD5 2c63e918c4a4946d0ba752ad5081a57a vzctl-patches-3.0.12.tar.bz2 3307
+RMD160 6f504387ed20f25f9f10724e835a3207be0f49af vzctl-patches-3.0.12.tar.bz2 3307
+SHA256 0efd0c067743501dc12f96d58849717e1442e1b8e4a6763a9e3ee5d32c35ac41 vzctl-patches-3.0.12.tar.bz2 3307
diff --git a/sys-cluster/vzctl/vzctl-3.0.12.ebuild b/sys-cluster/vzctl/vzctl-3.0.12.ebuild
new file mode 100644
index 000000000000..b2df99bef181
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.12.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.12.ebuild,v 1.1 2006/10/12 10:56:41 phreak Exp $
+
+inherit bash-completion eutils flag-o-matic multilib
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2
+ http://dev.gentoo.org/~phreak/distfiles/${PN}-patches-${PVR}.tar.bz2
+ http://dev.gentoo.org/~hollow/distfiles/${PN}-patches-${PVR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion logrotate udev"
+
+RDEPEND="logrotate? ( app-admin/logrotate )
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ udev? ( sys-fs/udev )
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch "${WORKDIR}/patches"/*.patch
+}
+
+src_compile() {
+ append-flags -Wall -g2
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/vzctl" install install-gentoo || die "make install failed"
+
+ # the get_libdir in `make install' breaks src/Makefile's logic (and thus all
+ # contained tools), so we have to create a env.d entry for vzctl's LDPATH.
+ dodir /etc/env.d
+ echo "LDPATH=\"/usr/$(get_libdir)/vzctl\"" > "${D}"/etc/env.d/05vzctl
+
+ # Remove udev files unless USE=udev
+ use udev || rm -rf "${D}"/etc/udev
+
+ # Remove the bash-completion and use dobashcompletion to install it in the
+ # right place!
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+
+ # Remove the logrotate entr unless USE=logrotate
+ use logrotate || rm -rf "${D}"/etc/logrotate.d
+
+ # Provide a symlink for vz.conf (fixing #138462)
+# dosym /etc/vz/vz.conf /etc/conf.d/vz
+
+ # Remove cruftie sysconfig entries
+ # We can get rid of that once ovz #254 is solved
+ rm -rf "${D}"/etc/sysconfig
+}
+
+pkg_postinst() {
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}