summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJochen Maes <sejo@gentoo.org>2005-05-16 14:31:22 +0000
committerJochen Maes <sejo@gentoo.org>2005-05-16 14:31:22 +0000
commit3cea6ebbc53774ea3f454af45d474e560ea80909 (patch)
tree1161ebdb0b5093eb1edd0b19139dcb4008059c9a /www-apps/dragonflycms
parentInitial import, ebuild based on the contribution by Josh Nichols <nichoj@alum... (diff)
downloadhistorical-3cea6ebbc53774ea3f454af45d474e560ea80909.tar.gz
historical-3cea6ebbc53774ea3f454af45d474e560ea80909.tar.bz2
historical-3cea6ebbc53774ea3f454af45d474e560ea80909.zip
first commit for dragonflycms
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'www-apps/dragonflycms')
-rw-r--r--www-apps/dragonflycms/ChangeLog7
-rw-r--r--www-apps/dragonflycms/Manifest15
-rw-r--r--www-apps/dragonflycms/dragonflycms-9.0.3.0.ebuild49
-rw-r--r--www-apps/dragonflycms/files/digest-dragonflycms-9.0.3.01
-rw-r--r--www-apps/dragonflycms/files/postinstall-en.txt9
-rw-r--r--www-apps/dragonflycms/metadata.xml16
6 files changed, 97 insertions, 0 deletions
diff --git a/www-apps/dragonflycms/ChangeLog b/www-apps/dragonflycms/ChangeLog
new file mode 100644
index 000000000000..2a544351fe44
--- /dev/null
+++ b/www-apps/dragonflycms/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for www-apps/dragonflycms
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dragonflycms/ChangeLog,v 1.1 2005/05/16 14:31:22 sejo Exp $
+
+ 16 May 2005; Jochen Maes <sejo@gentoo.org> :
+ Initial ebuild
+
diff --git a/www-apps/dragonflycms/Manifest b/www-apps/dragonflycms/Manifest
new file mode 100644
index 000000000000..5fb6fde743e8
--- /dev/null
+++ b/www-apps/dragonflycms/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 aac6036deccb54cf52bb257c7de3ac61 ChangeLog 278
+MD5 ed0191aae14b6c7743eb9b27b1e0202f metadata.xml 461
+MD5 08d0b805d5573660aa05e36b4d584d00 dragonflycms-9.0.3.0.ebuild 1073
+MD5 0de8c25d7b281327a6e87009d44c9f20 files/digest-dragonflycms-9.0.3.0 70
+MD5 64a19aed532f6b3b4729c0819b6bfedf files/postinstall-en.txt 196
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCiK5XMXMsRNMHhmARAlMvAJ4vGF4knqaFq704Mrn6PJoxhcwdhQCg5cAz
+WbJTrjvkw3WmdvDXVx3Zghg=
+=1nnS
+-----END PGP SIGNATURE-----
diff --git a/www-apps/dragonflycms/dragonflycms-9.0.3.0.ebuild b/www-apps/dragonflycms/dragonflycms-9.0.3.0.ebuild
new file mode 100644
index 000000000000..e2db7687e649
--- /dev/null
+++ b/www-apps/dragonflycms/dragonflycms-9.0.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/dragonflycms/dragonflycms-9.0.3.0.ebuild,v 1.1 2005/05/16 14:31:22 sejo Exp $
+
+inherit webapp
+
+MY_P=Dragonfly${PV}
+DESCRIPTION="DragonFly CMS is an Open Source CMS/Portal in php"
+HOMEPAGE="http://dragonflycms.org"
+SRC_URI="mirror://gentoo/$MY_P.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND=">=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ virtual/httpd-php"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_install() {
+
+ webapp_src_preinst
+
+ #Do the documentation
+ insinto /usr/share/doc/${PF}
+ doins -r ${WORKDIR}/documentation/*
+
+ #installing files where they need to be.
+ einfo "installing php main files"
+ cp -r ${WORKDIR}/public_html/* ${D}${MY_HTDOCSDIR}
+ einfo "Done"
+
+ #identiy the configuration file the app uses
+
+ webapp_configfile ${MY_HTDOCSDIR}/config.php
+
+ # add the postinstall instructions
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ # done, now strut the stuff
+
+ webapp_src_install
+
+}
diff --git a/www-apps/dragonflycms/files/digest-dragonflycms-9.0.3.0 b/www-apps/dragonflycms/files/digest-dragonflycms-9.0.3.0
new file mode 100644
index 000000000000..dfe0f8cffc7a
--- /dev/null
+++ b/www-apps/dragonflycms/files/digest-dragonflycms-9.0.3.0
@@ -0,0 +1 @@
+MD5 0440927ff7ef378aa187e5ff61e753e7 Dragonfly9.0.3.0.tar.bz2 1359238
diff --git a/www-apps/dragonflycms/files/postinstall-en.txt b/www-apps/dragonflycms/files/postinstall-en.txt
new file mode 100644
index 000000000000..a580f4521ce8
--- /dev/null
+++ b/www-apps/dragonflycms/files/postinstall-en.txt
@@ -0,0 +1,9 @@
+To complete your installation, you must
+
+1) add a database to mysql that will contain your DragonFly tables
+
+2) install by going to http://localhost/dragonflycms/install.php
+
+Enjoy DragonFly!!!
+
+
diff --git a/www-apps/dragonflycms/metadata.xml b/www-apps/dragonflycms/metadata.xml
new file mode 100644
index 000000000000..d6ec37e9ce41
--- /dev/null
+++ b/www-apps/dragonflycms/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd></herd>
+<maintainer>
+<email>sejo@gentoo.org</email>
+<name>Jochen Maes</name>
+</maintainer>
+<longdescription lang="en">
+ DragonFly CMS is an Opensource CMS/portal based on CPG-Nuke.
+</longdescription>
+<longdescription lang="nl">
+ DragonFLy CMS is een Opensource CMS/portaal gebaseerd op CPG-Nuke.
+</longdescription>
+</pkgmetadata>
+