summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-15 19:43:53 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-15 19:43:53 +0000
commitcef7f586a134be4ca907ecdf812b8b94c9885112 (patch)
treef5a99895e575fd3d2a2caa9f2b86e0b9ec68fa39 /x11-libs/libaosd
parentFix building with >=media-gfx/exiv2-0.21. (diff)
downloadhistorical-cef7f586a134be4ca907ecdf812b8b94c9885112.tar.gz
historical-cef7f586a134be4ca907ecdf812b8b94c9885112.tar.bz2
historical-cef7f586a134be4ca907ecdf812b8b94c9885112.zip
Add a new ebuild for libaosd, as requested per bug #351741. Thanks to Erik McNellis for the initial ebuild.
Package-Manager: portage-2.2.0_alpha15_p1/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/libaosd')
-rw-r--r--x11-libs/libaosd/ChangeLog11
-rw-r--r--x11-libs/libaosd/Manifest14
-rw-r--r--x11-libs/libaosd/libaosd-0.2.7.ebuild36
-rw-r--r--x11-libs/libaosd/metadata.xml14
4 files changed, 75 insertions, 0 deletions
diff --git a/x11-libs/libaosd/ChangeLog b/x11-libs/libaosd/ChangeLog
new file mode 100644
index 000000000000..c81582946ae6
--- /dev/null
+++ b/x11-libs/libaosd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-libs/libaosd
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libaosd/ChangeLog,v 1.1 2011/01/15 19:43:53 mgorny Exp $
+
+*libaosd-0.2.7 (15 Jan 2011)
+
+ 15 Jan 2011; Michał Górny <mgorny@gentoo.org> +libaosd-0.2.7.ebuild,
+ +metadata.xml:
+ Add a new ebuild for libaosd, as requested per bug #351741. Thanks to Erik
+ McNellis for the initial ebuild.
+
diff --git a/x11-libs/libaosd/Manifest b/x11-libs/libaosd/Manifest
new file mode 100644
index 000000000000..98ef7bb0ee5a
--- /dev/null
+++ b/x11-libs/libaosd/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST libaosd-0.2.7.tgz 89908 RMD160 42fcd57b68dfa8f4db78d909fb37431f761fbee9 SHA1 f3508e4ccb166bed17aa31129c53d17b2f2d3836 SHA256 073f30270964688f0cee9c59a46f03b74f73441f5adbe79d53f7787d35d37b8d
+EBUILD libaosd-0.2.7.ebuild 864 RMD160 b866f834042833ce1826e0b1bab2125916de5b4e SHA1 1cb426d43226ce080146c037f6c136b2fe84d38b SHA256 169fdff6f4ba0a348fc8681ffea25b6db7ee96f3fe5b4fd32f9bce7d9e4d323d
+MISC ChangeLog 438 RMD160 e34623e7e8c6600c208259440d6a27a4a03ca5ee SHA1 6ed499757611ba178ef928925cf7e8618a359642 SHA256 b6a1545e5dbb48661d10c7cb6396b908ee9060992c65cc8edc49eebe9905c78c
+MISC metadata.xml 424 RMD160 b6cd0a4814dedc5ba3d28cf3d61c71f13d849b0c SHA1 bddfd794a665b188e0687ff0a9ce238803f10eb2 SHA256 52add79244f278811c38c17045674f954b906343b2e45065a255e8c8d529b1b1
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAk0x+QAACgkQnGSe5QXeB7t4MwCgh7l4ukuKuQ+279t6hdHmnMdJ
+PBIAoK8nvQZnzcbeqEyFm4XPdxuS9cDN
+=8Ib5
+-----END PGP SIGNATURE-----
diff --git a/x11-libs/libaosd/libaosd-0.2.7.ebuild b/x11-libs/libaosd/libaosd-0.2.7.ebuild
new file mode 100644
index 000000000000..9c192ba29b32
--- /dev/null
+++ b/x11-libs/libaosd/libaosd-0.2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libaosd/libaosd-0.2.7.ebuild,v 1.1 2011/01/15 19:43:53 mgorny Exp $
+
+EAPI=3
+inherit autotools-utils
+
+DESCRIPTION="An advanced on screen display (OSD) library"
+HOMEPAGE="http://www.atheme.org/project/libaosd"
+SRC_URI="http://distfiles.atheme.org/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pango +tools xcomposite"
+
+RDEPEND="x11-libs/cairo
+ x11-libs/libX11
+ x11-libs/libXrender
+ pango? ( x11-libs/pango )
+ tools? ( dev-libs/glib:2 )
+ xcomposite? ( x11-libs/libXcomposite )"
+DEPEND="${RDEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+DOCS=( Changelog )
+
+src_configure() {
+ myeconfargs=(
+ $(use_enable tools glib)
+ $(use_enable pango pangocairo)
+ $(use_enable xcomposite)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/x11-libs/libaosd/metadata.xml b/x11-libs/libaosd/metadata.xml
new file mode 100644
index 000000000000..cecb7e16983d
--- /dev/null
+++ b/x11-libs/libaosd/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+
+ <use>
+ <flag name='pango'>Enable the textual helpers (requires pangocairo).</flag>
+ <flag name='tools'>Install the aosd_cat tool (requires glib-2.0).</flag>
+ </use>
+</pkgmetadata>