summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-21 09:15:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-21 09:15:55 +0000
commit3c26f0ece5fcd233e58e7694b970ccb28b65ac90 (patch)
treeac592b490591298523800601ffa530ce744058c8 /x11-wm/openbox
parentlibwww unmasked (diff)
downloadhistorical-3c26f0ece5fcd233e58e7694b970ccb28b65ac90.tar.gz
historical-3c26f0ece5fcd233e58e7694b970ccb28b65ac90.tar.bz2
historical-3c26f0ece5fcd233e58e7694b970ccb28b65ac90.zip
version bump
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/ChangeLog10
-rw-r--r--x11-wm/openbox/files/digest-openbox-1.2.31
-rw-r--r--x11-wm/openbox/openbox-1.2.3.ebuild58
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-wm/openbox/ChangeLog b/x11-wm/openbox/ChangeLog
index e3a0f3c9f0fe..87cd0c875c89 100644
--- a/x11-wm/openbox/ChangeLog
+++ b/x11-wm/openbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/openbox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.2 2002/05/26 00:38:16 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/ChangeLog,v 1.3 2002/06/21 09:15:55 seemant Exp $
+
+*openbox-1.2.3 (21 Jun 2002)
+
+ 21 Jun 2002; Seemant Kulleen <seemant@gentoo.org> openbox-1.2.3.ebuild
+ files/digest-openbox-1.2.3 :
+
+ Version bump to newest development, which upstream reports as being quite
+ stable and of which they encourage the use.
*openbox-0.99.3 (25 May 2002)
diff --git a/x11-wm/openbox/files/digest-openbox-1.2.3 b/x11-wm/openbox/files/digest-openbox-1.2.3
new file mode 100644
index 000000000000..6c37d0edc5bb
--- /dev/null
+++ b/x11-wm/openbox/files/digest-openbox-1.2.3
@@ -0,0 +1 @@
+MD5 b187371da118c4e063cbbe3e9a5b0cf0 openbox-1.2.3.tar.gz 348181
diff --git a/x11-wm/openbox/openbox-1.2.3.ebuild b/x11-wm/openbox/openbox-1.2.3.ebuild
new file mode 100644
index 000000000000..f396f2221934
--- /dev/null
+++ b/x11-wm/openbox/openbox-1.2.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/openbox/openbox-1.2.3.ebuild,v 1.1 2002/06/21 09:15:55 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on BlackBox"
+SRC_URI="ftp://sunsite.dk/projects/openbox/${P}.tar.gz"
+HOMEPAGE="http://openbox.sunsite.dk"
+
+DEPEND="virtual/x11"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/blackbox"
+
+SLOT="0"
+LICENSE="as-is"
+
+src_compile() {
+ local myconf
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ use kde \
+ && myconf="${myconf} --enable-kde" \
+ && export KDEDIR=/usr/kde/2 \
+ || myconf="${myconf} --disable-kde"
+
+ use gnome \
+ && myconf="${myconf} --enable-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ econf \
+ --with-x \
+ --enable-shape \
+ --enable-slit \
+ --enable-interlace \
+ --enable-clobber \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+
+ einstall \
+ sysconfdir=${D}/etc/X11/openbox || die
+
+ dodoc CHANGE* AUTHORS INSTALL README* TODO LICENSE BUGS CodingStyle
+ docinto data
+ dodoc data/README*
+
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/openbox" > ${D}/etc/X11/Sessions/openbox
+ chmod +x ${D}/etc/X11/Sessions/openbox
+}