summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-12-18 18:57:24 +0000
committerDaniel Goller <morfic@gentoo.org>2004-12-18 18:57:24 +0000
commitda242a5391958bedaf0f995fd5d4ce2181e0a7ae (patch)
treed88a71f405784066faa7c8d84cf4ace7bdb66aa3 /xfce-base/xfce4-panel
parentInitial commit. (diff)
downloadhistorical-da242a5391958bedaf0f995fd5d4ce2181e0a7ae.tar.gz
historical-da242a5391958bedaf0f995fd5d4ce2181e0a7ae.tar.bz2
historical-da242a5391958bedaf0f995fd5d4ce2181e0a7ae.zip
Applying panel endianess fix on ppc
Diffstat (limited to 'xfce-base/xfce4-panel')
-rw-r--r--xfce-base/xfce4-panel/ChangeLog8
-rw-r--r--xfce-base/xfce4-panel/Manifest15
-rw-r--r--xfce-base/xfce4-panel/files/getc.patch41
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild15
4 files changed, 74 insertions, 5 deletions
diff --git a/xfce-base/xfce4-panel/ChangeLog b/xfce-base/xfce4-panel/ChangeLog
index f6d9061d7f79..cf02f26fc257 100644
--- a/xfce-base/xfce4-panel/ChangeLog
+++ b/xfce-base/xfce4-panel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/xfce4-panel
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.38 2004/12/13 20:41:53 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.39 2004/12/18 18:57:24 morfic Exp $
+
+ 18 Dec 2004; Daniel Goller <morfic@gentoo.org> +files/getc.patch,
+ xfce4-panel-4.1.99.2.ebuild:
+ Applying panel endianess patch for ppc
*xfce4-panel-4.1.99.2 (13 Dec 2004)
@@ -32,7 +36,7 @@
xfce4-panel-4.0.6.ebuild:
Masked xfce4-panel-4.0.6.ebuild stable for ppc
- 07 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> xfce4-panel-4.0.6.ebuild:
+ 07 Aug 2004; Bryan Østergaard <kloeri@gentoo.org> xfce4-panel-4.0.6.ebuild:
Stable on alpha.
06 Aug 2004; Gustavo Zacarias <gustavoz@gentoo.org>
diff --git a/xfce-base/xfce4-panel/Manifest b/xfce-base/xfce4-panel/Manifest
index c4c80fb84613..5579e16b4866 100644
--- a/xfce-base/xfce4-panel/Manifest
+++ b/xfce-base/xfce4-panel/Manifest
@@ -1,6 +1,17 @@
-MD5 a936061c8fccfbd3babc9603dbdab86c xfce4-panel-4.1.99.2.ebuild 836
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 8073dcf3cdbf37cca4619fa8630c5000 xfce4-panel-4.1.99.2.ebuild 964
MD5 10ae236f5389787cb94a335590381795 xfce4-panel-4.0.6.ebuild 1028
-MD5 44cda5179a7c739d8f5d4d597b9fd7d0 ChangeLog 4793
+MD5 c672ea7a1d88691c95f5f9033292dcc2 ChangeLog 4935
MD5 c390804e060ffd11a5bbb143434b2b2d metadata.xml 157
+MD5 d855756f6b9d6b6bd7fa9752ddddac47 files/getc.patch 1153
MD5 d7e92e7bab9af83461452e7744ddb4bd files/digest-xfce4-panel-4.1.99.2 73
MD5 c2f0fe4a313f5e1c0dab8da34ca6f6ee files/digest-xfce4-panel-4.0.6 70
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBxIx7UpKYMelfdYERAkaqAJ9bV+e4yrmNpp8EB9pId0Hst7VRagCeJVtS
+y3C5sZQ7fJeoecJrlbmAlLU=
+=kSsu
+-----END PGP SIGNATURE-----
diff --git a/xfce-base/xfce4-panel/files/getc.patch b/xfce-base/xfce4-panel/files/getc.patch
new file mode 100644
index 000000000000..7777c33e0136
--- /dev/null
+++ b/xfce-base/xfce4-panel/files/getc.patch
@@ -0,0 +1,41 @@
+--- panel/main.c.orig 2004-10-06
+10:25:08.000000000 +0200
++++ panel/main.c 2004-12-14
+08:55:53.849841352 +0100
+@@ -316,7 +316,8 @@
+ const char *old_subdir, const char *old_file,
+ const char *new_subdir, const char *new_file)
+ {
+- char *old, *new, *path, c;
++ char *old, *new, *path;
++ int c;
+ FILE *r, *w;
+ GError *error = NULL;
+
+--- panel/xfce_support.c.orig 2004-11-10
+10:36:45.000000000 +0100
++++ panel/xfce_support.c 2004-12-14
+08:55:53.887835576 +0100
+@@ -194,7 +194,8 @@
+ {
+ FILE *fp;
+ FILE *bakfp;
+- char bakfile[MAXSTRLEN + 1], c;
++ char bakfile[MAXSTRLEN + 1];
++ int c;
+
+ snprintf (bakfile, MAXSTRLEN, "%s.bak", path);
+
+--- settings/xfce_settings_plugin.c.orig
+2004-12-14 08:56:28.720540200 +0100
++++ settings/xfce_settings_plugin.c
+2004-12-14 08:56:43.271328144 +0100
+@@ -100,7 +100,8 @@
+ const char *old_subdir, const char *old_file,
+ const char *new_subdir, const char *new_file)
+ {
+- char *old, *new, *path, c;
++ char *old, *new, *path;
++ int c;
+ FILE *r, *w;
+ GError *error = NULL;
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild
index 6efe19bf61ee..88ee0f21014c 100644
--- a/xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild,v 1.1 2004/12/13 20:41:53 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.1.99.2.ebuild,v 1.2 2004/12/18 18:57:24 morfic Exp $
+
+inherit eutils
DESCRIPTION="Xfce 4 panel"
HOMEPAGE="http://www.xfce.org/"
@@ -23,6 +25,17 @@ RDEPEND="virtual/x11
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_compile () {
+ unpack ${A}
+ cd ${S}
+ if use ppc ; then
+ epatch ${FILESDIR}/getc.patch
+ fi
+
+ econf
+ emake
+}
+
src_install () {
make DESTDIR=${D} install || die
dodoc ChangeLog* AUTHORS README* TODO*