summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/mythgallery/ChangeLog7
-rw-r--r--media-plugins/mythgallery/Manifest4
-rw-r--r--media-plugins/mythgallery/files/digest-mythgallery-0.111
-rw-r--r--media-plugins/mythgallery/mythgallery-0.11.ebuild61
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/Manifest4
-rw-r--r--media-plugins/mythgame/files/digest-mythgame-0.111
-rw-r--r--media-plugins/mythgame/mythgame-0.11.ebuild67
-rw-r--r--media-plugins/mythmusic/ChangeLog8
-rw-r--r--media-plugins/mythmusic/Manifest4
-rw-r--r--media-plugins/mythmusic/files/digest-mythmusic-0.111
-rw-r--r--media-plugins/mythmusic/mythmusic-0.11.ebuild77
-rw-r--r--media-plugins/mythvideo/ChangeLog8
-rw-r--r--media-plugins/mythvideo/Manifest4
-rw-r--r--media-plugins/mythvideo/files/digest-mythvideo-0.111
-rw-r--r--media-plugins/mythvideo/mythvideo-0.11.ebuild63
-rw-r--r--media-plugins/mythweather/ChangeLog7
-rw-r--r--media-plugins/mythweather/Manifest4
-rw-r--r--media-plugins/mythweather/files/digest-mythweather-0.111
-rw-r--r--media-plugins/mythweather/mythweather-0.11.ebuild40
20 files changed, 360 insertions, 10 deletions
diff --git a/media-plugins/mythgallery/ChangeLog b/media-plugins/mythgallery/ChangeLog
index 8c20337c5bd5..e575da7d3ac8 100644
--- a/media-plugins/mythgallery/ChangeLog
+++ b/media-plugins/mythgallery/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgallery
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.3 2003/08/08 05:16:47 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/ChangeLog,v 1.4 2003/08/18 18:00:55 max Exp $
+
+*mythgallery-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythgallery-0.11.ebuild:
+ Bump version to 0.11. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythgallery-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythgallery/Manifest b/media-plugins/mythgallery/Manifest
index 09987e36816e..f9edb2fd4ad6 100644
--- a/media-plugins/mythgallery/Manifest
+++ b/media-plugins/mythgallery/Manifest
@@ -1,3 +1,5 @@
+MD5 d108a1af804667dffc1c7872465f6df2 mythgallery-0.11.ebuild 1692
MD5 52bfb7cc60fe0cd218a9376e634b724d mythgallery-0.10.ebuild 1725
-MD5 f656bb8c38bbd3bbebe1d35698c02a99 ChangeLog 1346
+MD5 cdef693457802973ff52b7390f068e42 ChangeLog 1505
MD5 08ad7857fea9bfc28178d4e14aa3ae10 files/digest-mythgallery-0.10 67
+MD5 f367099e5641367ed71e682eed2243e5 files/digest-mythgallery-0.11 67
diff --git a/media-plugins/mythgallery/files/digest-mythgallery-0.11 b/media-plugins/mythgallery/files/digest-mythgallery-0.11
new file mode 100644
index 000000000000..26f97524e9ef
--- /dev/null
+++ b/media-plugins/mythgallery/files/digest-mythgallery-0.11
@@ -0,0 +1 @@
+MD5 03c4466e71b98ba1535210a3781ba952 mythgallery-0.11.tar.bz2 9981
diff --git a/media-plugins/mythgallery/mythgallery-0.11.ebuild b/media-plugins/mythgallery/mythgallery-0.11.ebuild
new file mode 100644
index 000000000000..e3d56c39dd83
--- /dev/null
+++ b/media-plugins/mythgallery/mythgallery-0.11.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgallery/mythgallery-0.11.ebuild,v 1.1 2003/08/18 18:00:55 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Gallery and slideshow module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins database/*.sql
+
+ dodoc COPYING README UPGRADING
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGallery,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/gallery.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/gallery.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 1f02dfe909aa..b71273b48fe1 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.3 2003/08/08 05:17:21 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.4 2003/08/18 18:03:40 max Exp $
+
+*mythgame-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythgame-0.11.ebuild:
+ Bump version to 0.11. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythgame-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 7a578d939f8b..9c5c6a4a10dc 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,3 +1,5 @@
+MD5 3c872516a4b019acc69a94db588fb58d mythgame-0.11.ebuild 1979
MD5 b5a65930fd5547384fa92e567bc0ee4a mythgame-0.10.ebuild 2012
-MD5 82f85b5bf0ad049ab70968a9ce694837 ChangeLog 1313
+MD5 f5a86ac164e7ed88098187d37fe7bc8b ChangeLog 1466
MD5 9b0262b1d9e5347fceb6265378d7bf2e files/digest-mythgame-0.10 65
+MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
diff --git a/media-plugins/mythgame/files/digest-mythgame-0.11 b/media-plugins/mythgame/files/digest-mythgame-0.11
new file mode 100644
index 000000000000..bf87bd15afb7
--- /dev/null
+++ b/media-plugins/mythgame/files/digest-mythgame-0.11
@@ -0,0 +1 @@
+MD5 c13dfb3a69afdd1cf954dfe91d8db6c3 mythgame-0.11.tar.bz2 50679
diff --git a/media-plugins/mythgame/mythgame-0.11.ebuild b/media-plugins/mythgame/mythgame-0.11.ebuild
new file mode 100644
index 000000000000..cbdb75d18e86
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.11.ebuild,v 1.1 2003/08/18 18:03:40 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}
diff --git a/media-plugins/mythmusic/ChangeLog b/media-plugins/mythmusic/ChangeLog
index 2a90c831f33b..db7b2cc9b521 100644
--- a/media-plugins/mythmusic/ChangeLog
+++ b/media-plugins/mythmusic/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythmusic
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/ChangeLog,v 1.4 2003/08/08 00:05:23 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/ChangeLog,v 1.5 2003/08/18 18:04:36 max Exp $
+
+*mythmusic-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythmusic-0.11.ebuild:
+ Bump version to 0.11. Change mad DEPEND to just libmad and libid3tag. Add
+ versions to some DEPENDs. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythmusic-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythmusic/Manifest b/media-plugins/mythmusic/Manifest
index 9d7c2656de35..4cfdc5e74c5a 100644
--- a/media-plugins/mythmusic/Manifest
+++ b/media-plugins/mythmusic/Manifest
@@ -1,3 +1,5 @@
+MD5 4c9260a43eaae457572d7fce820bfe87 mythmusic-0.11.ebuild 2164
MD5 a913196aeffdd80a0982ad9fb8158257 mythmusic-0.10.ebuild 2127
-MD5 c7a726b8b044b496fcaf08b738697c29 ChangeLog 1488
+MD5 a8c80b0d9412a593e61bd3c956054228 ChangeLog 1723
MD5 b8be115d97584eae89ae3cca03f7de73 files/digest-mythmusic-0.10 67
+MD5 d3782b76395f4d656284b24c9ee8e7b4 files/digest-mythmusic-0.11 67
diff --git a/media-plugins/mythmusic/files/digest-mythmusic-0.11 b/media-plugins/mythmusic/files/digest-mythmusic-0.11
new file mode 100644
index 000000000000..f4a0e354e145
--- /dev/null
+++ b/media-plugins/mythmusic/files/digest-mythmusic-0.11
@@ -0,0 +1 @@
+MD5 3c6add40f3680fd755b6011d37e6c24b mythmusic-0.11.tar.bz2 167010
diff --git a/media-plugins/mythmusic/mythmusic-0.11.ebuild b/media-plugins/mythmusic/mythmusic-0.11.ebuild
new file mode 100644
index 000000000000..0d09f9ca42d0
--- /dev/null
+++ b/media-plugins/mythmusic/mythmusic-0.11.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythmusic/mythmusic-0.11.ebuild,v 1.1 2003/08/18 18:04:37 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Music player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="opengl sdl X"
+
+DEPEND=">=media-sound/cdparanoia-3.9.8
+ >=media-libs/libmad-0.14.2b
+ >=media-libs/libid3tag-0.14.2b
+ >=media-libs/libvorbis-1.0
+ >=media-libs/libcdaudio-0.99.6
+ >=media-libs/flac-1.1.0
+ >=sys-apps/sed-4
+ X? ( dev-libs/fftw )
+ opengl? ( virtual/opengl >=dev-libs/fftw-2 )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} `use_enable X fftw`"
+ myconf="${myconf} `use_enable opengl`"
+ myconf="${myconf} `use_enable sdl`"
+
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ econf ${myconf}
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins musicdb/*.sql
+
+ dodoc AUTHORS COPYING README UPGRADING
+ newdoc musicdb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythMusic,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+}
diff --git a/media-plugins/mythvideo/ChangeLog b/media-plugins/mythvideo/ChangeLog
index 6753a0de6f14..482d587e12d6 100644
--- a/media-plugins/mythvideo/ChangeLog
+++ b/media-plugins/mythvideo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythvideo
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.2 2003/08/08 05:13:41 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/ChangeLog,v 1.3 2003/08/18 18:05:48 max Exp $
+
+*mythvideo-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythvideo-0.11.ebuild:
+ Bump version to 0.11. Add mplayer or xine-ui to RDEPEND. Change make install
+ to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythvideo-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythvideo/Manifest b/media-plugins/mythvideo/Manifest
index dfcf699ae162..637412931513 100644
--- a/media-plugins/mythvideo/Manifest
+++ b/media-plugins/mythvideo/Manifest
@@ -1,3 +1,5 @@
MD5 c941afde9a6ccac5e694cdc43db6bf52 mythvideo-0.10.ebuild 1736
-MD5 0ad2b67f0b510fcd5a979c77a8fd2e66 ChangeLog 1500
+MD5 92d55406d6084728270809054a483339 mythvideo-0.11.ebuild 1751
+MD5 15091b5845360d331b617a2faeaab467 ChangeLog 1692
MD5 bdd77fadda8f0eb40802ceb421042c18 files/digest-mythvideo-0.10 67
+MD5 1c1055ed7527e3c6e5c556e1f79456bc files/digest-mythvideo-0.11 67
diff --git a/media-plugins/mythvideo/files/digest-mythvideo-0.11 b/media-plugins/mythvideo/files/digest-mythvideo-0.11
new file mode 100644
index 000000000000..2022f315e773
--- /dev/null
+++ b/media-plugins/mythvideo/files/digest-mythvideo-0.11
@@ -0,0 +1 @@
+MD5 7825a89f31df0a4cd73541f915c409fd mythvideo-0.11.tar.bz2 198184
diff --git a/media-plugins/mythvideo/mythvideo-0.11.ebuild b/media-plugins/mythvideo/mythvideo-0.11.ebuild
new file mode 100644
index 000000000000..801db6fdd81c
--- /dev/null
+++ b/media-plugins/mythvideo/mythvideo-0.11.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythvideo/mythvideo-0.11.ebuild,v 1.1 2003/08/18 18:05:48 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Video player module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( media-video/mplayer media-video/xine-ui )
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins videodb/*.sql
+
+ dodoc COPYING README
+ newdoc videodb/README README.db
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythVideo,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "to your MythTV database."
+ einfo
+ einfo "You might run 'mysql < /usr/share/mythtv/database/${PN}/metadata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/README.db.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}
diff --git a/media-plugins/mythweather/ChangeLog b/media-plugins/mythweather/ChangeLog
index 2ac3111030ad..1a8619dafd51 100644
--- a/media-plugins/mythweather/ChangeLog
+++ b/media-plugins/mythweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythweather
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.3 2003/08/08 05:18:14 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/ChangeLog,v 1.4 2003/08/18 18:07:04 max Exp $
+
+*mythweather-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythweather-0.11.ebuild:
+ Bump version to 0.11. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythweather-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythweather/Manifest b/media-plugins/mythweather/Manifest
index 11c52c5e2297..f3f6340b5a8c 100644
--- a/media-plugins/mythweather/Manifest
+++ b/media-plugins/mythweather/Manifest
@@ -1,3 +1,5 @@
+MD5 4b853f569971fb1d6a9377987bde8394 mythweather-0.11.ebuild 973
MD5 11893933c13d93476fb961b975275cb9 mythweather-0.10.ebuild 1006
-MD5 fbb41082d39afd5ef5ece2acfc1be605 ChangeLog 1187
+MD5 633be5b82eec8d60f3cf1c5ddb5f56b6 ChangeLog 1346
MD5 09666f4a410bc5eda6781edd029505f7 files/digest-mythweather-0.10 69
+MD5 6a31e4f0a87c61e3e7f0eb55dca2f03b files/digest-mythweather-0.11 69
diff --git a/media-plugins/mythweather/files/digest-mythweather-0.11 b/media-plugins/mythweather/files/digest-mythweather-0.11
new file mode 100644
index 000000000000..0f0b4fe72b99
--- /dev/null
+++ b/media-plugins/mythweather/files/digest-mythweather-0.11
@@ -0,0 +1 @@
+MD5 22ec089fb144ef2c316b028c67d266af mythweather-0.11.tar.bz2 814175
diff --git a/media-plugins/mythweather/mythweather-0.11.ebuild b/media-plugins/mythweather/mythweather-0.11.ebuild
new file mode 100644
index 000000000000..5d6ca031daa6
--- /dev/null
+++ b/media-plugins/mythweather/mythweather-0.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythweather/mythweather-0.11.ebuild,v 1.1 2003/08/18 18:07:05 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Weather forcast module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall INSTALL_ROOT="${D}"
+ dodoc AUTHORS COPYING README
+}