summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-lmp/lc-lmp-0.5.97.ebuild')
-rw-r--r--app-leechcraft/lc-lmp/lc-lmp-0.5.97.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-leechcraft/lc-lmp/lc-lmp-0.5.97.ebuild b/app-leechcraft/lc-lmp/lc-lmp-0.5.97.ebuild
new file mode 100644
index 000000000000..a9830b89c035
--- /dev/null
+++ b/app-leechcraft/lc-lmp/lc-lmp-0.5.97.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-leechcraft/lc-lmp/lc-lmp-0.5.97.ebuild,v 1.1 2013/06/11 17:31:19 maksbotan Exp $
+
+EAPI="4"
+
+inherit leechcraft
+
+DESCRIPTION="LeechCraft Media Player, Phonon-based audio/video player."
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +graffiti kde +mpris +mp3tunes"
+
+DEPEND="~app-leechcraft/lc-core-${PV}
+ graffiti? ( media-libs/flac )
+ kde? ( media-libs/phonon )
+ !kde? ( dev-qt/qtphonon:4 )
+ media-libs/taglib
+ mpris? ( dev-qt/qtdbus:4 )
+ dev-qt/qtdeclarative:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable graffiti LMP_GRAFFITI)
+ $(cmake-utils_use_enable mpris LMP_MPRIS)
+ $(cmake-utils_use_enable mp3tunes LMP_MP3TUNES)"
+ cmake-utils_src_configure
+}