summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlite/sqlite-3.2.1-r1.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-3.2.1-r1.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-db/sqlite/sqlite-3.2.1-r1.ebuild b/dev-db/sqlite/sqlite-3.2.1-r1.ebuild
index fd0dbcf0da96..c0740c5d4600 100644
--- a/dev-db/sqlite/sqlite-3.2.1-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.2.1-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r1.ebuild,v 1.1 2005/04/02 20:11:34 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.2.1-r1.ebuild,v 1.2 2005/04/06 18:36:09 arj Exp $
inherit eutils
-IUSE="nothreadsafe"
+IUSE="nothreadsafe doc"
DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
SRC_URI="http://www.sqlite.org/${P}.tar.gz"
@@ -15,18 +15,13 @@ HOMEPAGE="http://www.sqlite.org"
# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
DEPEND="virtual/libc
!nothreadsafe? ( !ppc-macos? ( sys-libs/glibc ) )
- dev-lang/tcl"
+ doc? (dev-lang/tcl)"
SLOT="3"
LICENSE="as-is"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
src_compile() {
- # sqlite includes a doc directory making it impossible to generate docs,
- # which are very important to people adding support for sqlite3 to their
- # programs.
- rm -rf doc/
-
local myconf
myconf="--enable-incore-db --enable-tempdb-in-ram"
# Yes, this is ridiculous, but I'm not the maintainer for this ebuild,
@@ -37,9 +32,12 @@ src_compile() {
else
myconf="${myconf} --disable-threadsafe"
fi
- myconf="--with-tcl=/usr/$(get_libdir)/"
econf ${myconf} || die
- emake all || die # doc is not working yet in 3.1.2
+ emake all || die
+
+ if use doc; then
+ emake doc
+ fi
}
# In case we ever want testing support; note: this needs more work, as
@@ -56,6 +54,9 @@ src_install () {
dobin lemon
dodoc README VERSION
doman sqlite3.1
+
+ if use doc; then
docinto html
dohtml doc/*.html doc/*.txt doc/*.png
+ fi
}