summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-6.02.1-r1.ebuild50
-rw-r--r--dev-ml/camlp5/camlp5-6.02.2_p3.ebuild66
-rw-r--r--dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch23
4 files changed, 6 insertions, 140 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index b782a5cb939f..92800bd36ebd 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.56 2011/06/26 17:35:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.57 2011/07/06 18:24:55 aballier Exp $
+
+ 06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -camlp5-6.02.1-r1.ebuild,
+ -files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.pat
+ ch, -camlp5-6.02.2_p3.ebuild:
+ remove old
*camlp5-6.02.3 (26 Jun 2011)
diff --git a/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild b/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild
deleted file mode 100644
index c5270748163a..000000000000
--- a/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.02.1-r1.ebuild,v 1.1 2011/01/20 19:39:06 aballier Exp $
-
-EAPI="2"
-
-inherit multilib findlib eutils
-
-DESCRIPTION="A preprocessor-pretty-printer of ocaml"
-HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
-SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc +ocamlopt"
-
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-Fix-regression-in-pretty-printing-of-labelled-argume.patch"
-}
-
-src_configure() {
- ./configure \
- -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man || die "configure failed"
-}
-
-src_compile(){
- emake || die "emake failed"
- if use ocamlopt; then
- emake opt || die "Compiling native code programs failed"
- emake opt.opt || die "Compiling native code programs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- # findlib support
- insinto "$(ocamlfind printconf destdir)/${PN}"
- doins etc/META || die "failed to install META file for findlib support"
-
- use doc && dohtml -r doc/*
-
- dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
-}
diff --git a/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild b/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild
deleted file mode 100644
index 6340c01f442f..000000000000
--- a/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild,v 1.1 2011/04/19 18:31:25 aballier Exp $
-
-EAPI="2"
-
-inherit multilib findlib eutils
-
-MY_P=${P%_p*}
-DESCRIPTION="A preprocessor-pretty-printer of ocaml"
-HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
-SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${MY_P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
-IUSE="doc +ocamlopt"
-
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
-RDEPEND="${DEPEND}"
-
-PATCHLEVEL=${PV#*_p}
-PATCHLIST=""
-
-if [ -n "${PATCHLEVEL}" ] ; then
- for i in $(seq 1 ${PATCHLEVEL}) ; do
- SRC_URI="${SRC_URI}
- http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
- PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
- done
-fi
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- for i in ${PATCHLIST} ; do
- epatch "${DISTDIR}/${i}"
- done
-}
-
-src_configure() {
- ./configure \
- -prefix /usr \
- -bindir /usr/bin \
- -libdir /usr/$(get_libdir)/ocaml \
- -mandir /usr/share/man || die "configure failed"
-}
-
-src_compile(){
- emake || die "emake failed"
- if use ocamlopt; then
- emake opt || die "Compiling native code programs failed"
- emake opt.opt || die "Compiling native code programs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- # findlib support
- insinto "$(ocamlfind printconf destdir)/${PN}"
- doins etc/META || die "failed to install META file for findlib support"
-
- use doc && dohtml -r doc/*
-
- dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
-}
diff --git a/dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch b/dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch
deleted file mode 100644
index 56a554d5374c..000000000000
--- a/dev-ml/camlp5/files/camlp5-6.02.1-Fix-regression-in-pretty-printing-of-labelled-argume.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Stephane Glondu <steph@glondu.net>
-Date: Mon, 6 Dec 2010 11:39:34 +0100
-Subject: [PATCH] Fix regression in pretty-printing of labelled arguments
-
-Patch provided by Daniel de Rauglaudre, applied in upstream CVS.
----
- etc/pr_o.ml | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/etc/pr_o.ml b/etc/pr_o.ml
-index ad8d6b9..747e64e 100644
---- a/etc/pr_o.ml
-+++ b/etc/pr_o.ml
-@@ -2080,7 +2080,7 @@ value poly_type pc =
- value label_ipatt expr pc (p, oe) =
- match Pcaml.unvala oe with
- [ Some e -> pprintf pc "~%p:%p" patt p expr e
-- | None -> patt pc p ]
-+ | None -> pprintf pc "~%p" patt p ]
- ;
-
- EXTEND_PRINTER
---