summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/syslogger/syslogger-1.5.1.ebuild')
-rw-r--r--dev-ruby/syslogger/syslogger-1.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/syslogger/syslogger-1.5.1.ebuild b/dev-ruby/syslogger/syslogger-1.5.1.ebuild
new file mode 100644
index 000000000000..7f8a6e8fd307
--- /dev/null
+++ b/dev-ruby/syslogger/syslogger-1.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/syslogger/syslogger-1.5.1.ebuild,v 1.1 2013/07/28 20:42:14 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+# if ever needed
+#GITHUB_USER="crohr"
+#GITHUB_PROJECT="${PN}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Drop-in replacement for the standard Logger, that logs to the syslog"
+HOMEPAGE="https://github.com/crohr/syslogger"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( >=dev-ruby/rdoc-2.4.2 )"
+
+all_ruby_prepare() {
+ sed -i '/[Bb]undler/d' Rakefile || die
+}