summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/ChangeLog11
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.0.5a-r11
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.1-r11
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild81
-rw-r--r--kde-base/kdelibs/kdelibs-3.1-r1.ebuild79
5 files changed, 172 insertions, 1 deletions
diff --git a/kde-base/kdelibs/ChangeLog b/kde-base/kdelibs/ChangeLog
index 74cc30d19c0a..1fd011cd2f2e 100644
--- a/kde-base/kdelibs/ChangeLog
+++ b/kde-base/kdelibs/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kdelibs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.44 2003/01/17 20:31:28 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/ChangeLog,v 1.45 2003/01/28 12:03:59 danarmak Exp $
+
+*kdelibs-3.1-r1, kdelibs-3.0.5a-r1 (28 Jan 2003)
+
+ 28 Jan 2003; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New revisions to fix bug #7179. This part of the fix removes KDEDIRS
+ settings from kdelibs' env.d files. This is a bug/fix almost noone cares
+ about, so no need to upgrade unless you know what this is. Masked at first
+ for initial testing.
*kdelibs-2.2.2a-r1 (17 Jan 2003)
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.0.5a-r1 b/kde-base/kdelibs/files/digest-kdelibs-3.0.5a-r1
new file mode 100644
index 000000000000..d05d48bfa85c
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.0.5a-r1
@@ -0,0 +1 @@
+MD5 a3c714c7727ddc70e7c9ea6acf5e42dc kdelibs-3.0.5a.tar.bz2 7647507
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.1-r1 b/kde-base/kdelibs/files/digest-kdelibs-3.1-r1
new file mode 100644
index 000000000000..5e6b6600e866
--- /dev/null
+++ b/kde-base/kdelibs/files/digest-kdelibs-3.1-r1
@@ -0,0 +1 @@
+MD5 4b5cb94d5889134ba4e86749e6b5476c kdelibs-3.1.tar.bz2 10377330
diff --git a/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild b/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild
new file mode 100644
index 000000000000..0f0b39233cc0
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild,v 1.1 2003/01/28 12:03:59 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+DESCRIPTION="KDE $PV - base libraries needed by all kde programs"
+KEYWORDS="x86 ~ppc ~alpha ~sparc"
+HOMEPAGE="http//www.kde.org/"
+
+SLOT="3.0"
+LICENSE="GPL-2 LGPL-2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.0.5a
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for bug #7359
+
+myconf="$myconf --with-distribution=Gentoo"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+[ "$ARCH" == "x86" ] && myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ # fixes crash if kdelibs is compiled with debug and you
+ # click on "Home" button in konqueror
+ patch -p0 < ${FILESDIR}/${P}-dontcrash.diff
+ kde_sandbox_patch ${S}/kio/misc/kpac
+}
+
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+ echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/65kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/50kdedir-${PV} # number goes up with version upgrade
+
+}
+
+
diff --git a/kde-base/kdelibs/kdelibs-3.1-r1.ebuild b/kde-base/kdelibs/kdelibs-3.1-r1.ebuild
new file mode 100644
index 000000000000..8fcbb2a9a966
--- /dev/null
+++ b/kde-base/kdelibs/kdelibs-3.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.1-r1.ebuild,v 1.1 2003/01/28 12:03:59 danarmak Exp $
+inherit kde kde.org
+#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
+
+# check need for glib >=1.3.3 (we have 1.2.10 only; configure has no glib flag but searches for it)
+
+DESCRIPTION="KDE libraries needed by all kde programs"
+KEYWORDS="x86 ppc"
+HOMEPAGE="http//www.kde.org/"
+SLOT="3.1"
+LICENSE="GPL-2 LGPL-2"
+
+# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
+# DEPEND from scratch.
+DEPEND=""
+RDEPEND=""
+newdepend "sys-devel/perl
+ >=media-libs/audiofile-0.1.9
+ >=sys-apps/bzip2-1.0.1
+ >=dev-libs/libxslt-1.0.7
+ >=dev-libs/libpcre-3.5
+ >=dev-libs/libxml2-2.4.10
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
+ cups? ( >=net-print/cups-1.1.14 )
+ >=media-libs/tiff-3.5.5
+ app-admin/fam-oss
+ ~kde-base/arts-1.1.0
+ app-text/ghostscript"
+
+newdepend "/c"
+newdepend "/autotools"
+
+RDEPEND="$RDEPEND
+ app-text/sgml-common
+ cups? ( net-print/cups )
+ dev-lang/python
+ >=sys-apps/portage-2.0.36" # for #7359
+
+myconf="$myconf --with-distribution=Gentoo --enable-libfam --enable-dnotify"
+use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
+use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
+use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
+use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
+
+[ "$ARCH" == "x86" ] && myconf="$myconf --enable-fast-malloc=full"
+
+qtver-from-kdever ${PV}
+need-qt $selected_version
+
+set-kdedir $PV
+
+src_unpack() {
+
+ base_src_unpack
+ kde_sandbox_patch ${S}/kio/misc/kpac
+
+}
+
+src_install() {
+
+ kde_src_install
+
+ dohtml *.html
+
+ dodir /etc/env.d
+
+echo "PATH=${PREFIX}/bin
+ROOTPATH=${PREFIX}/sbin:${PREFIX}/bin
+LDPATH=${PREFIX}/lib
+CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/49kdelibs-${PV} # number goes down with version upgrade
+
+ echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/56kdedir-${PV} # number goes up with version upgrade
+
+}
+
+