summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch')
-rw-r--r--media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch b/media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch
new file mode 100644
index 000000000000..8d9ba5dc1cab
--- /dev/null
+++ b/media-gfx/asymptote/files/asymptote-1.43-r1-configure-ac.patch
@@ -0,0 +1,59 @@
+diff -U2 -r asymptote-1.43.orig/configure.ac asymptote-1.43/configure.ac
+--- asymptote-1.43.orig/configure.ac 2008-06-12 14:42:50.000000000 +0700
++++ asymptote-1.43/configure.ac 2008-10-03 20:15:51.000000000 +0700
+@@ -77,8 +77,14 @@
+ fi
+
+-AC_CHECK_HEADER(fftw3.h,
+- AC_CHECK_LIB([fftw3], fftw_execute,,
++AC_ARG_WITH([fftw],
++ [ --with-fftw use fftw3],
++ [with_fftw=$withval],
++ [with_fftw="no"])
++if test "$with_fftw" = "yes"; then
++AC_CHECK_HEADER([fftw3.h],
++ AC_CHECK_LIB([fftw3], [fftw_execute],,
+ AC_MSG_NOTICE([*** Could not find libfftw3: will compile without optional fast Fourier transforms. ***])),
+ AC_MSG_NOTICE([*** Header file fftw3.h not found: will compile without optional fast Fourier transforms. ***]))
++fi
+
+ GCVERSION=gc-7.1
+@@ -117,5 +123,5 @@
+ CPPFLAGS_SAVE=$CPPFLAGS
+ CPPFLAGS=$CPPFLAGS" $INCL"
+- AC_CHECK_HEADER(gc.h,
++ AC_CHECK_HEADER([gc/gc.h],
+ AC_CHECK_LIB([gc],[GC_malloc],[
+ LIBS=$LIBS"-lgc "
+@@ -182,5 +188,14 @@
+ AC_CHECK_LIB([curses], [setupterm]))
+ AC_CHECK_LIB([m], [sqrt])
+-AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler])
++
++AC_ARG_WITH(sigsegv,
++ [ --with-sigsegv use libsigsegv],
++ [with_sigsegv=$withval],
++ [with_sigsegv="no"])
++if test "$with_sigsegv" = "yes"; then
++AC_CHECK_HEADER(sigsegv.h,
++ AC_CHECK_LIB([sigsegv], [stackoverflow_install_handler]),
++ AC_MSG_NOTICE([*** Header file sigsegv.h not found ***]))
++fi
+
+ AC_CHECK_LIB([readline], [rl_completion_matches],,
+@@ -198,4 +213,9 @@
+ AC_MSG_WARN([*** Broken rpc headers; XDR support disabled ***]))
+
++AC_ARG_WITH(gsl,
++ [ --with-gsl use gsl libraries],
++ [with_gsl=$withval],
++ [with_gsl="no"])
++if test "$with_gsl" = "yes"; then
+ AC_CHECK_HEADER(gsl/gsl_sf.h,
+ AC_CHECK_LIB([gsl], gsl_sf_Si, [AC_DEFINE(HAVE_LIBGSL, 1,
+@@ -203,4 +223,5 @@
+ AC_MSG_NOTICE([*** Could not find libgsl: will compile without optional special functions. ***]),[-lgslcblas]),
+ AC_MSG_NOTICE([*** Header file gsl_sf.h not found: will compile without optional special functions. ***]))
++fi
+
+ TRIANGLE=Delaunay