summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/tse3/tse3-0.3.1-r1.ebuild')
-rw-r--r--media-libs/tse3/tse3-0.3.1-r1.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/media-libs/tse3/tse3-0.3.1-r1.ebuild b/media-libs/tse3/tse3-0.3.1-r1.ebuild
index 120223bac2e6..cdf4e57ba4ed 100644
--- a/media-libs/tse3/tse3-0.3.1-r1.ebuild
+++ b/media-libs/tse3/tse3-0.3.1-r1.ebuild
@@ -1,25 +1,21 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.3.1-r1.ebuild,v 1.1 2007/08/09 14:16:59 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.3.1-r1.ebuild,v 1.2 2008/01/09 19:25:57 drac Exp $
inherit eutils flag-o-matic libtool autotools
DESCRIPTION="TSE3 Sequencer library"
-HOMEPAGE="http://TSE3.sourceforge.net/"
-SRC_URI="mirror://sourceforge/tse3/${P}.tar.gz"
+HOMEPAGE="http://TSE3.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="amd64 ~ppc ~sparc ~x86"
IUSE="alsa oss arts"
RDEPEND="alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )"
-
-DEPEND="${RDEPEND}
- sys-devel/automake
- sys-devel/autoconf
- sys-devel/libtool"
+DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
@@ -51,12 +47,12 @@ src_compile() {
use alsa || myconf="${myconf} --without-alsa"
use oss || myconf="${myconf} --without-oss"
- econf ${myconf} || die "./configure failed"
- emake || die
+ econf ${myconf} || die "econf failed."
+ emake || die "emake failed."
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS NEWS README THANKS TODO doc/History
- dohtml doc/*.html doc/*.gif doc/*.png
+ dohtml doc/*.{html,gif,png}
}