summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.11.9.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.9.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.11.9.ebuild b/net-libs/libtorrent/libtorrent-0.11.9.ebuild
deleted file mode 100644
index 4d6403fbca94..000000000000
--- a/net-libs/libtorrent/libtorrent-0.11.9.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.9.ebuild,v 1.7 2008/02/06 20:55:41 nixnut Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
-
-IUSE="debug ipv6"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-src_compile() {
- replace-flags -Os -O2
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- $(use_enable ipv6) \
- --enable-static \
- --enable-shared \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}